aboutsummaryrefslogtreecommitdiff
path: root/shells/lshell/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-04 10:16:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-04 10:16:29 +0000
commitf2a1a5bb009e6593ed1d2716106c5afdd4a3a0d1 (patch)
treefb04189649ed19c7bc9f50a56c0100a1d548b4a7 /shells/lshell/Makefile
parent116a1b24582d9fb7e675c8b7f39d9b91fef2b6f0 (diff)
downloadports-f2a1a5bb009e6593ed1d2716106c5afdd4a3a0d1.tar.gz
ports-f2a1a5bb009e6593ed1d2716106c5afdd4a3a0d1.zip
Notes
Diffstat (limited to 'shells/lshell/Makefile')
-rw-r--r--shells/lshell/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index 3b0cadc7aef2..bc5160b63635 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -6,17 +6,13 @@
#
PORTNAME= lshell
-PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTVERSION= 0.9.6
CATEGORIES= shells
MASTER_SITES= SF
MAINTAINER= scjamorim@bsd.com.br
COMMENT= Shell environment to limited sets of commands to user's
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
USE_PYDISTUTILS= yes
USE_PYTHON= yes
@@ -24,12 +20,17 @@ SHELLS= /etc/shells
MAN1= lshell.1
+PORTDOCS= CHANGES COPYING README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g; \
+ s|share/man|${LOCALBASE}/man|g; 44d' ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}/
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
.endif
@${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
@if [ ! -f ${PREFIX}/etc/${PORTNAME}.conf ]; then \