aboutsummaryrefslogtreecommitdiff
path: root/shells/lshell
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:34:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:34:05 +0000
commitceda823a27d919b9fe2d2d3c2a79b4133bf4aeea (patch)
treeacfb7038ea9e1e3c559addaed7df09f7e95bf604 /shells/lshell
parentc4fdddbe8f522160e6b009710bac442feafbe776 (diff)
downloadports-ceda823a27d919b9fe2d2d3c2a79b4133bf4aeea.tar.gz
ports-ceda823a27d919b9fe2d2d3c2a79b4133bf4aeea.zip
Notes
Diffstat (limited to 'shells/lshell')
-rw-r--r--shells/lshell/Makefile24
-rw-r--r--shells/lshell/pkg-plist1
2 files changed, 6 insertions, 19 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index 1552581993d4..254a16c42190 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -12,31 +12,17 @@ COMMENT= Shell environment to limited sets of commands to user's
USE_PYDISTUTILS= yes
USE_PYTHON= yes
-SHELLS= /etc/shells
-
-MAN1= lshell.1
-
PORTDOCS= CHANGES COPYING README
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g; \
- s|share/man|${LOCALBASE}/man|g; 45d' ${WRKSRC}/setup.py
+ s|share/man|${MANPREFIX}/man|g; 45d' ${WRKSRC}/setup.py
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
- @if [ ! -f ${PREFIX}/etc/${PORTNAME}.conf ]; then \
- ${INSTALL_DATA} -p ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf ; \
- fi
- @${ECHO_MSG} "Updating ${SHELLS}"
- @${CP} ${SHELLS} ${SHELLS}.bak
- @(${GREP} -v ${PREFIX}/bin/${PORTNAME} ${SHELLS}.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/${PORTNAME}) > ${SHELLS}
- @${RM} ${SHELLS}.bak
+ ${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
.include <bsd.port.mk>
diff --git a/shells/lshell/pkg-plist b/shells/lshell/pkg-plist
index 4699e1a77eff..59fcc8c3e8de 100644
--- a/shells/lshell/pkg-plist
+++ b/shells/lshell/pkg-plist
@@ -1,4 +1,5 @@
bin/lshell
+man/man1/lshell.1.gz
@exec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
@unexec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
@unexec if cmp -s %D/etc/lshell.conf %D/etc/lshell.conf.sample; then rm -f %D/etc/lshell.conf; fi