aboutsummaryrefslogtreecommitdiff
path: root/shells/psh/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-10-23 23:38:12 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-10-23 23:38:12 +0000
commit1cc339cbe4f5ef9e5d009602adef511d6f590846 (patch)
treedae16ce68a2f51b77be65800980bdfad905bc778 /shells/psh/Makefile
parentc3e4a4ac675fc4fef7d50fde7f141d639095c06e (diff)
. Support staging
. Add devel/p5-Term-ReadLine-Perl as dependency, as suggested by install scripts
Notes
Notes: svn path=/head/; revision=331448
Diffstat (limited to 'shells/psh/Makefile')
-rw-r--r--shells/psh/Makefile76
1 files changed, 3 insertions, 73 deletions
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index e962c1886855..ccd838cc07c4 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= psh
PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:GREGOR
@@ -11,81 +11,11 @@ MASTER_SITE_SUBDIR= CPAN:GREGOR
MAINTAINER= garga@FreeBSD.org
COMMENT= New shell made entirely out of a Perl script
+RUN_DEPENDS= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-Term-ReadLine-Perl
+
USES= perl5
USE_PERL5= configure
SUB_FILES= pkg-install pkg-deinstall
-MAN1= psh.1 \
- pshcomplete.1 \
- pshconfig.1 \
- pshdevel.1
-MAN3= Psh::Builtins::Alias.3 \
- Psh::Builtins::Bg.3 \
- Psh::Builtins::Bind.3 \
- Psh::Builtins::Builtin.3 \
- Psh::Builtins::Cd.3 \
- Psh::Builtins::Complete.3 \
- Psh::Builtins::Delenv.3 \
- Psh::Builtins::Dirs.3 \
- Psh::Builtins::Drives.3 \
- Psh::Builtins::Exit.3 \
- Psh::Builtins::Export.3 \
- Psh::Builtins::Fallback::Env.3 \
- Psh::Builtins::Fallback::Ls.3 \
- Psh::Builtins::Fc.3 \
- Psh::Builtins::Fg.3 \
- Psh::Builtins::Firsttime.3 \
- Psh::Builtins::Forfile.3 \
- Psh::Builtins::Function.3 \
- Psh::Builtins::Hash.3 \
- Psh::Builtins::Help.3 \
- Psh::Builtins::History.3 \
- Psh::Builtins::Jobs.3 \
- Psh::Builtins::Kill.3 \
- Psh::Builtins::Modules.3 \
- Psh::Builtins::Option.3 \
- Psh::Builtins::Package.3 \
- Psh::Builtins::Printenv.3 \
- Psh::Builtins::Readline.3 \
- Psh::Builtins::Rehash.3 \
- Psh::Builtins::Rename.3 \
- Psh::Builtins::Set.3 \
- Psh::Builtins::Setenv.3 \
- Psh::Builtins::Source.3 \
- Psh::Builtins::Strategy.3 \
- Psh::Builtins::Sudo.3 \
- Psh::Builtins::Symbols.3 \
- Psh::Builtins::Theme.3 \
- Psh::Builtins::Tieopt.3 \
- Psh::Builtins::Unalias.3 \
- Psh::Builtins::Which.3 \
- Psh::Completion.3 \
- Psh::Joblist.3 \
- Psh::Locale.3 \
- Psh::Locale::Default.3 \
- Psh::OS.3 \
- Psh::OS::Win.3 \
- Psh::Parser.3 \
- Psh::PerlEval.3 \
- Psh::Strategy.3 \
- Psh::StrategyBunch.3 \
- Psh::Strategy::Auto_cd.3 \
- Psh::Strategy::Auto_resume.3 \
- Psh::Strategy::Bang.3 \
- Psh::Strategy::Brace.3 \
- Psh::Strategy::Darwin_apps.3 \
- Psh::Strategy::Debug.3 \
- Psh::Strategy::Eval.3 \
- Psh::Strategy::Executable.3 \
- Psh::Strategy::Fallback_builtin.3 \
- Psh::Strategy::Perl.3 \
- Psh::Strategy::Perlfunc.3 \
- Psh::Strategy::Perlfunc_heavy.3 \
- Psh::Strategy::Perlscript.3
-
-NO_STAGE= yes
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>