aboutsummaryrefslogtreecommitdiff
path: root/shells/psh
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 02:27:02 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 02:27:02 +0000
commitd158e99d339876e2ee8cd317b5dbb3be376999e3 (patch)
tree9d243c2fa926181e6e9280f7fb21edfd88eed55b /shells/psh
parent61ab6ea6beb5c79a6941bab54dd32e022e7f709e (diff)
downloadports-d158e99d339876e2ee8cd317b5dbb3be376999e3.tar.gz
ports-d158e99d339876e2ee8cd317b5dbb3be376999e3.zip
Notes
Diffstat (limited to 'shells/psh')
-rw-r--r--shells/psh/Makefile28
-rw-r--r--shells/psh/distinfo2
-rw-r--r--shells/psh/files/man319
-rw-r--r--shells/psh/files/patch-aa10
-rw-r--r--shells/psh/pkg-descr2
-rw-r--r--shells/psh/pkg-plist56
6 files changed, 91 insertions, 26 deletions
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index fd310560a7e0..b59a8f2077a8 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -1,31 +1,29 @@
# New ports collection makefile for: perlsh
-# Version required: 0.004pre2
+# Version required: 0.007
# Date created: 11 Dec 1999
# Whom: Will Andrews <andrews@technologist.com>
#
# $FreeBSD$
#
-DISTNAME= psh-0.004pre2
-CATEGORIES= shells
+DISTNAME= psh-${VERSION}
+PKGNAME= perlsh-${VERSION}
+CATEGORIES= shells perl5
MASTER_SITES= http://www.focusresearch.com/gregor/psh/
MAINTAINER= andrews@technologist.com
-do-build:
- @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
+VERSION= 0.007
+USE_PERL5= yes
+FETCH_BEFORE_ARGS+= -t
+MAKE_ENV+= PPREFIX="${PREFIX}"
+MAN1= psh.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-post-build:
- @${PERL} -pi -e "s/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/g" ${WRKSRC}/psh
+.include "${.CURDIR}/files/man3"
-do-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/perlsh
-.for DOC in CHANGES MANIFEST README TODO psh.NEWS pshrc test.pl psh.pod
- @${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/perlsh
-.endfor
-.endif
- @${INSTALL_SCRIPT} ${WRKSRC}/psh ${PREFIX}/bin
+do-build:
+ @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
post-install:
@${ECHO} "Updating /etc/shells"
diff --git a/shells/psh/distinfo b/shells/psh/distinfo
index 75c2db0f9e8a..64afe5342cf8 100644
--- a/shells/psh/distinfo
+++ b/shells/psh/distinfo
@@ -1 +1 @@
-MD5 (psh-0.004pre2.tar.gz) = 9b8f0ef1bd3708cb8fa4101ab4d6c1b4
+MD5 (psh-0.007.tar.gz) = caae93083d1cf5724b9e7d5864ba1d2c
diff --git a/shells/psh/files/man3 b/shells/psh/files/man3
new file mode 100644
index 000000000000..72352696c2a6
--- /dev/null
+++ b/shells/psh/files/man3
@@ -0,0 +1,19 @@
+MAN3= \
+ Psh::OS::Unix.3 \
+ Psh::Locale::French.3 \
+ Psh::Locale::Spanish.3 \
+ Psh::Joblist.3 \
+ Psh::Locale::German.3 \
+ Psh::Locale::Base.3 \
+ Psh::Completion.3 \
+ Psh::PerlEval.3 \
+ Psh::Job.3 \
+ Psh::Util.3 \
+ Psh::OS::Win.3 \
+ Psh::Locale::Italian.3 \
+ Psh::OS.3 \
+ Psh::OS::Mac.3 \
+ Psh::Locale::Default.3 \
+ Psh::Builtins.3 \
+ Psh::Parser.3 \
+ Psh::Locale::Portuguese.3
diff --git a/shells/psh/files/patch-aa b/shells/psh/files/patch-aa
new file mode 100644
index 000000000000..365334e4e1eb
--- /dev/null
+++ b/shells/psh/files/patch-aa
@@ -0,0 +1,10 @@
+--- Makefile.PL Mon Dec 27 06:11:05 1999
++++ Makefile.PL.new Sun Feb 27 22:34:55 2000
+@@ -17,6 +17,7 @@
+
+ WriteMakefile (
+ NAME => 'psh',
++ PREFIX => '${PPREFIX}',
+ VERSION_FROM => 'psh',
+ AUTHOR => 'Gregor N. Purdy (gregor@focusresearch.com)',
+ ABSTRACT => 'Perl Shell',
diff --git a/shells/psh/pkg-descr b/shells/psh/pkg-descr
index f0e2a2dfd58c..0025c8a8c1c0 100644
--- a/shells/psh/pkg-descr
+++ b/shells/psh/pkg-descr
@@ -1,4 +1,4 @@
Perl Shell is a new shell that combines the power of bash
and several other shells with the power of perl programming.
-WWW: http://www.focusresearch.com/gregor/psh/index.html
+WWW: http://www.focusresearch.com/gregor/psh/
diff --git a/shells/psh/pkg-plist b/shells/psh/pkg-plist
index ac3a1eb131e4..01d5d21d0578 100644
--- a/shells/psh/pkg-plist
+++ b/shells/psh/pkg-plist
@@ -1,10 +1,48 @@
bin/psh
-share/perlsh/CHANGES
-share/perlsh/MANIFEST
-share/perlsh/README
-share/perlsh/TODO
-share/perlsh/psh.NEWS
-share/perlsh/pshrc
-share/perlsh/test.pl
-share/perlsh/psh.pod
-@dirrm share/perlsh
+lib/perl5/site_perl/%%PERL_VER%%/Psh.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/OS/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/OS/Win.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/OS/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Joblist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Fallback/Ls.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Fallback/Env.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Readline.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Bg.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Symbols.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Fg.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Jobs.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Which.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Builtin.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Exit.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Help.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Kill.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Source.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Strategy.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Completion.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/Italian.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/Default.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/French.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/Spanish.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/German.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale/Portuguese.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/PerlEval.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy/Perlfunc.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy/Fallback_builtin.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy/Auto_resume.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy/Auto_cd.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy/Perlscript.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/OS.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Job.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Util.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Prompt.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins.pm
+lib/perl5/site_perl/%%PERL_VER%%/Psh/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/psh/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/psh
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins/Fallback
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh/Builtins
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh/Locale
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh/OS
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh/Strategy
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Psh