aboutsummaryrefslogtreecommitdiff
path: root/shells/rssh
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-05 20:12:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-05 20:12:49 +0000
commitc52df97c064c255cb26069584da008dbb700b07f (patch)
tree83e09516444d11bb7e268ef06368b15bf2a24b68 /shells/rssh
parent045dcdcadc7f9bed40543969a7aa3cc97e2e2c7e (diff)
downloadports-c52df97c064c255cb26069584da008dbb700b07f.tar.gz
ports-c52df97c064c255cb26069584da008dbb700b07f.zip
Notes
Diffstat (limited to 'shells/rssh')
-rw-r--r--shells/rssh/Makefile8
-rw-r--r--shells/rssh/pkg-plist6
2 files changed, 13 insertions, 1 deletions
diff --git a/shells/rssh/Makefile b/shells/rssh/Makefile
index a9421c80b4a4..8f368e602924 100644
--- a/shells/rssh/Makefile
+++ b/shells/rssh/Makefile
@@ -19,7 +19,6 @@ USE_REINPLACE= yes
MAN1= rssh.1
MAN5= rssh.conf.5
-PLIST_FILES= bin/rssh etc/rssh.conf.dist libexec/rssh_chroot_helper
OPTIONS= RSYNC "rsync support" off \
RDIST "rdist support" off
@@ -44,4 +43,11 @@ post-patch:
${REINPLACE_CMD} -E -e 's,(\$$\(DESTDIR\)\$$\(sysconfdir\)/\$$\$$f),\1.dist,g' \
${WRKSRC}/Makefile.in
+post-install:
+ @${ECHO_MSG} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/${PORTNAME} /etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/${PORTNAME}) > /etc/shells
+ @${RM} /etc/shells.bak
+
.include <bsd.port.post.mk>
diff --git a/shells/rssh/pkg-plist b/shells/rssh/pkg-plist
new file mode 100644
index 000000000000..4bfa5f99c1a6
--- /dev/null
+++ b/shells/rssh/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/rssh
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
+etc/rssh.conf.dist
+libexec/rssh_chroot_helper