aboutsummaryrefslogtreecommitdiff
path: root/shells/sash/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 22:36:06 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 22:36:06 +0000
commitaea575ce76589e8bcdf16cb42e58017df088fbc2 (patch)
tree5ebabb9b375ea41ab2a1978f28a8d632adf40b3b /shells/sash/Makefile
parente3a63b2d1653ce58e8d8aec94469d0aab49ec745 (diff)
downloadports-aea575ce76589e8bcdf16cb42e58017df088fbc2.tar.gz
ports-aea575ce76589e8bcdf16cb42e58017df088fbc2.zip
Notes
Diffstat (limited to 'shells/sash/Makefile')
-rw-r--r--shells/sash/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/shells/sash/Makefile b/shells/sash/Makefile
new file mode 100644
index 000000000000..1945c773ede6
--- /dev/null
+++ b/shells/sash/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sash
+# Version required: 3.4
+# Date created: Jan 22, 2000
+# Whom: Patrick Gardella <patrick@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= sash-3.4
+CATEGORIES= shells
+MASTER_SITES= http://www.pcug.org.au/~dbell/programs/ \
+ http://www.freebsd.org/~patrick/
+
+MAINTAINER= patrick@freebsd.org
+
+MAN1= sash.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sash ${PREFIX}/bin/sash
+ ${INSTALL_MAN} ${WRKSRC}/sash.1 ${PREFIX}/man/man1/sash.1
+ @${ECHO_MSG} "------------------"
+ @${ECHO_MSG} "Installing into ${PREFIX}/bin"
+ @${ECHO_MSG} "If you want this installed elsewhere, "
+ @${ECHO_MSG} "set the environmental variable PREFIX"
+ @${ECHO_MSG} "------------------"
+
+post-install:
+ @${ECHO_MSG} "Updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/sash /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/sash) > /etc/shells
+ @${RM} /etc/shells.bak
+ strip ${PREFIX}/bin/sash
+
+.include <bsd.port.mk>