aboutsummaryrefslogtreecommitdiff
path: root/shells/scponly/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-17 13:02:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-17 13:02:01 +0000
commit66424cf8d337a04ed35e4ec9d122bc809f381951 (patch)
treee8e96dd41e5380bd701781c16eb8971df29df5ed /shells/scponly/Makefile
parent2bff5b1ac3f041be3e142eb53b2c726f9c213432 (diff)
Notes
Diffstat (limited to 'shells/scponly/Makefile')
-rw-r--r--shells/scponly/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 3f75a17cd3b4..577735723bb2 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -39,6 +39,10 @@
# default: undefined
# define if you want to enable rsync compatibility.
#
+# WITH_SCPONLY_UNISON
+# default: undefined
+# define if you want to enable unison compatibility.
+#
#
# Additional knobs:
#
@@ -49,7 +53,7 @@
# to be installed.
PORTNAME= scponly
-PORTVERSION= 3.9
+PORTVERSION= 3.11
PORTREVISION= 0
CATEGORIES= shells
MASTER_SITES= http://www.sublimation.org/scponly/
@@ -84,8 +88,6 @@ CONFIGURE_ARGS+=--disable-winscp-compat
.if defined(WITH_SCPONLY_CHROOT)
PLIST_SUB= SCPONLY_CHROOT=""
CONFIGURE_ARGS+=--enable-chrooted-binary
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ab
-USE_AUTOCONF_VER=253
.endif
.if defined(WITH_SCPONLY_RSYNC)
@@ -94,6 +96,12 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
CONFIGURE_ARGS+=--enable-rsync-compat
.endif
+.if defined(WITH_SCPONLY_UNISON)
+BUILD_DEPENDS+= unison:${PORTSDIR}/net/unison
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+CONFIGURE_ARGS+=--enable-unison-compat
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can enable chroot functionality by defining WITH_SCPONLY_CHROOT."