aboutsummaryrefslogtreecommitdiff
path: root/shells/scponly/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-15 07:12:02 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-15 07:12:02 +0000
commitf08bff30cbd36fec3f2c046dee1afd2c319d52fc (patch)
tree2e04a73544ce815b7900d9726a3bd4cb9c536ef0 /shells/scponly/Makefile
parent6cddd349b090c246fbb130e7d6f5ce385bd845c7 (diff)
downloadports-f08bff30cbd36fec3f2c046dee1afd2c319d52fc.tar.gz
ports-f08bff30cbd36fec3f2c046dee1afd2c319d52fc.zip
Notes
Diffstat (limited to 'shells/scponly/Makefile')
-rw-r--r--shells/scponly/Makefile92
1 files changed, 15 insertions, 77 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 953a4b190f5e..4b9a8a647ff4 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -5,76 +5,11 @@
# $FreeBSD$
#
-# There are many knobs to tune scponly towards your specific wishes
-# and preferences.
-# You can activate a knob by typing something like
-# "make -DKNOB" or "make KNOB=yes" instead of just "make"
-#
-# A description of the several possibilities is available here:
-#
-#
-# Core funcionality:
-#
-# SCPONLY_DEFAULT_CHDIR=DIR
-# default: undefined
-# example: public_html
-# define if you want to make users `cd' to this directory after authentication
-#
-# WITHOUT_SCPONLY_WILDCARDS
-# default: undefined
-# define if you want to disable wildcard processing.
-#
-# WITHOUT_SCPONLY_GFTP
-# default: undefined
-# define if you want to disable gftp compatibility.
-#
-# WITH_SCPONLY_CHROOT
-# default: undefined
-# define if you want to use chroot functionality (set UID to root).
-#
-# WITH_SCPONLY_RSYNC
-# default: undefined
-# define if you want to enable rsync compatibility.
-#
-# WITH_SCPONLY_SCP
-# default: undefined
-# define if you want to enable vanilla scp compatibility.
-#
-# WITH_SCPONLY_SFTP_LOGGING
-# default: undefined
-# define if you want to enable sftp logging compatibility.
-#
-# WITH_SCPONLY_SVN
-# default: undefined
-# define if you want to enable subversion compatibility.
-#
-# WITH_SCPONLY_SVNSERVE
-# default: undefined
-# define if you want to enable subversion compatibility with svn+ssh://
-#
-# WITH_SCPONLY_UNISON
-# default: undefined
-# define if you want to enable unison compatibility.
-#
-# WITH_SCPONLY_WINSCP
-# default: undefined
-# define if you want to enable WinSCP compatibility.
-#
-#
-# Additional knobs:
-#
-# NOPORTDOCS
-# default: undefined
-# This knob prevents the ports system from installing additional
-# documentation. If you define this, only the manpage is going
-# to be installed.
-
PORTNAME= scponly
PORTVERSION= 4.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells security
-MASTER_SITES= http://www.sublimation.org/scponly/ \
- SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= rfarmer@predatorlabs.net
@@ -82,6 +17,8 @@ COMMENT= A tiny shell that only permits scp and sftp
MAN8= scponly.8
+PORTDOCS= BUILDING-JAILS.TXT INSTALL README SECURITY
+
GNU_CONFIGURE= yes
OPTIONS= SCPONLY_WILDCARDS "wildcards processing" on \
@@ -153,14 +90,10 @@ CONFIGURE_ARGS+=--enable-unison-compat
CONFIGURE_ARGS+=--enable-winscp-compat
.endif
-pre-everything::
- @${ECHO_MSG} "From scponly 4.2, scp & WinSCP compatibilities are not"
- @${ECHO_MSG} "enabled by default. To enable those compatibilities,"
- @${ECHO_MSG} "define WITH_SCPONLY_SCP and/or WITH_SCPONLY_WINSCP,"
- @${ECHO_MSG} "respectively."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can enable chroot functionality by defining WITH_SCPONLY_CHROOT."
- @${ECHO_MSG} ""
+post-patch:
+ @${ECHO_MSG} "In addition to knobs available from the OPTIONS dialog,"
+ @${ECHO_MSG} "you may set SCPONLY_DEFAULT_CHDIR to make users 'cd' to"
+ @${ECHO_MSG} "this directory after authentication."
post-install:
@${ECHO_MSG} "Updating /etc/shells"
@@ -180,14 +113,19 @@ post-install:
@${ECHO_MSG} "To setup chroot cage, run the following commands:"
@${ECHO_MSG} " 1) cd ${EXAMPLESDIR}/ && ${SH} setup_chroot.sh"
@${ECHO_MSG} " 2) Set scponlyc_enable=\"YES\" in /etc/rc.conf"
- @${ECHO_MSG} " 3) Run ${LOCALBASE}/etc/rc.d/scponly start"
+ @${ECHO_MSG} " 3) Run ${PREFIX}/etc/rc.d/scponly start"
@${ECHO_MSG} ""
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for i in README INSTALL TODO
+.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
.endfor
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "For information on several potential security concerns,"
+ @${ECHO_MSG} "please read:"
+ @${ECHO_MSG} "${DOCSDIR}/SECURITY"
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.post.mk>