aboutsummaryrefslogtreecommitdiff
path: root/shells/scponly/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-04-17 18:40:51 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-04-17 18:40:51 +0000
commit6a246b2a897f7fa24b2c7e7175c2fcd4e4ca5c8d (patch)
treec40d2908ba7169f8fa3d9363cebec8683a46e9e8 /shells/scponly/Makefile
parent3200ccffb37a6e881c195307f54621e0fc36546f (diff)
downloadports-6a246b2a897f7fa24b2c7e7175c2fcd4e4ca5c8d.tar.gz
ports-6a246b2a897f7fa24b2c7e7175c2fcd4e4ca5c8d.zip
Notes
Diffstat (limited to 'shells/scponly/Makefile')
-rw-r--r--shells/scponly/Makefile88
1 files changed, 84 insertions, 4 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 0fbe591ffd25..99e2fb09cfd8 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -5,17 +5,97 @@
# $FreeBSD$
#
+# There are many knobs to tune scponly towards your specific wishes
+# and preferences.
+# You can activate a knob by typing something like
+# "make -DKNOB" or "make KNOB=yes" instead of just "make"
+#
+# A description of the several possibilities is available here:
+#
+#
+# Core funcionality:
+#
+# WITH_SCPONLY_WILDCARDS
+# default: undefined
+# define if you want to enable wildcard processing.
+#
+# WITH_SCPONLY_SCP
+# default: undefined
+# define if you want to enable vanilla scp compatibility.
+#
+# WITH_SCPONLY_GFTP
+# default: undefined
+# define if you want to enable gftp compatibility.
+#
+# WITH_SCPONLY_WINSCP
+# default: undefined
+# define if you want to enable WinSCP compatibility.
+#
+# WITH_SCPONLY_RSYNC
+# default: undefined
+# define if you want to enable rsync compatibility.
+#
+#
+# Additional knobs:
+#
+# NOPORTDOCS
+# default: undefined
+# This knob prevents the ports system from installing additional
+# documentation. If you define this, only the manpage is going
+# to be installed.
+
PORTNAME= scponly
-PORTVERSION= 3.4
+PORTVERSION= 3.7
CATEGORIES= shells
MASTER_SITES= http://www.sublimation.org/scponly/
EXTRACT_SUFX= .tgz
MAINTAINER= mcglk@artlogix.com
-COMMENT= A tiny shell which only permits scp and sftp
+COMMENT= A tiny shell that only permits scp and sftp
-MAN8= scponly.8
+MAN8= scponly.8
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-chrooted-binary
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SCPONLY_WILDCARDS)
+CONFIGURE_ARGS+=--enable-wildcards
+.else
+CONFIGURE_ARGS+=--disable-wildcards
+.endif
+
+.if defined(WITH_SCPONLY_SCP)
+CONFIGURE_ARGS+=--enable-scp-compat
+.else
+CONFIGURE_ARGS+=--disable-scp-compat
+.endif
+
+.if defined(WITH_SCPONLY_GFTP)
+CONFIGURE_ARGS+=--enable-gftp
+.else
+CONFIGURE_ARGS+=--disable-gftp
+.endif
+
+.if defined(WITH_SCPONLY_WINSCP)
+CONFIGURE_ARGS+=--enable-winscp-compat
+.else
+CONFIGURE_ARGS+=--disable-winscp-compat
+.endif
+
+.if defined(WITH_SCPONLY_RSYNC) && exists(${LOCALBASE}/bin/rsync)
+CONFIGURE_ARGS+=--enable-rsync-compat
+.else
+CONFIGURE_ARGS+=--disable-rsync-compat
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/scponly
+.for i in README INSTALL TODO
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/scponly
+.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>