aboutsummaryrefslogtreecommitdiff
path: root/shells/shell-include
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-20 21:36:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-20 21:36:35 +0000
commitc8a7494f7e1757230a1138fed9222b97959b2789 (patch)
tree0bf3f96322b111ad07c39f439336a54a9e3633e4 /shells/shell-include
parent1fa26157d13e9d74807c293c3efd0b3f1fdb3d33 (diff)
downloadports-c8a7494f7e1757230a1138fed9222b97959b2789.tar.gz
ports-c8a7494f7e1757230a1138fed9222b97959b2789.zip
Notes
Diffstat (limited to 'shells/shell-include')
-rw-r--r--shells/shell-include/Makefile39
-rw-r--r--shells/shell-include/distinfo3
-rw-r--r--shells/shell-include/pkg-descr9
-rw-r--r--shells/shell-include/pkg-plist9
4 files changed, 60 insertions, 0 deletions
diff --git a/shells/shell-include/Makefile b/shells/shell-include/Makefile
new file mode 100644
index 000000000000..803394e15626
--- /dev/null
+++ b/shells/shell-include/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: qar-bufo
+# Date created: 18 April 2007
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= shell-include
+PORTVERSION= 0.1.1
+CATEGORIES= shells devel
+MASTER_SITES= http://vvelox.net/src/shell-include/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A include system for shell scripts
+
+USE_PERL5= yes
+
+MAN3= random::shortIntRandom.3 \
+ random.3 \
+ fileGetLine.3
+
+MAN7= shell-include.7
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+#nothing to configure
+do-configure:
+ @${ECHO} -n
+
+#nothing to build
+do-build:
+ @${ECHO} -n
+
+do-install:
+ @${EXEC} cd ${WRKDIR}/${PORTNAME}/ ; ${WRKDIR}/${PORTNAME}/install ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/shells/shell-include/distinfo b/shells/shell-include/distinfo
new file mode 100644
index 000000000000..f4a0dfb62516
--- /dev/null
+++ b/shells/shell-include/distinfo
@@ -0,0 +1,3 @@
+MD5 (shell-include-0.1.1.tgz) = 2a08625a72c118fb4040e087e5f61a29
+SHA256 (shell-include-0.1.1.tgz) = fac3ae3e9b05dbefc9ddb01c6dffbbbd118428ec3a6b256fb124616bfb73052d
+SIZE (shell-include-0.1.1.tgz) = 4039
diff --git a/shells/shell-include/pkg-descr b/shells/shell-include/pkg-descr
new file mode 100644
index 000000000000..4fab44fa15ba
--- /dev/null
+++ b/shells/shell-include/pkg-descr
@@ -0,0 +1,9 @@
+Allows include files to be used in shells the same way they are with C.
+The file with the include code needs to be included. This is done by
+figuring out were it is located using which. . `which sh-include` will
+take care of it for sh.
+
+sh example...
+. `which sh-include`
+include fileGetLine
+line=`fileGetLine /etc/group 4`
diff --git a/shells/shell-include/pkg-plist b/shells/shell-include/pkg-plist
new file mode 100644
index 000000000000..3e4fe5e85fe5
--- /dev/null
+++ b/shells/shell-include/pkg-plist
@@ -0,0 +1,9 @@
+bin/sh-include
+bin/bash-include
+libexec/shell-include/sh/random
+libexec/shell-include/sh/fileGetLine
+@dirrm libexec/shell-include/sh
+libexec/shell-include/bash/random
+libexec/shell-include/bash/fileGetLine
+@dirrm libexec/shell-include/bash
+@dirrm libexec/shell-include