aboutsummaryrefslogtreecommitdiff
path: root/shells/tcsh
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1996-12-16 01:40:25 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1996-12-16 01:40:25 +0000
commitd88d277609e1882592913b0df6bdb38185c47070 (patch)
treeaaa6d353c1b5676231aa09f226f77c6d33fce2c5 /shells/tcsh
parent71674f98e656878693b23a372e41be792bd0a770 (diff)
downloadports-d88d277609e1882592913b0df6bdb38185c47070.tar.gz
ports-d88d277609e1882592913b0df6bdb38185c47070.zip
Notes
Diffstat (limited to 'shells/tcsh')
-rw-r--r--shells/tcsh/Makefile19
-rw-r--r--shells/tcsh/distinfo2
-rw-r--r--shells/tcsh/files/patch-ad16
-rw-r--r--shells/tcsh/pkg-plist1
4 files changed, 24 insertions, 14 deletions
diff --git a/shells/tcsh/Makefile b/shells/tcsh/Makefile
index 9b93cf61e399..9fe099256440 100644
--- a/shells/tcsh/Makefile
+++ b/shells/tcsh/Makefile
@@ -1,17 +1,20 @@
# New ports collection makefile for: tcsh
-# Version required: 6.06
+# Version required: 6.07.02
# Date created: 22 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.14 1996/11/18 11:39:56 asami Exp $
+# $Id: Makefile,v 1.15 1996/11/18 14:13:54 asami Exp $
#
-DISTNAME= tcsh-6.06
+PKGNAME= tcsh-6.07.02
+DISTNAME= tcsh-6.07
CATEGORIES= shells
-MASTER_SITES= ftp://ee.cornell.edu/pub/tcsh/
+MASTER_SITES= ftp://ftp.deshaw.com/pub/tcsh/
MAINTAINER= ache@FreeBSD.ORG
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PKGNAME}
ALL_TARGET= all catalogs
INSTALL_TARGET= install install.man
MAN1= tcsh.1
@@ -19,13 +22,15 @@ MAN1= tcsh.1
post-install:
chown bin.bin ${PREFIX}/bin/tcsh
chown bin.bin ${PREFIX}/man/man1/tcsh.1
- cd ${WRKSRC}; install -c -o bin -g bin -m 444 tcsh.C.cat ${PREFIX}/share/nls/C/tcsh.cat
- cd ${WRKSRC}; install -c -o bin -g bin -m 444 tcsh.french.cat ${PREFIX}/share/nls/fr_FR.ISO_8859-1/tcsh.cat
+ cd ${WRKSRC}; ${INSTALL_DATA} tcsh.C.cat ${PREFIX}/share/nls/C/tcsh.cat
+ cd ${WRKSRC}; ${INSTALL_DATA} tcsh.french.cat ${PREFIX}/share/nls/fr_FR.ISO_8859-1/tcsh.cat
ln -sf ${PREFIX}/share/nls/fr_FR.ISO_8859-1/tcsh.cat ${PREFIX}/share/nls/fr_BE.ISO_8859-1/tcsh.cat
ln -sf ${PREFIX}/share/nls/fr_FR.ISO_8859-1/tcsh.cat ${PREFIX}/share/nls/fr_CA.ISO_8859-1/tcsh.cat
ln -sf ${PREFIX}/share/nls/fr_FR.ISO_8859-1/tcsh.cat ${PREFIX}/share/nls/fr_CH.ISO_8859-1/tcsh.cat
- cd ${WRKSRC}; install -c -o bin -g bin -m 444 tcsh.german.cat ${PREFIX}/share/nls/de_DE.ISO_8859-1/tcsh.cat
+ cd ${WRKSRC}; ${INSTALL_DATA} tcsh.german.cat ${PREFIX}/share/nls/de_DE.ISO_8859-1/tcsh.cat
ln -sf ${PREFIX}/share/nls/de_DE.ISO_8859-1/tcsh.cat ${PREFIX}/share/nls/de_AT.ISO_8859-1/tcsh.cat
ln -sf ${PREFIX}/share/nls/de_DE.ISO_8859-1/tcsh.cat ${PREFIX}/share/nls/de_CH.ISO_8859-1/tcsh.cat
+ install -d -o ${BINOWN} -g ${BINGRP} -m 755 ${PREFIX}/share/nls/el_GR.ISO_8859-7
+ cd ${WRKSRC}; ${INSTALL_DATA} tcsh.greek.cat ${PREFIX}/share/nls/el_GR.ISO_8859-7/tcsh.cat
.include <bsd.port.mk>
diff --git a/shells/tcsh/distinfo b/shells/tcsh/distinfo
index 597ad2c208c3..87e4635683bf 100644
--- a/shells/tcsh/distinfo
+++ b/shells/tcsh/distinfo
@@ -1 +1 @@
-MD5 (tcsh-6.06.tar.gz) = 3577853dce2671874a2cf0282c2e93e3
+MD5 (tcsh-6.07.tar.gz) = 18a9d8091c6da38ebdd63ab509324eb5
diff --git a/shells/tcsh/files/patch-ad b/shells/tcsh/files/patch-ad
index b5217d0cde2c..490b9f6b044b 100644
--- a/shells/tcsh/files/patch-ad
+++ b/shells/tcsh/files/patch-ad
@@ -1,25 +1,29 @@
-*** glob.c.orig Sun May 14 00:49:21 1995
---- glob.c Thu Oct 31 18:04:28 1996
+*** glob.c.orig Sat Nov 13 03:40:56 1993
+--- glob.c Mon Dec 16 03:09:07 1996
***************
*** 139,144 ****
---- 139,161 ----
+--- 139,165 ----
#define M_SET META('[')
#define ismeta(c) (((c)&M_META) != 0)
+ int collate_range_cmp (c1, c2)
+ int c1, c2;
+ {
++ #if defined(NLS) && defined(LC_COLLATE)
+ static char s1[2], s2[2];
+ int ret;
++ #endif
+
-+ c1 &= UCHAR_MAX;
-+ c2 &= UCHAR_MAX;
++ c1 &= 0xFF;
++ c2 &= 0xFF;
++ #if defined(NLS) && defined(LC_COLLATE)
+ if (c1 == c2)
+ return (0);
+ s1[0] = c1;
+ s2[0] = c2;
+ if ((ret = strcoll(s1, s2)) != 0)
+ return (ret);
++ #endif
+ return (c1 - c2);
+ }
+
@@ -35,7 +39,7 @@
ok = 1;
pat += 2;
}
---- 663,671 ----
+--- 667,675 ----
++pat;
while (((c = *pat++) & M_MASK) != M_END) {
if ((*pat & M_MASK) == M_RNG) {
diff --git a/shells/tcsh/pkg-plist b/shells/tcsh/pkg-plist
index c9b672abdca5..d060882a38ac 100644
--- a/shells/tcsh/pkg-plist
+++ b/shells/tcsh/pkg-plist
@@ -10,3 +10,4 @@ share/nls/fr_FR.ISO_8859-1/tcsh.cat
share/nls/de_DE.ISO_8859-1/tcsh.cat
@exec ln -fs %D/%F %D/share/nls/de_AT.ISO_8859-1/tcsh.cat
@exec ln -fs %D/%F %D/share/nls/de_CH.ISO_8859-1/tcsh.cat
+share/nls/el_GR.ISO_8859-7/tcsh.cat