aboutsummaryrefslogtreecommitdiff
path: root/shells/vshnu/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-25 19:35:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-25 19:35:33 +0000
commit4dda97dc3613443de815969c029fc8183a56e2da (patch)
tree5d3700a1f93580b1ac9eb844e5925aa40676db5a /shells/vshnu/Makefile
parent9f044fc5278661c505318c255149895b145e2faa (diff)
Notes
Diffstat (limited to 'shells/vshnu/Makefile')
-rw-r--r--shells/vshnu/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/shells/vshnu/Makefile b/shells/vshnu/Makefile
new file mode 100644
index 000000000000..58a4f25a4784
--- /dev/null
+++ b/shells/vshnu/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: vshnu
+# Date created: Feb 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vshnu
+PORTVERSION= 1.0005
+CATEGORIES= shells
+MASTER_SITES= http://www.cs.indiana.edu/hyplan/kinzler/vshnu/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+.include <bsd.port.pre.mk>
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Term/Screen.pm:${PORTSDIR}/devel/p5-Term-Screen
+
+# perl 5.6.0
+.if ${OSVERSION} < 500007
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+.endif
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.post.mk>