aboutsummaryrefslogtreecommitdiff
path: root/shells/wapsh/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-06-17 17:52:33 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-06-17 17:52:33 +0000
commit00b40eca21c7c87360147657652efa83e8fdd17c (patch)
treed4c27ad0eb169d157bc9663c36016cb7f337ea6f /shells/wapsh/Makefile
parentdf0e95a57c96b706df462256af4172f4de9162b1 (diff)
downloadports-00b40eca21c7c87360147657652efa83e8fdd17c.tar.gz
ports-00b40eca21c7c87360147657652efa83e8fdd17c.zip
Notes
Diffstat (limited to 'shells/wapsh/Makefile')
-rw-r--r--shells/wapsh/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index f503184e9af3..81f7dac81f77 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -54,7 +54,11 @@ do-install:
${MKDIR} ${PREFIX}/etc/wapsh
.for C in htsh_profile htshd.conf loginhosts
- ${INSTALL_DATA} ${WRKSRC}/sample/$C ${PREFIX}/etc/wapsh
+ ${INSTALL_DATA} ${WRKSRC}/sample/$C ${PREFIX}/etc/wapsh/$C.dist
+ if [ ! -e ${PREFIX}/etc/wapsh/$C ]; then \
+ ${CP} ${PREFIX}/etc/wapsh/$C.dist \
+ ${PREFIX}/etc/wapsh/$C; \
+ fi
.endfor
${MKDIR} ${PREFIX}/share/wapsh/htdocs