aboutsummaryrefslogtreecommitdiff
path: root/shells/wapsh
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-18 20:29:21 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-18 20:29:21 +0000
commitb18e5f4f22c012c2a912d806dec859fc0ad8b2f9 (patch)
tree9d6186a3e82909512a140279b1e157359fd6529e /shells/wapsh
parenta9eb0f55e5c7d078d4fbbf37cf99ab9b1a372797 (diff)
downloadports-b18e5f4f22c012c2a912d806dec859fc0ad8b2f9.tar.gz
ports-b18e5f4f22c012c2a912d806dec859fc0ad8b2f9.zip
Notes
Diffstat (limited to 'shells/wapsh')
-rw-r--r--shells/wapsh/Makefile28
-rw-r--r--shells/wapsh/files/patch-htshd::htshd.c80
-rw-r--r--shells/wapsh/pkg-descr3
-rw-r--r--shells/wapsh/pkg-message1
-rw-r--r--shells/wapsh/pkg-plist168
5 files changed, 171 insertions, 109 deletions
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index 30eb8e0388f3..f82da143f9cb 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -5,11 +5,11 @@
# $FreeBSD$
#
-PORTNAME= wapsh
+PORTNAME= wapsh
PORTVERSION= 1.0
PORTREVISION= 1
-CATEGORIES= shells
-MASTER_SITES= http://www.exolution.de/wapsh/
+CATEGORIES= shells
+MASTER_SITES= http://www.exolution.de/wapsh/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -42,12 +42,6 @@ HTDOCS= command.php command_html.inc command_wml.inc \
login_html.php login_wml.php scroll_wml.php \
shortcuts_wml.php
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > ${WRKDIR}/foo && \
${MV} ${WRKDIR}/foo ${WRKSRC}/htshd/htshd.c
@@ -74,21 +68,21 @@ do-install:
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/wapsh/admin_guide
- ${MKDIR} ${PREFIX}/share/doc/wapsh/implementation_notes
- ${MKDIR} ${PREFIX}/share/doc/wapsh/user_guide
+ ${MKDIR} ${DOCSDIR}/admin_guide
+ ${MKDIR} ${DOCSDIR}/implementation_notes
+ ${MKDIR} ${DOCSDIR}/user_guide
.for B in Image1.jpg Image2.jpg Image3.jpg index.html qpl.html
- ${INSTALL_DATA} ${WRKSRC}/docs/html/$B ${PREFIX}/share/doc/wapsh
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/$B ${DOCSDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/docs/html/admin_guide/index.html \
- ${PREFIX}/share/doc/wapsh/admin_guide
+ ${DOCSDIR}/admin_guide
.for I in index.html image57.gif
${INSTALL_DATA} ${WRKSRC}/docs/html/implementation_notes/$I \
- ${PREFIX}/share/doc/wapsh/implementation_notes
+ ${DOCSDIR}/implementation_notes
.endfor
.for U in ${USERGUIDEDOCS}
${INSTALL_DATA} ${WRKSRC}/docs/html/user_guide/$U \
- ${PREFIX}/share/doc/wapsh/user_guide
+ ${DOCSDIR}/user_guide
.endfor
.endif #if !defined(NOPORTDOCS)
@@ -102,4 +96,4 @@ post-install:
fi
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/wapsh/files/patch-htshd::htshd.c b/shells/wapsh/files/patch-htshd::htshd.c
index 712c7dc7821e..48b1a6a49edf 100644
--- a/shells/wapsh/files/patch-htshd::htshd.c
+++ b/shells/wapsh/files/patch-htshd::htshd.c
@@ -1,15 +1,87 @@
---- htshd/htshd.c.orig Sat Jan 13 17:35:54 2001
-+++ htshd/htshd.c Sat Jan 13 17:36:18 2001
+--- htshd/htshd.c.orig Fri Nov 24 15:46:01 2000
++++ htshd/htshd.c Tue Nov 18 18:03:33 2003
@@ -97,10 +97,10 @@
#define SERVICE_NAME "htsh" /* Should be in /etc/services
on login and http server hosts */
-#define CONFIG_FILE "/etc/htshd.conf"
-+#define CONFIG_FILE "%%PREFIX%%/etc/wapsh/htshd.conf"
++#define CONFIG_FILE "/usr/local/etc/wapsh/htshd.conf"
/* Default name of startup config file */
-#define GLOBAL_RC_FILE "/etc/htsh_profile"
-+#define GLOBAL_RC_FILE "%%PREFIX%%/etc/wapsh/htsh_profile"
++#define GLOBAL_RC_FILE "/usr/local/etc/wapsh/htsh_profile"
/* Default name of global user
initialisation file */
#define RCFILE ".htshrc" /* Name of user-specific initialisation file
+@@ -3572,39 +3572,38 @@
+ usage(void)
+ {
+ if (!weAreDaemon) {
+- fprintf(stderr,
+-"htsh options are:
+--b numbytes Specify upper limit for per-user shell output buffers
+- (Default: %d bytes)
+--c numbytes Maximum number of bytes to be transferred at a time
+- between Client Shell and HTTP Server.
+- (Default: %d bytes, minimum setting %d bytes)
+--d Run in debug mode
+--D [y|n] If argument is 'y' run as daemon, otherwise ('n')
+- do not daemonise.
+- (If run from inetd, htsh is always a daemon. If run from a
+- shell, htsh is a daemon by default)
+--f config-file Use named file for startup configuration, instead of %s
+--F Do not use standard configuration file (%s)
+--h Display this help message
+--g global-init-file Use named file as login initialisation file for all user
+- logins. (Default: %s)
+--H http-server Specify HTTP server from which connections will
+- be accepted. (Can be specified multiple times)
+--L log-file-dir Record script(1) style log of each login session
+- in named directory
+--o numsecs Timeout for shell output (Default: %3.1f seconds,
+- minimum: %3.1f, maximum: %4.1f seconds)
+--p port-num Specify TCP port on which htsh should listen for
+- connections. (Default is %s in /etc/services)
+--P 'proto-name... ' Specify list of allowed login protocols
+- (can be '%s' and or '%s'
+--t numsecs Timeout for shell input (Default: %d seconds)
+--u username Specify user who is allowed to login to htsh
+- (Can be repeated multiple times)
+-
+-The -c, -D, -o, -p, and -t options override corresponding options in the
+-configuration file. The -h and -u options are additive with corresponding
++ fprintf(stderr, "htsh options are: \n\
++-b numbytes Specify upper limit for per-user shell output buffers \n\
++ (Default: %d bytes)\n\
++-c numbytes Maximum number of bytes to be transferred at a time \n\
++ between Client Shell and HTTP Server. \n\
++ (Default: %d bytes, minimum setting %d bytes)\n\
++-d Run in debug mode\n\
++-D [y|n] If argument is 'y' run as daemon, otherwise ('n')\n\
++ do not daemonise. \n\
++ (If run from inetd, htsh is always a daemon. If run from a \n\
++ shell, htsh is a daemon by default)\n\
++-f config-file Use named file for startup configuration, instead of %s\n\
++-F Do not use standard configuration file (%s)\n\
++-h Display this help message\n\
++-g global-init-file Use named file as login initialisation file for all user\n\
++ logins. (Default: %s)\n\
++-H http-server Specify HTTP server from which connections will \n\
++ be accepted. (Can be specified multiple times)\n\
++-L log-file-dir Record script(1) style log of each login session\n\
++ in named directory\n\
++-o numsecs Timeout for shell output (Default: %3.1f seconds, \n\
++ minimum: %3.1f, maximum: %4.1f seconds)\n\
++-p port-num Specify TCP port on which htsh should listen for \n\
++ connections. (Default is %s in /etc/services)\n\
++-P 'proto-name... ' Specify list of allowed login protocols \n\
++ (can be '%s' and or '%s'\n\
++-t numsecs Timeout for shell input (Default: %d seconds)\n\
++-u username Specify user who is allowed to login to htsh\n\
++ (Can be repeated multiple times)\n\
++\n\
++The -c, -D, -o, -p, and -t options override corresponding options in the\n\
++configuration file. The -h and -u options are additive with corresponding\n\
+ options in the configuration file\n",
+ DEF_OUTPUT_BUFFER_LIMIT,
+ DEF_CS_MAX_TRANSFER_SIZE, CS_MAX_TRANSFER_SIZE_LOW_BOUND,
diff --git a/shells/wapsh/pkg-descr b/shells/wapsh/pkg-descr
index 7d2046a5caee..1ce365b09854 100644
--- a/shells/wapsh/pkg-descr
+++ b/shells/wapsh/pkg-descr
@@ -12,6 +12,3 @@ htsh:
We welcome feedback (at wapsh@exolution.de) from users about their
experiences using other phone types.
-
-- George Reid
-greid@ukug.uk.freebsd.org
diff --git a/shells/wapsh/pkg-message b/shells/wapsh/pkg-message
index 1e9d938baca1..6228883b3740 100644
--- a/shells/wapsh/pkg-message
+++ b/shells/wapsh/pkg-message
@@ -10,4 +10,3 @@ PHP scripts for both HTTP and WAP access have been installed in
Please read the installed documentation for information on how to create
the configuration files.
-
diff --git a/shells/wapsh/pkg-plist b/shells/wapsh/pkg-plist
index 6802c9a8f30a..8599b1bb713f 100644
--- a/shells/wapsh/pkg-plist
+++ b/shells/wapsh/pkg-plist
@@ -9,90 +9,90 @@ etc/wapsh/htshd.conf.dist
@unexec if cmp -s %D/etc/wapsh/loginhosts %D/etc/wapsh/loginhosts.dist; then rm -f %D/etc/wapsh/loginhosts; fi
etc/wapsh/loginhosts.dist
@exec [ -f %B/loginhosts ] || cp %B/%f %B/loginhosts
-share/wapsh/htdocs/command.php
-share/wapsh/htdocs/command_html.inc
-share/wapsh/htdocs/command_wml.inc
-share/wapsh/htdocs/common.inc
-share/wapsh/htdocs/common_html.inc
-share/wapsh/htdocs/common_wml.inc
-share/wapsh/htdocs/controls_wml.php
-share/wapsh/htdocs/displayfuncs.inc
-share/wapsh/htdocs/getloginhosts.inc
-share/wapsh/htdocs/history_edit_wml.php
-share/wapsh/htdocs/history_html.php
-share/wapsh/htdocs/history_wml.php
-share/wapsh/htdocs/login_html.php
-share/wapsh/htdocs/login_wml.php
-share/wapsh/htdocs/scroll_wml.php
-share/wapsh/htdocs/shortcuts_wml.php
-share/doc/wapsh/Image1.jpg
-share/doc/wapsh/Image2.jpg
-share/doc/wapsh/Image3.jpg
-share/doc/wapsh/admin_guide/index.html
-share/doc/wapsh/implementation_notes/image57.gif
-share/doc/wapsh/implementation_notes/index.html
-share/doc/wapsh/index.html
-share/doc/wapsh/qpl.html
-share/doc/wapsh/user_guide/Image10.jpg
-share/doc/wapsh/user_guide/Image11.jpg
-share/doc/wapsh/user_guide/Image12.jpg
-share/doc/wapsh/user_guide/Image13.jpg
-share/doc/wapsh/user_guide/Image14.jpg
-share/doc/wapsh/user_guide/Image15.jpg
-share/doc/wapsh/user_guide/Image16.jpg
-share/doc/wapsh/user_guide/Image17.jpg
-share/doc/wapsh/user_guide/Image18.jpg
-share/doc/wapsh/user_guide/Image19.jpg
-share/doc/wapsh/user_guide/Image20.jpg
-share/doc/wapsh/user_guide/Image21.jpg
-share/doc/wapsh/user_guide/Image22.jpg
-share/doc/wapsh/user_guide/Image23.jpg
-share/doc/wapsh/user_guide/Image24.jpg
-share/doc/wapsh/user_guide/Image25.gif
-share/doc/wapsh/user_guide/Image26.jpg
-share/doc/wapsh/user_guide/Image27.jpg
-share/doc/wapsh/user_guide/Image28.jpg
-share/doc/wapsh/user_guide/Image29.jpg
-share/doc/wapsh/user_guide/Image30.jpg
-share/doc/wapsh/user_guide/Image31.jpg
-share/doc/wapsh/user_guide/Image32.jpg
-share/doc/wapsh/user_guide/Image33.jpg
-share/doc/wapsh/user_guide/Image34.jpg
-share/doc/wapsh/user_guide/Image35.jpg
-share/doc/wapsh/user_guide/Image36.jpg
-share/doc/wapsh/user_guide/Image37.jpg
-share/doc/wapsh/user_guide/Image38.jpg
-share/doc/wapsh/user_guide/Image39.jpg
-share/doc/wapsh/user_guide/Image4.gif
-share/doc/wapsh/user_guide/Image40.jpg
-share/doc/wapsh/user_guide/Image41.jpg
-share/doc/wapsh/user_guide/Image42.jpg
-share/doc/wapsh/user_guide/Image43.jpg
-share/doc/wapsh/user_guide/Image44.jpg
-share/doc/wapsh/user_guide/Image45.jpg
-share/doc/wapsh/user_guide/Image46.jpg
-share/doc/wapsh/user_guide/Image47.jpg
-share/doc/wapsh/user_guide/Image48.jpg
-share/doc/wapsh/user_guide/Image49.jpg
-share/doc/wapsh/user_guide/Image5.gif
-share/doc/wapsh/user_guide/Image50.gif
-share/doc/wapsh/user_guide/Image51.jpg
-share/doc/wapsh/user_guide/Image52.jpg
-share/doc/wapsh/user_guide/Image53.gif
-share/doc/wapsh/user_guide/Image54.jpg
-share/doc/wapsh/user_guide/Image55.jpg
-share/doc/wapsh/user_guide/Image56.jpg
-share/doc/wapsh/user_guide/Image6.jpg
-share/doc/wapsh/user_guide/Image7.jpg
-share/doc/wapsh/user_guide/Image8.jpg
-share/doc/wapsh/user_guide/Image9.jpg
-share/doc/wapsh/user_guide/index.html
+%%DATADIR%%/htdocs/command.php
+%%DATADIR%%/htdocs/command_html.inc
+%%DATADIR%%/htdocs/command_wml.inc
+%%DATADIR%%/htdocs/common.inc
+%%DATADIR%%/htdocs/common_html.inc
+%%DATADIR%%/htdocs/common_wml.inc
+%%DATADIR%%/htdocs/controls_wml.php
+%%DATADIR%%/htdocs/displayfuncs.inc
+%%DATADIR%%/htdocs/getloginhosts.inc
+%%DATADIR%%/htdocs/history_edit_wml.php
+%%DATADIR%%/htdocs/history_html.php
+%%DATADIR%%/htdocs/history_wml.php
+%%DATADIR%%/htdocs/login_html.php
+%%DATADIR%%/htdocs/login_wml.php
+%%DATADIR%%/htdocs/scroll_wml.php
+%%DATADIR%%/htdocs/shortcuts_wml.php
+%%PORTDOCS%%%%DOCSDIR%%/Image1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/Image2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/Image3.jpg
+%%PORTDOCS%%%%DOCSDIR%%/admin_guide/index.html
+%%PORTDOCS%%%%DOCSDIR%%/implementation_notes/image57.gif
+%%PORTDOCS%%%%DOCSDIR%%/implementation_notes/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/qpl.html
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image10.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image11.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image12.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image13.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image14.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image15.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image16.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image17.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image18.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image19.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image20.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image21.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image22.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image23.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image24.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image25.gif
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image26.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image27.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image28.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image29.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image30.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image31.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image32.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image33.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image34.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image35.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image36.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image37.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image38.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image39.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image4.gif
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image40.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image41.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image42.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image43.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image44.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image45.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image46.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image47.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image48.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image49.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image5.gif
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image50.gif
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image51.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image52.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image53.gif
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image54.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image55.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image56.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image6.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image7.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image8.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/Image9.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user_guide/index.html
@exec echo "updating /etc/services"; cp /etc/services /etc/services.bak; (grep -v ^htsh /etc/services.bak ; echo "htsh 3001/tcp # htsh/wapsh server") > /etc/services
@unexec echo "updating /etc/services"; cp /etc/services /etc/services.bak; (grep -v ^htsh /etc/services.bak ) > /etc/services
@dirrm etc/wapsh
-@dirrm share/doc/wapsh/admin_guide
-@dirrm share/doc/wapsh/implementation_notes
-@dirrm share/doc/wapsh/user_guide
-@dirrm share/doc/wapsh
-@dirrm share/wapsh/htdocs
-@dirrm share/wapsh
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/admin_guide
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/implementation_notes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/user_guide
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/htdocs
+@dirrm %%DATADIR%%