aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /shells/zsh
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index f5ec69dfa1ad..c7927961e8ec 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -31,7 +31,7 @@ USE_NCURSES= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
.endif
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
--enable-function-subdirs
@@ -91,7 +91,7 @@ CONFIGURE_ARGS+= --enable-maildir-support
.endif
.if defined(WITH_ZSH_STATIC)
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -static"
+LDFLAGS+= -static
CONFIGURE_ARGS+= --disable-dynamic
PLIST_SUB+= SHARED="@comment "
.else