aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-05 19:06:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-05 19:06:06 +0000
commitf578dd2ebaf61ddae69c47e39e981f680909ec9f (patch)
tree3b0a569156d5d11dc1707daba7299b6d6dd7b879 /shells
parent952922b3fd28ed7c1017662192faaab778f428c5 (diff)
downloadports-f578dd2ebaf61ddae69c47e39e981f680909ec9f.tar.gz
ports-f578dd2ebaf61ddae69c47e39e981f680909ec9f.zip
Add FREEBSD option (enabled by default)
- Update pkg-descr - Bump PORTREVISION for package change FreeBSD-specific bash completions are provided by 0mp@.
Notes
Notes: svn path=/head/; revision=471801
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile16
-rw-r--r--shells/bash-completion/distinfo4
-rw-r--r--shells/bash-completion/pkg-descr6
-rw-r--r--shells/bash-completion/pkg-plist3
4 files changed, 24 insertions, 5 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index a52b37476b57..e1162e2a0e2d 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bash-completion
PORTVERSION= 2.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= shells
@@ -10,21 +11,21 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Programmable completion library for Bash
LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to build: gmake: install-recursive: Error 1
BROKEN_armv7= fails to build: gmake: install-recursive: Error 1
PORTSCOUT= limit:^[0-9\.]*$$
-OPTIONS_DEFINE= CMAKE_MODULES DOCS
+OPTIONS_DEFINE= CMAKE_MODULES DOCS FREEBSD
OPTIONS_SINGLE= BASH
OPTIONS_SINGLE_BASH= BASH_SHARED BASH_STATIC
-OPTIONS_DEFAULT=BASH_SHARED CMAKE_MODULES
+OPTIONS_DEFAULT=BASH_SHARED CMAKE_MODULES FREEBSD
OPTIONS_SUB= yes
BASH_SHARED_DESC= Use shells/bash as backend
BASH_STATIC_DESC= Use shells/bash-static as backend
CMAKE_MODULES_DESC= Install bash-completion modules for cmake
+FREEBSD_DESC= Install completion functions for FreeBSD programs
NO_ARCH= yes
GNU_CONFIGURE= yes
@@ -38,6 +39,12 @@ USE_GITHUB= yes
BASH_SHARED_RUN_DEPENDS=bash:shells/bash
BASH_STATIC_RUN_DEPENDS=bash:shells/bash-static
+FREEBSD_GH_TUPLE= 0mp:bash-completion-freebsd:1.0.2:freebsd/freebsd
+FREEBSD_VARS= LICENSE="BSD2CLAUSE GPLv2+" \
+ LICENSE_COMB=multi \
+ LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/freebsd/LICENSE \
+ LICENSE_FILE_GPLv2+=${WRKSRC}/COPYING
+FREEBSD_VARS_OFF= LICENSE_FILE=${WRKSRC}/COPYING
post-patch:
@${REINPLACE_CMD} \
@@ -60,4 +67,7 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES README.md doc/bash_completion.txt doc/bashrc doc/inputrc ${STAGEDIR}${DOCSDIR}/
+post-install-FREEBSD-on:
+ cd ${WRKSRC}/freebsd/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS}
+
.include <bsd.port.mk>
diff --git a/shells/bash-completion/distinfo b/shells/bash-completion/distinfo
index eb93761f5d31..063b02cc4381 100644
--- a/shells/bash-completion/distinfo
+++ b/shells/bash-completion/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1521366391
+TIMESTAMP = 1528130663
SHA256 (scop-bash-completion-2.8_GH0.tar.gz) = c3f1bacac64bc69e3dfb9b1ef79ddbf755aac441b452845531950f1643bed25f
SIZE (scop-bash-completion-2.8_GH0.tar.gz) = 326534
+SHA256 (0mp-bash-completion-freebsd-1.0.2_GH0.tar.gz) = e072d62bd4532083f054f48065148dca907d6885347072262ee3d4a5a8531256
+SIZE (0mp-bash-completion-freebsd-1.0.2_GH0.tar.gz) = 7199
diff --git a/shells/bash-completion/pkg-descr b/shells/bash-completion/pkg-descr
index 50b35e9ec059..48fe1cd8ee63 100644
--- a/shells/bash-completion/pkg-descr
+++ b/shells/bash-completion/pkg-descr
@@ -1,4 +1,8 @@
-This is a programmable completion convenience library for the bash(1) shell. It
+This is a programmable completion convenience library for the Bash shell. It
features the ability to tab-complete arguments for many common programs.
+Completion functions for FreeBSD-specific software are developed independently
+as an extension to the official bash-completion library. The development takes
+place on GitHub: https://github.com/0mp/bash-completion-freebsd
+
WWW: https://github.com/scop/bash-completion
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 27627c3d1d2f..7f2b6d4446ad 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -1,3 +1,6 @@
+%%FREEBSD%%etc/bash_completion.d/mandoc
+%%FREEBSD%%etc/bash_completion.d/pkg
+%%FREEBSD%%etc/bash_completion.d/service
libdata/pkgconfig/bash-completion.pc
%%DATADIR%%/bash_completion
%%DATADIR%%/bash_completion.sh