aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2010-09-28 13:23:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2010-09-28 13:23:45 +0000
commit114cb1ed36dfb597ff64961c4209fd945a943024 (patch)
treecb6f8bc2b0c5c774c5017fccd59a35203b3ed8e4 /shells
parentb985d103cf51b9c71b89f8d9c8ccfde148d05801 (diff)
downloadports-114cb1ed36dfb597ff64961c4209fd945a943024.tar.gz
ports-114cb1ed36dfb597ff64961c4209fd945a943024.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile3
-rw-r--r--shells/fd/distinfo6
-rw-r--r--shells/fd/files/patch-dosdisk.c62
3 files changed, 67 insertions, 4 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index a02a7a25ec96..9021f5caaad7 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fd
-PORTVERSION= 3.00i
+PORTVERSION= 3.00j
CATEGORIES= shells net
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
@@ -19,6 +19,7 @@ MANLANG= "" ja
MAN1= fd.1 fdsh.1
MAKE_ENV= LANG=ja
MAKE_ARGS= CC="${CC}" CONFDIR="${PREFIX}/etc"
+MAKE_JOBS_SAFE= yes
DOCS_EN= FAQ.eng \
LICENSES.eng \
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index d7fa488361cd..1ac2a08e4d98 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1,3 +1,3 @@
-MD5 (FD-3.00i.tar.gz) = 68fbbe57576dab810006292d0300f942
-SHA256 (FD-3.00i.tar.gz) = 8bf9fd7fcd219e3deecdcea9a18cc2361e30679e25ee8258cb1fbe9c417f373d
-SIZE (FD-3.00i.tar.gz) = 924400
+MD5 (FD-3.00j.tar.gz) = 9e12c8a1480cc5f535bf6df852a0defc
+SHA256 (FD-3.00j.tar.gz) = 43285bc4cdb0e37d52859972fe1b9030c187acbdf796920b085a364aa63f269e
+SIZE (FD-3.00j.tar.gz) = 925560
diff --git a/shells/fd/files/patch-dosdisk.c b/shells/fd/files/patch-dosdisk.c
new file mode 100644
index 000000000000..55edfb9a39fa
--- /dev/null
+++ b/shells/fd/files/patch-dosdisk.c
@@ -0,0 +1,62 @@
+This is a patch taken from [FDclone-users:00927].
+
+diff -u ../old/FD-3.00j/dosdisk.c ./dosdisk.c
+--- ../old/FD-3.00j/dosdisk.c Sat Sep 25 00:00:00 2010
++++ ./dosdisk.c Sun Sep 26 00:05:47 2010
+@@ -2269,7 +2269,7 @@
+ {
+ time_t mt;
+ u_short date, time;
+- int isnow;
++ int sec, isnow;
+
+ mt = (time_t)0;
+ isnow = 0;
+@@ -2277,9 +2277,12 @@
+ t = Xtime(&mt);
+ isnow++;
+ }
+- getdostime(&date, &time, t);
++ sec = getdostime(&date, &time, t);
+
+- if (!time && isnow) time = 0x0001;
++ if (isnow) {
++ if (!time) time = 0x0001;
++ mt += (sec & 0x01) * 1000L;
++ }
+ buf[0] = time & 0xff;
+ buf[1] = (time >> 8) & 0xff;
+ buf[2] = date & 0xff;
+diff -u ../old/FD-3.00j/sysemu.c ./sysemu.c
+--- ../old/FD-3.00j/sysemu.c Sat Sep 25 00:00:00 2010
++++ ./sysemu.c Sun Sep 26 00:03:20 2010
+@@ -720,7 +720,7 @@
+ return(attr);
+ }
+
+-VOID getdostime(dp, tp, t)
++int getdostime(dp, tp, t)
+ u_short *dp, *tp;
+ time_t t;
+ {
+@@ -733,6 +733,8 @@
+ *tp = ((tm -> tm_hour & 0x1f) << 11)
+ + ((tm -> tm_min & 0x3f) << 5)
+ + ((tm -> tm_sec & 0x3e) >> 1);
++
++ return(tm -> tm_sec);
+ }
+ #endif /* DEP_DOSPATH */
+
+diff -u ../old/FD-3.00j/sysemu.h ./sysemu.h
+--- ../old/FD-3.00j/sysemu.h Sat Sep 25 00:00:00 2010
++++ ./sysemu.h Sat Sep 25 23:59:47 2010
+@@ -58,7 +58,7 @@
+ extern u_int getunixmode __P_((u_int));
+ extern time_t getunixtime __P_((u_int, u_int));
+ extern u_short getdosmode __P_((u_int));
+-extern VOID getdostime __P_((u_short *, u_short *, time_t));
++extern int getdostime __P_((u_short *, u_short *, time_t));
+ #endif
+ #if defined (DEP_DIRENT)
+ extern DIR *Xopendir __P_((CONST char *));