aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-12 06:27:41 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-12 06:27:41 +0000
commit94f7601273e43def2b3ea22208ebfb08ec7d2ee3 (patch)
tree6e473a930c60d1c8d5c8a722b75b4e61c883d3e7 /shells
parentd730b150617e040f468ca720d3b105a8bfaba0db (diff)
downloadports-94f7601273e43def2b3ea22208ebfb08ec7d2ee3.tar.gz
ports-94f7601273e43def2b3ea22208ebfb08ec7d2ee3.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/p5-Shell-Perl/Makefile9
-rw-r--r--shells/psh/Makefile3
-rw-r--r--shells/shell-include/Makefile8
-rw-r--r--shells/vshnu/Makefile10
4 files changed, 10 insertions, 20 deletions
diff --git a/shells/p5-Shell-Perl/Makefile b/shells/p5-Shell-Perl/Makefile
index b50a4707a147..a5fc9d0ebb01 100644
--- a/shells/p5-Shell-Perl/Makefile
+++ b/shells/p5-Shell-Perl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Shell-Perl
-# Date created: 2008-02-27
-# Whom: Shinsuke Matsui <smatsui@karashi.org>
-#
+# Created by: Shinsuke Matsui <smatsui@karashi.org>
# $FreeBSD$
-#
PORTNAME= Shell-Perl
PORTVERSION= 0.0022
@@ -25,7 +21,8 @@ BUILD_DEPENDS= p5-Test-Script>=0:${PORTSDIR}/devel/p5-Test-Script \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
p5-Test-Expect>=0:${PORTSDIR}/devel/p5-Test-Expect
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN1= pirl.1
MAN3= Shell::Perl.3 Shell::Perl::Dumper.3
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index 08031ba5dd74..2f6425a67b92 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -11,7 +11,8 @@ MASTER_SITE_SUBDIR= CPAN:GREGOR
MAINTAINER= garga@FreeBSD.org
COMMENT= New shell made entirely out of a Perl script
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SUB_FILES= pkg-install pkg-deinstall
diff --git a/shells/shell-include/Makefile b/shells/shell-include/Makefile
index c470584c3acc..fbc730af2ad7 100644
--- a/shells/shell-include/Makefile
+++ b/shells/shell-include/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qar-bufo
-# Date created: 18 April 2007
-# Whom: Zane C. Bowers
-#
+# Created by: Zane C. Bowers
# $FreeBSD$
-#
PORTNAME= shell-include
PORTVERSION= 0.1.2
@@ -14,7 +10,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= vvelox@vvelox.net
COMMENT= A include system for shell scripts
-USE_PERL5= yes
+USES= perl5
MAN3= random::shortIntRandom.3 \
random.3 \
diff --git a/shells/vshnu/Makefile b/shells/vshnu/Makefile
index bb0746ca8914..d83c01004ba1 100644
--- a/shells/vshnu/Makefile
+++ b/shells/vshnu/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: vshnu
-# Date created: Feb 26, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= vshnu
PORTVERSION= 1.0305
@@ -18,6 +13,7 @@ COMMENT= New Visual Shell
BUILD_DEPENDS= p5-Term-Screen>=0:${PORTSDIR}/devel/p5-Term-Screen
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>