aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2008-05-02 21:13:47 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2008-05-02 21:13:47 +0000
commit54df03845729df56ccdbcdf8627db279c6415dbf (patch)
tree2f1140885320c3bcd596f1790f11d13262e3e5e2 /shells
parent299ccb4639bb401ee3b71f418f854d4d66008fec (diff)
downloadports-54df03845729df56ccdbcdf8627db279c6415dbf.tar.gz
ports-54df03845729df56ccdbcdf8627db279c6415dbf.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile5
-rw-r--r--shells/zsh/distinfo12
-rw-r--r--shells/zsh/files/patch-Completion-Unix-Command-_locate33
-rw-r--r--shells/zsh/files/patch-Completion-Unix-Command-_subversion20
-rw-r--r--shells/zsh/files/patch-Completion-Unix-Type-_canonical_paths20
-rw-r--r--shells/zsh/files/patch-Completion-X-Command-_acroread17
-rw-r--r--shells/zsh/files/patch-Config_installfns.sh15
-rw-r--r--shells/zsh/files/patch-Src::utils.c23
-rw-r--r--shells/zsh/files/patch-environ253
-rw-r--r--shells/zsh/pkg-plist49
10 files changed, 54 insertions, 393 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 34a9518c9a79..6b6ae0cd2cdd 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -21,8 +21,7 @@
# NOTE: does NOT have to be inside ${PREFIX} tree
PORTNAME= zsh
-PORTVERSION= 4.3.4
-PORTREVISION= 3
+PORTVERSION= 4.3.6
CATEGORIES= shells
MASTER_SITES= SF
.if !defined(NOPORTDOCS)
@@ -43,7 +42,7 @@ USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-curses-terminfo --with-tcsetpgrp \
+CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
--enable-etcdir=${ZSH_ETCDIR} \
--enable-fndir=${ZSH_FNDIR} --enable-function-subdirs \
--enable-site-fndir=${ZSH_SITEFNDIR}
diff --git a/shells/zsh/distinfo b/shells/zsh/distinfo
index ab6323f4f80f..13303fa4b0f9 100644
--- a/shells/zsh/distinfo
+++ b/shells/zsh/distinfo
@@ -1,6 +1,6 @@
-MD5 (zsh-4.3.4.tar.bz2) = 8410a30e4f5c6160790bc3afc096424f
-SHA256 (zsh-4.3.4.tar.bz2) = 6fa0e22cb0da3a02c115425097002f2b4bb56e412db6c821ca111e088cbfdec6
-SIZE (zsh-4.3.4.tar.bz2) = 2374851
-MD5 (zsh-4.3.4-doc.tar.bz2) = 1a4ab09a9d75c5ae8585ad645406f27d
-SHA256 (zsh-4.3.4-doc.tar.bz2) = e74289f99479328b8bcee9c47ae07038e54437e860fb5487da57cfc8d1836777
-SIZE (zsh-4.3.4-doc.tar.bz2) = 2358063
+MD5 (zsh-4.3.6.tar.bz2) = 16f399af1081ad3c303a794c9c7dc47e
+SHA256 (zsh-4.3.6.tar.bz2) = 5a253d107533ff60ab9edb74de9425f2ca93bc5a3ddb5c1b5bfd488a794dc873
+SIZE (zsh-4.3.6.tar.bz2) = 2527972
+MD5 (zsh-4.3.6-doc.tar.bz2) = cab29228a90f58b1431a66ab24a0a0c2
+SHA256 (zsh-4.3.6-doc.tar.bz2) = a82cf4e55d6bcf1ea40c23ef5f99002d504c441a8f6d14af0ed4d574c6ffbcc6
+SIZE (zsh-4.3.6-doc.tar.bz2) = 2473544
diff --git a/shells/zsh/files/patch-Completion-Unix-Command-_locate b/shells/zsh/files/patch-Completion-Unix-Command-_locate
index 8fdefbd05f3f..5d95703beb87 100644
--- a/shells/zsh/files/patch-Completion-Unix-Command-_locate
+++ b/shells/zsh/files/patch-Completion-Unix-Command-_locate
@@ -4,37 +4,8 @@
;;
(locate)
-- input="$(_call_program locate $words[0] -V)"
-+ input="$(_call_program locate $words[0] -V 2>&1)"
+- input="$(_call_program locate $words[1] -V)"
++ input="$(_call_program locate $words[1] -V 2>&1)"
case $input in
(*mlocate*)
ltype=mlocate
-@@ -25,6 +25,10 @@
- ltype=gnu
- ;;
-
-+ (*illegal option*)
-+ ltype=bsd
-+ ;;
-+
- # guess
- (*)
- ltype=$best_guess
-@@ -108,4 +112,17 @@
- --help'[Show help]' \
- '*:pattern: '
- ;;
-+
-+ (bsd)
-+ _arguments -s : \
-+ -0'[Output separated by NUL characters]' \
-+ -S'[Show database statistics]' \
-+ -c'[Output the number of matching entries]' \
-+ -d'[Use alternative database]:database:_files' \
-+ -i'[Ignore case distinctions in patterns]' \
-+ -l'[Limit search results]:file limit: ' \
-+ -m'[Use mmap instead of stdio library]' \
-+ -s'[Use stdio instead of mmap]' \
-+ '*:pattern: '
-+ ;;
- esac
diff --git a/shells/zsh/files/patch-Completion-Unix-Command-_subversion b/shells/zsh/files/patch-Completion-Unix-Command-_subversion
deleted file mode 100644
index 55e362fabc7f..000000000000
--- a/shells/zsh/files/patch-Completion-Unix-Command-_subversion
+++ /dev/null
@@ -1,20 +0,0 @@
---- Completion/Unix/Command/_subversion 2007/04/19 20:37:04 1.24
-+++ Completion/Unix/Command/_subversion 2008/01/31 16:16:36 1.25
-@@ -30,7 +30,7 @@
-
- usage=${${(M)${(f)"$(LC_ALL=C _call_program options svn help $cmd)"}:#usage:*}#usage:*$cmd] }
- args=(
-- ${=${${${(M)${(f)"$(LC_ALL=C _call_program options svn help $cmd)"##*Valid options:}:#* :*}%% #:*}/ arg/:arg:}/(#b)-([[:alpha:]]) \[--([a-z-]##)\](:arg:)#/(--$match[2])-$match[1]$match[3] (-$match[1])--$match[2]$match[3]}
-+ ${=${${${(M)${(f)"$(LC_ALL=C _call_program options svn help $cmd)"#(*Valid options:|(#e))}:#* :*}%% #:*}/ (arg|ARG)/:arg:}/(#b)-([[:alpha:]]) \[--([a-z-]##)\](:arg:)#/(--$match[2])-$match[1]$match[3] (-$match[1])--$match[2]$match[3]}
- )
-
- case $cmd in;
-@@ -148,7 +148,7 @@
-
- usage=${${(M)${(f)"$(LC_ALL=C _call_program options svnadmin help $cmd)"}:#$cmd: usage:*}#$cmd: usage: svnadmin $cmd }
- args=(
-- ${=${${${(M)${(f)"$(LC_ALL=C _call_program options svnadmin help $cmd)"##*Valid options:}:#*:*}%% #:*}/ arg/:arg:}/(#b)-([[:alpha:]]) \[--([a-z-]##)\](:arg:)#/(--$match[2])-$match[1]$match[3] (-$match[1])--$match[2]$match[3]}
-+ ${=${${${(M)${(f)"$(LC_ALL=C _call_program options svnadmin help $cmd)"#(*Valid options:|(#e))}:#* :*}%% #:*}/ (arg|ARG)/:arg:}/(#b)-([[:alpha:]]) \[--([a-z-]##)\](:arg:)#/(--$match[2])-$match[1]$match[3] (-$match[1])--$match[2]$match[3]}
- )
- if [[ $_svnadmin_subcmd_usage == *REPOS_PATH* ]]; then
- args+=( ":path:_files -/" )
diff --git a/shells/zsh/files/patch-Completion-Unix-Type-_canonical_paths b/shells/zsh/files/patch-Completion-Unix-Type-_canonical_paths
deleted file mode 100644
index 43e0eed42a6e..000000000000
--- a/shells/zsh/files/patch-Completion-Unix-Type-_canonical_paths
+++ /dev/null
@@ -1,20 +0,0 @@
---- Completion/Unix/Type/_canonical_paths.orig 2006-05-28 13:36:06.000000000 -0500
-+++ Completion/Unix/Type/_canonical_paths 2007-08-20 21:23:04.000000000 -0500
-@@ -38,7 +38,7 @@
- files=($@)
- else
- for __index in $@; do
-- files+=$(readlink -qf $__index)
-+ files+=$(/usr/bin/stat -qr $__index | cut -d' ' -f16)
- done
- fi
-
-@@ -48,7 +48,7 @@
- expref=${~origpref}
- [[ $origpref == (|*/). ]] && rltrim=.
- curpref=${${expref%$rltrim}:-./}
-- canpref=$(readlink -qf $curpref)
-+ canpref=$(/usr/bin/stat -qr $curpref | cut -d' ' -f16)
- if [[ $? -eq 0 ]]; then
- [[ $curpref == */ && $canpref == *[^/] ]] && canpref+=/
- canpref+=$rltrim
diff --git a/shells/zsh/files/patch-Completion-X-Command-_acroread b/shells/zsh/files/patch-Completion-X-Command-_acroread
deleted file mode 100644
index b4881c378174..000000000000
--- a/shells/zsh/files/patch-Completion-X-Command-_acroread
+++ /dev/null
@@ -1,17 +0,0 @@
---- Completion/X/Command/_acroread.orig Mon Mar 19 10:02:50 2007
-+++ Completion/X/Command/_acroread Tue Jul 24 15:39:18 2007
-@@ -16,12 +16,12 @@
-
- # Try extracting the version number directly from the executable.
- # (This will fail if the executable is a wrapper script for acroread.)
-- _acroread_version=${${(M)${(f)"$(<$cmdfile)"}:#ver=*}##ver=}
-+ _acroread_version=${${${(Mf)"$(<$commands[$words[1]])"}:#ver=*}##ver=}
-
- if [[ -z $_acroread_version ]]; then
- local acropath=${${(s. .)${${(f)"$($words[1] -help 2>&1)"}[1]}}[2]}
- if [[ -r $acropath ]]; then
-- _acroread_version=${${(M)${(f)"$(<$acropath)"}:#ver=*}##ver=}
-+ _acroread_version=${${${(Mf)"$(<$acropath)"}:#ver=*}##ver=}
- fi
- fi
- fi
diff --git a/shells/zsh/files/patch-Config_installfns.sh b/shells/zsh/files/patch-Config_installfns.sh
deleted file mode 100644
index 07b95dc6abfb..000000000000
--- a/shells/zsh/files/patch-Config_installfns.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- Config/installfns.sh.orig Mon Mar 20 08:06:24 2006
-+++ Config/installfns.sh Thu Jul 26 11:10:23 2007
-@@ -45,10 +45,9 @@
- esac
- fi
- test -d $instdir || /bin/sh $sdir_top/mkinstalldirs $instdir || exit 1
-+ $INSTALL_DATA $sdir_top/$file $instdir || exit 1
- if test -x $sdir_top/$file; then
-- $INSTALL_PROGRAM $sdir_top/$file $instdir || exit 1
-- else
-- $INSTALL_DATA $sdir_top/$file $instdir || exit 1
-+ chmod +x $instdir/`echo $file | sed -e 's%^.*/%%'`
- fi
- fi
- done
diff --git a/shells/zsh/files/patch-Src::utils.c b/shells/zsh/files/patch-Src::utils.c
deleted file mode 100644
index 6fb4c5752050..000000000000
--- a/shells/zsh/files/patch-Src::utils.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- Src/utils.c.orig Tue Apr 17 10:57:15 2007
-+++ Src/utils.c Wed Jul 25 15:13:58 2007
-@@ -1092,6 +1092,7 @@
- time_t lastmailcheck;
-
- /* the last time we checked the people in the WATCH variable */
-+extern char *_mktemp(char *);
-
- /**/
- time_t lastwatch;
-@@ -4569,11 +4570,11 @@
- int count;
- #else
- unsigned int wval;
-+ size_t count;
- # if defined(HAVE_NL_LANGINFO) && defined(CODESET) && defined(HAVE_ICONV)
- iconv_t cd;
- char inbuf[4];
- size_t inbytes, outbytes;
-- size_t count;
- # endif
- #endif
-
diff --git a/shells/zsh/files/patch-environ b/shells/zsh/files/patch-environ
deleted file mode 100644
index febaa74cf368..000000000000
--- a/shells/zsh/files/patch-environ
+++ /dev/null
@@ -1,253 +0,0 @@
-diff -u Src/exec.c Src/exec.c
---- Src/exec.c 2007-02-14 10:11:19.000000000 -0600
-+++ Src/exec.c 2007-07-31 08:49:13.000000000 -0500
-@@ -501,7 +501,16 @@
- * that as argv[0] for this external command */
- if (unset(RESTRICTED) && (z = zgetenv("ARGV0"))) {
- setdata(firstnode(args), (void *) ztrdup(z));
-+ /*
-+ * Note we don't do anything with the parameter structure
-+ * for ARGV0: that's OK since we're about to exec or exit
-+ * on failure.
-+ */
-+#ifdef USE_SET_UNSET_ENV
-+ unsetenv("ARGV0");
-+#else
- delenvvalue(z - 6);
-+#endif
- } else if (dash) {
- /* Else if the pre-command `-' was given, we add `-' *
- * to the front of argv[0] for this command. */
-diff -u Src/params.c Src/params.c
---- Src/params.c 2007-04-13 06:40:27.000000000 -0500
-+++ Src/params.c 2007-07-31 08:49:13.000000000 -0500
-@@ -606,7 +606,7 @@
- createparamtable(void)
- {
- Param ip, pm;
--#ifndef HAVE_PUTENV
-+#if !defined(HAVE_PUTENV) && !defined(USE_SET_UNSET_ENV)
- char **new_environ;
- int envsize;
- #endif
-@@ -661,7 +661,7 @@
-
- setsparam("LOGNAME", ztrdup((str = getlogin()) && *str ? str : cached_username));
-
--#ifndef HAVE_PUTENV
-+#if !defined(HAVE_PUTENV) && !defined(USE_SET_UNSET_ENV)
- /* Copy the environment variables we are inheriting to dynamic *
- * memory, so we can do mallocs and frees on it. */
- envsize = sizeof(char *)*(1 + arrlen(environ));
-@@ -3727,6 +3727,30 @@
- int
- zputenv(char *str)
- {
-+#ifdef USE_SET_UNSET_ENV
-+ /*
-+ * If we are using unsetenv() to remove values from the
-+ * environment, which is the safe thing to do, we
-+ * need to use setenv() to put them there in the first place.
-+ * Unfortunately this is a slightly different interface
-+ * from what zputenv() assumes.
-+ */
-+ char *ptr;
-+ int ret;
-+
-+ for (ptr = str; *ptr && *ptr != '='; ptr++)
-+ ;
-+ if (*ptr) {
-+ *ptr = '\0';
-+ ret = setenv(str, ptr+1, 1);
-+ *ptr = '=';
-+ } else {
-+ /* safety first */
-+ DPUTS(1, "bad environment string");
-+ ret = setenv(str, ptr, 1);
-+ }
-+ return ret;
-+#else
- #ifdef HAVE_PUTENV
- return putenv(str);
- #else
-@@ -3750,9 +3774,12 @@
- }
- return 0;
- #endif
-+#endif
- }
-
- /**/
-+#ifndef USE_SET_UNSET_ENV
-+/**/
- static int
- findenv(char *name, int *pos)
- {
-@@ -3771,6 +3798,8 @@
-
- return 0;
- }
-+/**/
-+#endif
-
- /* Given *name = "foo", it searches the environment for string *
- * "foo=bar", and returns a pointer to the beginning of "bar" */
-@@ -3811,14 +3840,18 @@
- void
- addenv(Param pm, char *value)
- {
-- char *oldenv = 0, *newenv = 0, *env = 0;
-+ char *newenv = 0;
-+#ifndef USE_SET_UNSET_ENV
-+ char *oldenv = 0, *env = 0;
- int pos;
-
-- /* First check if there is already an environment *
-- * variable matching string `name'. If not, and *
-- * we are not requested to add new, return */
-+ /*
-+ * First check if there is already an environment
-+ * variable matching string `name'.
-+ */
- if (findenv(pm->node.nam, &pos))
- oldenv = environ[pos];
-+#endif
-
- newenv = mkenvstr(pm->node.nam, value, pm->node.flags);
- if (zputenv(newenv)) {
-@@ -3826,6 +3859,19 @@
- pm->env = NULL;
- return;
- }
-+#ifdef USE_SET_UNSET_ENV
-+ /*
-+ * If we are using setenv/unsetenv to manage the environment,
-+ * we simply store the string we created in pm->env since
-+ * memory management of the environment is handled entirely
-+ * by the system.
-+ *
-+ * TODO: is this good enough to fix problem cases from
-+ * the other branch? If so, we don't actually need to
-+ * store pm->env at all, just a flag that the value was set.
-+ */
-+ pm->env = newenv;
-+#else
- /*
- * Under Cygwin we must use putenv() to maintain consistency.
- * Unfortunately, current version (1.1.2) copies argument and may
-@@ -3845,6 +3891,7 @@
-
- DPUTS(1, "addenv should never reach the end");
- pm->env = NULL;
-+#endif
- }
-
-
-@@ -3875,6 +3922,7 @@
- * string. */
-
-
-+#ifndef USE_SET_UNSET_ENV
- /**/
- void
- delenvvalue(char *x)
-@@ -3890,6 +3938,8 @@
- }
- zsfree(x);
- }
-+#endif
-+
-
- /* Delete a pointer from the list of pointers to environment *
- * variables by shifting all the other pointers up one slot. */
-@@ -3898,7 +3948,12 @@
- void
- delenv(Param pm)
- {
-+#ifdef USE_SET_UNSET_ENV
-+ unsetenv(pm->node.nam);
-+ zsfree(pm->env);
-+#else
- delenvvalue(pm->env);
-+#endif
- pm->env = NULL;
- /*
- * Note we don't remove PM_EXPORT from the flags. This
-diff -u Src/system.h Src/system.h
---- Src/system.h 2007-04-13 05:11:31.000000000 -0500
-+++ Src/system.h 2007-07-31 08:49:13.000000000 -0500
-@@ -693,6 +693,15 @@
-
- extern char **environ;
-
-+/*
-+ * We always need setenv and unsetenv in pairs, because
-+ * we don't know how to do memory management on the values set.
-+ */
-+#if defined(HAVE_SETENV) && defined(HAVE_UNSETENV)
-+# define USE_SET_UNSET_ENV
-+#endif
-+
-+
- /* These variables are sometimes defined in, *
- * and needed by, the termcap library. */
- #if MUST_DEFINE_OSPEED
-diff -u Test/B02typeset.ztst Test/B02typeset.ztst
---- Test/B02typeset.ztst 2006-06-26 13:17:32.000000000 -0500
-+++ Test/B02typeset.ztst 2007-07-31 08:49:13.000000000 -0500
-@@ -379,3 +379,31 @@
- >integer local i
- >local tagged scalar
- >preserved
-+
-+ export ENVFOO=bar
-+ print ENVFOO in environment
-+ env | grep '^ENVFOO'
-+ print Changing ENVFOO
-+ ENVFOO="not bar any more"
-+ env | grep '^ENVFOO'
-+ unset ENVFOO
-+ print ENVFOO no longer in environment
-+ env | grep '^ENVFOO'
-+1:Adding and removing values to and from the environment
-+>ENVFOO in environment
-+>ENVFOO=bar
-+>Changing ENVFOO
-+>ENVFOO=not bar any more
-+>ENVFOO no longer in environment
-+
-+ (export FOOENV=BAR
-+ env | grep '^FOOENV'
-+ print Exec
-+ exec $ZTST_testdir/../Src/zsh -c '
-+ print Unset
-+ unset FOOENV
-+ env | grep "^FOOENV"')
-+1:Can unset environment variables after exec
-+>FOOENV=BAR
-+>Exec
-+>Unset
-diff -u configure configure
---- configure 2007-01-18 10:33:17.000000000 -0600
-+++ configure 2007-07-31 08:49:06.000000000 -0500
-@@ -10263,7 +10263,7 @@
- setlocale \
- uname \
- signgam \
-- putenv getenv \
-+ putenv getenv setenv unsetenv xw \
- brk sbrk \
- pathconf sysconf \
- tgetent tigetflag tigetnum tigetstr setupterm \
-diff -u configure.ac configure.ac
---- configure.ac 2007-01-05 07:58:04.000000000 -0600
-+++ configure.ac 2007-07-31 08:49:06.000000000 -0500
-@@ -1126,7 +1126,7 @@
- setlocale \
- uname \
- signgam \
-- putenv getenv \
-+ putenv getenv setenv unsetenv xw\
- brk sbrk \
- pathconf sysconf \
- tgetent tigetflag tigetnum tigetstr setupterm \
diff --git a/shells/zsh/pkg-plist b/shells/zsh/pkg-plist
index 19ea162b5067..f66fa4fe62f4 100644
--- a/shells/zsh/pkg-plist
+++ b/shells/zsh/pkg-plist
@@ -14,6 +14,7 @@ bin/zsh-%%ZSH_VER%%
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/complete.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/complist.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/computil.so
+%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/curses.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/datetime.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/deltochar.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/example.so
@@ -26,6 +27,7 @@ bin/zsh-%%ZSH_VER%%
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/newuser.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/parameter.so
%%PCRE%%%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/pcre.so
+%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/regex.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/rlimits.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/sched.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/stat.so
@@ -42,7 +44,6 @@ bin/zsh-%%ZSH_VER%%
%%NO_STATIC%%@dirrm lib/zsh/%%ZSH_VER%%/zsh/net
%%NO_STATIC%%@dirrm lib/zsh/%%ZSH_VER%%/zsh
%%NO_STATIC%%@dirrm lib/zsh/%%ZSH_VER%%
-%%NO_STATIC%%lib/zsh/libzsh-%%ZSH_VER%%.so
%%NO_STATIC%%@dirrm lib/zsh
@exec mkdir %%ZSH_SITEFNDIR%% 2> /dev/null || true
@unexec rmdir %%ZSH_SITEFNDIR%% 2> /dev/null || true
@@ -51,6 +52,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Calendar/calendar_add
%%ZSH_FNDIR%%/Calendar/calendar_edit
%%ZSH_FNDIR%%/Calendar/calendar_lockfiles
+%%ZSH_FNDIR%%/Calendar/calendar_parse
%%ZSH_FNDIR%%/Calendar/calendar_read
%%ZSH_FNDIR%%/Calendar/calendar_scandate
%%ZSH_FNDIR%%/Calendar/calendar_show
@@ -69,8 +71,8 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/AIX/_volume_groups
%%ZSH_FNDIR%%/Completion/BSD/_bsd_pkg
%%ZSH_FNDIR%%/Completion/BSD/_chflags
-%%ZSH_FNDIR%%/Completion/BSD/_cvsup
%%ZSH_FNDIR%%/Completion/BSD/_csup
+%%ZSH_FNDIR%%/Completion/BSD/_cvsup
%%ZSH_FNDIR%%/Completion/BSD/_kld
%%ZSH_FNDIR%%/Completion/BSD/_portlint
%%ZSH_FNDIR%%/Completion/BSD/_portsnap
@@ -88,6 +90,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Base/_complete
%%ZSH_FNDIR%%/Completion/Base/_complete_debug
%%ZSH_FNDIR%%/Completion/Base/_complete_help
+%%ZSH_FNDIR%%/Completion/Base/_complete_help_generic
%%ZSH_FNDIR%%/Completion/Base/_complete_tag
%%ZSH_FNDIR%%/Completion/Base/_correct
%%ZSH_FNDIR%%/Completion/Base/_correct_filename
@@ -170,24 +173,32 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Debian/_debfoster
%%ZSH_FNDIR%%/Completion/Debian/_debsign
%%ZSH_FNDIR%%/Completion/Debian/_dlocate
+%%ZSH_FNDIR%%/Completion/Debian/_dpatch-edit-patch
%%ZSH_FNDIR%%/Completion/Debian/_dpkg
+%%ZSH_FNDIR%%/Completion/Debian/_dpkg-buildpackage
%%ZSH_FNDIR%%/Completion/Debian/_dpkg-cross
+%%ZSH_FNDIR%%/Completion/Debian/_dpkg-repack
%%ZSH_FNDIR%%/Completion/Debian/_dpkg_source
%%ZSH_FNDIR%%/Completion/Debian/_dput
%%ZSH_FNDIR%%/Completion/Debian/_dupload
%%ZSH_FNDIR%%/Completion/Debian/_invoke-rc.d
+%%ZSH_FNDIR%%/Completion/Debian/_lighttpd
%%ZSH_FNDIR%%/Completion/Debian/_linda
%%ZSH_FNDIR%%/Completion/Debian/_lintian
%%ZSH_FNDIR%%/Completion/Debian/_madison
%%ZSH_FNDIR%%/Completion/Debian/_make-kpkg
+%%ZSH_FNDIR%%/Completion/Debian/_members
%%ZSH_FNDIR%%/Completion/Debian/_mergechanges
%%ZSH_FNDIR%%/Completion/Debian/_module-assistant
%%ZSH_FNDIR%%/Completion/Debian/_piuparts
+%%ZSH_FNDIR%%/Completion/Debian/_reprepro
%%ZSH_FNDIR%%/Completion/Debian/_schroot
+%%ZSH_FNDIR%%/Completion/Debian/_svn-buildpackage
%%ZSH_FNDIR%%/Completion/Debian/_toolchain-source
%%ZSH_FNDIR%%/Completion/Debian/_update-alternatives
%%ZSH_FNDIR%%/Completion/Debian/_update-rc.d
%%ZSH_FNDIR%%/Completion/Debian/_uscan
+%%ZSH_FNDIR%%/Completion/Debian/_vim-addons
%%ZSH_FNDIR%%/Completion/Debian/_wajig
%%ZSH_FNDIR%%/Completion/Debian/_wanna-build
%%ZSH_FNDIR%%/Completion/Linux/_acpi
@@ -200,6 +211,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Linux/_iptables
%%ZSH_FNDIR%%/Completion/Linux/_iwconfig
%%ZSH_FNDIR%%/Completion/Linux/_losetup
+%%ZSH_FNDIR%%/Completion/Linux/_lsusb
%%ZSH_FNDIR%%/Completion/Linux/_mii-tool
%%ZSH_FNDIR%%/Completion/Linux/_modutils
%%ZSH_FNDIR%%/Completion/Linux/_mondo
@@ -236,9 +248,11 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_bzip2
%%ZSH_FNDIR%%/Completion/Unix/_bzr
%%ZSH_FNDIR%%/Completion/Unix/_cal
+%%ZSH_FNDIR%%/Completion/Unix/_calendar
%%ZSH_FNDIR%%/Completion/Unix/_canonical_paths
%%ZSH_FNDIR%%/Completion/Unix/_ccal
%%ZSH_FNDIR%%/Completion/Unix/_cdcd
+%%ZSH_FNDIR%%/Completion/Unix/_cdrdao
%%ZSH_FNDIR%%/Completion/Unix/_cdrecord
%%ZSH_FNDIR%%/Completion/Unix/_chkconfig
%%ZSH_FNDIR%%/Completion/Unix/_chmod
@@ -252,6 +266,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_cplay
%%ZSH_FNDIR%%/Completion/Unix/_cssh
%%ZSH_FNDIR%%/Completion/Unix/_ctags_tags
+%%ZSH_FNDIR%%/Completion/Unix/_cut
%%ZSH_FNDIR%%/Completion/Unix/_cvs
%%ZSH_FNDIR%%/Completion/Unix/_darcs
%%ZSH_FNDIR%%/Completion/Unix/_date
@@ -264,6 +279,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_diffstat
%%ZSH_FNDIR%%/Completion/Unix/_dir_list
%%ZSH_FNDIR%%/Completion/Unix/_directories
+%%ZSH_FNDIR%%/Completion/Unix/_dmidecode
%%ZSH_FNDIR%%/Completion/Unix/_domains
%%ZSH_FNDIR%%/Completion/Unix/_du
%%ZSH_FNDIR%%/Completion/Unix/_dvi
@@ -287,6 +303,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_fuser
%%ZSH_FNDIR%%/Completion/Unix/_gcc
%%ZSH_FNDIR%%/Completion/Unix/_gdb
+%%ZSH_FNDIR%%/Completion/Unix/_genisoimage
%%ZSH_FNDIR%%/Completion/Unix/_getconf
%%ZSH_FNDIR%%/Completion/Unix/_getent
%%ZSH_FNDIR%%/Completion/Unix/_getmail
@@ -301,10 +318,13 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_grep
%%ZSH_FNDIR%%/Completion/Unix/_groff
%%ZSH_FNDIR%%/Completion/Unix/_groups
+%%ZSH_FNDIR%%/Completion/Unix/_growisofs
%%ZSH_FNDIR%%/Completion/Unix/_gs
+%%ZSH_FNDIR%%/Completion/Unix/_guilt
%%ZSH_FNDIR%%/Completion/Unix/_gzip
%%ZSH_FNDIR%%/Completion/Unix/_hosts
%%ZSH_FNDIR%%/Completion/Unix/_iconv
+%%ZSH_FNDIR%%/Completion/Unix/_id
%%ZSH_FNDIR%%/Completion/Unix/_ifconfig
%%ZSH_FNDIR%%/Completion/Unix/_imagemagick
%%ZSH_FNDIR%%/Completion/Unix/_init_d
@@ -318,6 +338,8 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_knock
%%ZSH_FNDIR%%/Completion/Unix/_kvno
%%ZSH_FNDIR%%/Completion/Unix/_last
+%%ZSH_FNDIR%%/Completion/Unix/_ld_debug
+%%ZSH_FNDIR%%/Completion/Unix/_ldd
%%ZSH_FNDIR%%/Completion/Unix/_less
%%ZSH_FNDIR%%/Completion/Unix/_links
%%ZSH_FNDIR%%/Completion/Unix/_list_files
@@ -334,6 +356,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_mailboxes
%%ZSH_FNDIR%%/Completion/Unix/_make
%%ZSH_FNDIR%%/Completion/Unix/_man
+%%ZSH_FNDIR%%/Completion/Unix/_md5sum
%%ZSH_FNDIR%%/Completion/Unix/_mencal
%%ZSH_FNDIR%%/Completion/Unix/_mercurial
%%ZSH_FNDIR%%/Completion/Unix/_metaflac
@@ -361,6 +384,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_other_accounts
%%ZSH_FNDIR%%/Completion/Unix/_pack
%%ZSH_FNDIR%%/Completion/Unix/_patch
+%%ZSH_FNDIR%%/Completion/Unix/_path_commands
%%ZSH_FNDIR%%/Completion/Unix/_path_files
%%ZSH_FNDIR%%/Completion/Unix/_pax
%%ZSH_FNDIR%%/Completion/Unix/_pbm
@@ -390,11 +414,13 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_quilt
%%ZSH_FNDIR%%/Completion/Unix/_raggle
%%ZSH_FNDIR%%/Completion/Unix/_rake
+%%ZSH_FNDIR%%/Completion/Unix/_ranlib
%%ZSH_FNDIR%%/Completion/Unix/_rar
%%ZSH_FNDIR%%/Completion/Unix/_rcs
%%ZSH_FNDIR%%/Completion/Unix/_renice
-%%ZSH_FNDIR%%/Completion/Unix/_rlogin
%%ZSH_FNDIR%%/Completion/Unix/_ri
+%%ZSH_FNDIR%%/Completion/Unix/_rlogin
+%%ZSH_FNDIR%%/Completion/Unix/_rrdtool
%%ZSH_FNDIR%%/Completion/Unix/_rsync
%%ZSH_FNDIR%%/Completion/Unix/_rubber
%%ZSH_FNDIR%%/Completion/Unix/_ruby
@@ -441,8 +467,10 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Unix/_tracepath
%%ZSH_FNDIR%%/Completion/Unix/_twisted
%%ZSH_FNDIR%%/Completion/Unix/_unace
+%%ZSH_FNDIR%%/Completion/Unix/_uname
%%ZSH_FNDIR%%/Completion/Unix/_unexpand
%%ZSH_FNDIR%%/Completion/Unix/_uniq
+%%ZSH_FNDIR%%/Completion/Unix/_units
%%ZSH_FNDIR%%/Completion/Unix/_urls
%%ZSH_FNDIR%%/Completion/Unix/_user_admin
%%ZSH_FNDIR%%/Completion/Unix/_user_at_host
@@ -478,8 +506,8 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/X/_nedit
%%ZSH_FNDIR%%/Completion/X/_netscape
%%ZSH_FNDIR%%/Completion/X/_qiv
-%%ZSH_FNDIR%%/Completion/X/_urxvt
%%ZSH_FNDIR%%/Completion/X/_setxkbmap
+%%ZSH_FNDIR%%/Completion/X/_urxvt
%%ZSH_FNDIR%%/Completion/X/_vnc
%%ZSH_FNDIR%%/Completion/X/_x_arguments
%%ZSH_FNDIR%%/Completion/X/_x_borderwidth
@@ -506,6 +534,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/X/_xloadimage
%%ZSH_FNDIR%%/Completion/X/_xmodmap
%%ZSH_FNDIR%%/Completion/X/_xpdf
+%%ZSH_FNDIR%%/Completion/X/_xrandr
%%ZSH_FNDIR%%/Completion/X/_xscreensaver
%%ZSH_FNDIR%%/Completion/X/_xset
%%ZSH_FNDIR%%/Completion/X/_xt_arguments
@@ -527,6 +556,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Zsh/_compdef
%%ZSH_FNDIR%%/Completion/Zsh/_condition
%%ZSH_FNDIR%%/Completion/Zsh/_default
+%%ZSH_FNDIR%%/Completion/Zsh/_delimiters
%%ZSH_FNDIR%%/Completion/Zsh/_directory_stack
%%ZSH_FNDIR%%/Completion/Zsh/_dirs
%%ZSH_FNDIR%%/Completion/Zsh/_disable
@@ -539,7 +569,10 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Completion/Zsh/_file_descriptors
%%ZSH_FNDIR%%/Completion/Zsh/_first
%%ZSH_FNDIR%%/Completion/Zsh/_functions
+%%ZSH_FNDIR%%/Completion/Zsh/_globqual_delims
+%%ZSH_FNDIR%%/Completion/Zsh/_globquals
%%ZSH_FNDIR%%/Completion/Zsh/_hash
+%%ZSH_FNDIR%%/Completion/Zsh/_history_modifiers
%%ZSH_FNDIR%%/Completion/Zsh/_in_vared
%%ZSH_FNDIR%%/Completion/Zsh/_jobs
%%ZSH_FNDIR%%/Completion/Zsh/_jobs_bg
@@ -609,7 +642,12 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Misc/promptnl
%%ZSH_FNDIR%%/Misc/relative
%%ZSH_FNDIR%%/Misc/run-help
+%%ZSH_FNDIR%%/Misc/run-help-git
+%%ZSH_FNDIR%%/Misc/run-help-svk
+%%ZSH_FNDIR%%/Misc/run-help-svn
+%%ZSH_FNDIR%%/Misc/sticky-note
%%ZSH_FNDIR%%/Misc/tetris
+%%ZSH_FNDIR%%/Misc/xtermctl
%%ZSH_FNDIR%%/Misc/zargs
%%ZSH_FNDIR%%/Misc/zcalc
%%ZSH_FNDIR%%/Misc/zed
@@ -631,6 +669,7 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Prompts/prompt_off_setup
%%ZSH_FNDIR%%/Prompts/prompt_oliver_setup
%%ZSH_FNDIR%%/Prompts/prompt_redhat_setup
+%%ZSH_FNDIR%%/Prompts/prompt_special_chars
%%ZSH_FNDIR%%/Prompts/prompt_suse_setup
%%ZSH_FNDIR%%/Prompts/prompt_walters_setup
%%ZSH_FNDIR%%/Prompts/prompt_zefram_setup
@@ -706,8 +745,8 @@ bin/zsh-%%ZSH_VER%%
%%ZSH_FNDIR%%/Zle/keeper
%%ZSH_FNDIR%%/Zle/keymap+widget
%%ZSH_FNDIR%%/Zle/kill-word-match
-%%ZSH_FNDIR%%/Zle/match-words-by-style
%%ZSH_FNDIR%%/Zle/match-word-context
+%%ZSH_FNDIR%%/Zle/match-words-by-style
%%ZSH_FNDIR%%/Zle/modify-current-argument
%%ZSH_FNDIR%%/Zle/narrow-to-region
%%ZSH_FNDIR%%/Zle/narrow-to-region-invisible