aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-15 22:22:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-15 22:22:04 +0000
commita4f5f55d835a61ade12d8dd8ca7486d55d6a8a4b (patch)
treeee6e67f140a8d964a017bf37a1c946017612f101 /shells
parentfe8a244970321b99e18bcaad7a7977a251e55812 (diff)
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 14c5935492e9..fa21a6c6134b 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -66,6 +66,10 @@ MULTIBYTE_CONFIGURE_ENABLE= multibyte
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
+CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
+.endif
+
.if ${PORT_OPTIONS:MDOCS}
INFO= zsh
.endif
@@ -116,7 +120,8 @@ post-install:
.endif
${STAGEDIR}${PREFIX}/bin/zsh -fc ' \
setopt extendedglob nomark_dirs; \
- for i in ${STAGEDIR}${DATADIR}/${ZSH_VER}/functions/**/*(/) ; do \
+ cd ${STAGEDIR}/${DATADIR}/${ZSH_VER} ; \
+ for i in functions/**/*(/) ; do \
zcompile -U -M $$i.zwc $$i/*~*.zwc(^/) ; \
${CHMOD} 644 $$i.zwc ; \
done'