aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-03-02 20:54:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-03-02 20:54:04 +0000
commit626fe03bf450fb204c2d5f049ca9c1d4aa7bffa5 (patch)
tree07f8dd7970d0526c55c98bd3ec07a83770ee35f3 /shells
parentdfd07fd791ec93aa89e329a8f5662da5fe52a946 (diff)
downloadports-626fe03bf450fb204c2d5f049ca9c1d4aa7bffa5.tar.gz
ports-626fe03bf450fb204c2d5f049ca9c1d4aa7bffa5.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/tcsh_nls/Makefile79
-rw-r--r--shells/tcsh_nls/pkg-descr1
3 files changed, 81 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 71235301b996..6085ecd8efc9 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -36,6 +36,7 @@
SUBDIR += sash
SUBDIR += scponly
SUBDIR += shell-include
+ SUBDIR += tcsh_nls
SUBDIR += tcshrc
SUBDIR += v7sh
SUBDIR += viewglob
diff --git a/shells/tcsh_nls/Makefile b/shells/tcsh_nls/Makefile
new file mode 100644
index 000000000000..581bd6a73889
--- /dev/null
+++ b/shells/tcsh_nls/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: tcsh_nls
+# Date created: 14 Feb 2006
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcsh_nls
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= Misc NLS catalogs for tcsh which requires libiconv
+
+USE_ICONV= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/nls/de_AT.UTF-8/tcsh.cat \
+ share/nls/de_CH.UTF-8/tcsh.cat \
+ share/nls/de_DE.UTF-8/tcsh.cat \
+ share/nls/el_GR.UTF-8/tcsh.cat \
+ share/nls/es_ES.UTF-8/tcsh.cat \
+ share/nls/et_EE.UTF-8/tcsh.cat \
+ share/nls/fi_FI.UTF-8/tcsh.cat \
+ share/nls/fr_BE.UTF-8/tcsh.cat \
+ share/nls/fr_CA.UTF-8/tcsh.cat \
+ share/nls/fr_CH.UTF-8/tcsh.cat \
+ share/nls/fr_FR.UTF-8/tcsh.cat \
+ share/nls/it_CH.UTF-8/tcsh.cat \
+ share/nls/it_IT.UTF-8/tcsh.cat \
+ share/nls/ja_JP.SJIS/tcsh.cat \
+ share/nls/ja_JP.UTF-8/tcsh.cat \
+ share/nls/ru_RU.CP1251/tcsh.cat \
+ share/nls/ru_RU.CP866/tcsh.cat \
+ share/nls/ru_RU.ISO8859-5/tcsh.cat \
+ share/nls/ru_RU.UTF-8/tcsh.cat \
+ share/nls/uk_UA.ISO8859-5/tcsh.cat \
+ share/nls/uk_UA.UTF-8/tcsh.cat
+
+NLS_CATALOGS= de_DE.ISO8859-1:de_AT.UTF-8 \
+ de_DE.ISO8859-1:de_CH.UTF-8 \
+ de_DE.ISO8859-1:de_DE.UTF-8 \
+ el_GR.ISO8859-7:el_GR.UTF-8 \
+ es_ES.ISO8859-1:es_ES.UTF-8 \
+ et_EE.ISO8859-15:et_EE.UTF-8 \
+ fi_FI.ISO8859-1:fi_FI.UTF-8 \
+ fr_FR.ISO8859-1:fr_BE.UTF-8 \
+ fr_FR.ISO8859-1:fr_CA.UTF-8 \
+ fr_FR.ISO8859-1:fr_CH.UTF-8 \
+ fr_FR.ISO8859-1:fr_FR.UTF-8 \
+ it_IT.ISO8859-1:it_CH.UTF-8 \
+ it_IT.ISO8859-1:it_IT.UTF-8 \
+ ja_JP.eucJP:ja_JP.SJIS \
+ ja_JP.eucJP:ja_JP.UTF-8 \
+ ru_RU.KOI8-R:ru_RU.CP1251 \
+ ru_RU.KOI8-R:ru_RU.CP866 \
+ ru_RU.KOI8-R:ru_RU.ISO8859-5 \
+ ru_RU.KOI8-R:ru_RU.UTF-8 \
+ uk_UA.KOI8-U:uk_UA.ISO8859-5 \
+ uk_UA.KOI8-U:uk_UA.UTF-8 \
+
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 700000 && ${OSVERSION} < 700014) || ${OSVERSION} < 600105
+IGNORE= needs FreeBSD 6.1 or 7
+.endif
+
+do-fetch:
+ @${DO_NADA}
+
+do-install:
+ @for i in ${NLS_CATALOGS}; do \
+ ${LN} -sf /usr/share/nls/$${i%%:*}/tcsh.cat \
+ ${PREFIX}/share/nls/$${i##*:}/tcsh.cat; \
+ done
+
+.include <bsd.port.post.mk>
diff --git a/shells/tcsh_nls/pkg-descr b/shells/tcsh_nls/pkg-descr
new file mode 100644
index 000000000000..5d90d29e632c
--- /dev/null
+++ b/shells/tcsh_nls/pkg-descr
@@ -0,0 +1 @@
+Misc NLS catalogs for tcsh which requires libiconv.