aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-03-19 16:30:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-03-19 16:30:56 +0000
commitb0dbf985769ff57b897710abcdbae9baae6c7e48 (patch)
tree423631191482e504264e93d2ef150b729166517b /shells
parentaa039978161208d7e7fe6e5124fa294cda7c00fd (diff)
downloadports-b0dbf985769ff57b897710abcdbae9baae6c7e48.tar.gz
ports-b0dbf985769ff57b897710abcdbae9baae6c7e48.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fish/Makefile8
-rw-r--r--shells/fish/pkg-deinstall7
2 files changed, 8 insertions, 7 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index f6e501e0817c..fb478a1e9fe7 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fish
PORTVERSION= 1.23.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= shells
MASTER_SITES= SF
@@ -78,10 +78,4 @@ post-install:
${ECHO_CMD} '${PREFIX}/bin/${PORTNAME}' >> /etc/shells; \
fi
-post-deinstall:
- ${CP} /etc/shells /etc/shells.bak
- ${GREP} -v '${PREFIX}/bin/${PORTNAME}' /etc/shells.bak \
- >> /etc/shells
- ${RM} -f /etc/shells.bak
-
.include <bsd.port.post.mk>
diff --git a/shells/fish/pkg-deinstall b/shells/fish/pkg-deinstall
new file mode 100644
index 000000000000..a3c046a0658c
--- /dev/null
+++ b/shells/fish/pkg-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ /bin/cp /etc/shells /etc/shells.bak
+ /usr/bin/grep -v '/usr/local/bin/fish' /etc/shells.bak >> /etc/shells
+ /bin/rm -f /etc/shells.bak
+fi