aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
commit053520453dc374b6c02b15ad78efd7e0e52867f6 (patch)
tree9715c5e142788fa00b976d2c5a75b984e005be15 /shells
parent353346c8f2676860eb119c92298802aa94479b3a (diff)
downloadports-053520453dc374b6c02b15ad78efd7e0e52867f6.tar.gz
ports-053520453dc374b6c02b15ad78efd7e0e52867f6.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash2/Makefile2
-rw-r--r--shells/flash/Makefile14
-rw-r--r--shells/viewglob/Makefile8
3 files changed, 2 insertions, 22 deletions
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index f0df1e681498..27966ed8d2f5 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -52,14 +52,12 @@ MAN1= bash.1 bashbug.1
INFO= bash
post-patch:
-.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
@${RM} -rf ${WRKSRC}/lib/readline/*.[ch] \
${WRKSRC}/lib/readline/Makefile
@${TOUCH} ${WRKSRC}/lib/readline/Makefile.in
@${REINPLACE_CMD} -E "s,^((RL|HIST)_LIBSRC = ).*,\1/usr/include/readline," ${WRKSRC}/Makefile.in
-.endif
update-etc-shells:
@${ECHO_MSG} "updating /etc/shells"
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index ed8714b263ad..ec05707f1f10 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -14,13 +14,6 @@ MASTER_SITES= http://www.netsoc.ucd.ie/flash/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A ncurses-based restriction shell
-.include <bsd.port.pre.mk>
-
-# outdated version of ncurses in non-CURRENT
-.if ${OSVERSION} < 400000
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -rdynamic" \
@@ -37,11 +30,6 @@ DATA= system.bg.Netsoc.3 system.bg.Netsoc.4 system.flashlogin \
system.maillogin system.module system.module.9798 system.rc \
system.rc.mailshell
-.if ${OSVERSION} < 400000
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_NCURSES_NCURSES_H" \
- LDFLAGS="-L${LOCALBASE}/lib"
-.endif
-
post-patch:
.for file in ${SCRIPT}
@${REINPLACE_CMD} -e "s:/usr/slocal:${PREFIX}:g" ${WRKSRC}/orcasetup/${file}
@@ -72,4 +60,4 @@ post-install:
@${RM} /etc/shells.bak
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
index 64e88886dea0..aad4fd5107a8 100644
--- a/shells/viewglob/Makefile
+++ b/shells/viewglob/Makefile
@@ -23,10 +23,4 @@ GNU_CONFIGURE= yes
MAN1= vgd.1 vgseer.1 viewglob.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x, it's missing posix_openpt and ptsname functions
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>