aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2010-09-04 17:51:46 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2010-09-04 17:51:46 +0000
commit293b2c979ed4b1ec4befb07330bf2333930d9ad3 (patch)
treed36bca2650a44539460c850f96d537c84c614919 /shells
parent7cce6f025f6f52fc90b70fef14a0eaf80bec632f (diff)
downloadports-293b2c979ed4b1ec4befb07330bf2333930d9ad3.tar.gz
ports-293b2c979ed4b1ec4befb07330bf2333930d9ad3.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion-classic/Makefile47
-rw-r--r--shells/bash-completion-classic/distinfo6
-rw-r--r--shells/bash-completion-classic/files/patch-bash_completion19
-rw-r--r--shells/bash-completion-classic/files/patch-contrib_portupgrade15
-rw-r--r--shells/bash-completion-classic/files/pkg-message.in18
-rw-r--r--shells/bash-completion-classic/pkg-descr10
-rw-r--r--shells/bash-completion/Makefile47
-rw-r--r--shells/bash-completion/distinfo6
-rw-r--r--shells/bash-completion/files/patch-bash_completion19
-rw-r--r--shells/bash-completion/files/patch-contrib_portupgrade15
-rw-r--r--shells/bash-completion/files/pkg-message.in18
-rw-r--r--shells/bash-completion/pkg-descr10
12 files changed, 104 insertions, 126 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 566429633c12..6fffcfb66900 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -5,47 +5,36 @@
# $FreeBSD$
#
-PORTNAME= bash-completion
-PORTVERSION= 20060301
-PORTREVISION= 3
-CATEGORIES= shells
-MASTER_SITES= http://www.caliban.org/files/bash/
+PORTNAME= bash-completion
+PORTVERSION= 1.2
+PORTEPOCH= 1
+CATEGORIES= shells
+MASTER_SITES= http://bash-completion.alioth.debian.org/files/
-MAINTAINER= kirk@strauser.com
-COMMENT= Programmable completion library for Bash 2.04 and up
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Programmable completion library for Bash
-WRKSRC= ${WRKDIR}/bash_completion
-NO_BUILD= yes
-
-SUB_FILES= pkg-message
-PLIST_FILES= etc/bash_completion
-
-OPTIONS= GSED "Use GNU sed to enable additional completions" off
-
-.include <bsd.port.pre.mk>
+USE_BZIP2= yes
+SUB_FILES= pkg-message
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-.if defined(WITH_GSED)
-RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
-.endif
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
- s|/usr\(/sbin/postconf\)|${LOCALBASE}\1|g; \
- s|/usr\(/lib/rpm/macros\)|${LOCALBASE}\1|g; \
+ s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
+ s|/usr\(/lib/rpm/macros\)|${PREFIX}\1|g; \
s|/usr/share\(/ssl/openssl.cnf\)|/etc\1|g; \
s|/usr/ports|${PORTSDIR}|g; \
- s|/usr/lib\(/aspell\)|${LOCALBASE}/share\1|g; \
- s|/usr/share/info|&:${LOCALBASE}/info|g; \
+ s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
+ s|/usr/share/info|&:${PREFIX}/info|g; \
+ s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
s|\(FLAC\)|\1\|flv\|FLV|' \
- ${WRKSRC}/bash_completion
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc
+ ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/bash-completion-classic/distinfo b/shells/bash-completion-classic/distinfo
index 285a36c0e2d4..963f9b288a63 100644
--- a/shells/bash-completion-classic/distinfo
+++ b/shells/bash-completion-classic/distinfo
@@ -1,3 +1,3 @@
-MD5 (bash-completion-20060301.tar.gz) = 9bca1cf97e8f8c73e3ef560cc9dead21
-SHA256 (bash-completion-20060301.tar.gz) = 29b78834b975b29810f0bf1f15e5d3a6c003a137cfac7fea671bfaf8f58f5c0d
-SIZE (bash-completion-20060301.tar.gz) = 123300
+MD5 (bash-completion-1.2.tar.bz2) = 88c022a98a02a02293716f840eadd884
+SHA256 (bash-completion-1.2.tar.bz2) = dd09a86134204e4c6b860bfbd5ee8ac46c6b32a54478b967dcf81e8a7839d354
+SIZE (bash-completion-1.2.tar.bz2) = 197574
diff --git a/shells/bash-completion-classic/files/patch-bash_completion b/shells/bash-completion-classic/files/patch-bash_completion
deleted file mode 100644
index 3d06ec6850e3..000000000000
--- a/shells/bash-completion-classic/files/patch-bash_completion
+++ /dev/null
@@ -1,19 +0,0 @@
---- bash_completion.old Sat Sep 23 20:42:29 2006
-+++ bash_completion Sun Sep 24 10:55:26 2006
-@@ -5485,14 +5485,10 @@
- local cur portsdir prev indexfile
- local -a COMPREPLY2
-
-- portsdir=${PORTSDIR:-/usr/ports}/
-+ portsdir=${PORTSDIR:-/usr/ports}
- cur=${COMP_WORDS[COMP_CWORD]}
- prev=${COMP_WORDS[COMP_CWORD-1]}
-- # First try INDEX-5
-- indexfile=$portsdir/INDEX-5
-- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
-- [ "${OSTYPE%.*}" = "freebsd5" -a -f $indexfile ] ||
-- indexfile=$portsdir/INDEX
-+ indexfile="${portsdir}/INDEX-${OSTYPE:7:1}"
-
- [ "$prev" = "-l" -o "$prev" = "-L" -o "$prev" = "-o" ] && return 0
-
diff --git a/shells/bash-completion-classic/files/patch-contrib_portupgrade b/shells/bash-completion-classic/files/patch-contrib_portupgrade
new file mode 100644
index 000000000000..caa9b91d5800
--- /dev/null
+++ b/shells/bash-completion-classic/files/patch-contrib_portupgrade
@@ -0,0 +1,15 @@
+--- contrib/portupgrade.orig 2010-09-04 02:35:04.000000000 -0400
++++ contrib/portupgrade 2010-09-04 02:38:00.000000000 -0400
+@@ -26,11 +26,7 @@
+
+ portsdir=${PORTSDIR:-/usr/ports}/
+ _get_comp_words_by_ref cur prev
+- # First try INDEX-5
+- indexfile=$portsdir/INDEX-5
+- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
+- [[ "${OSTYPE%.*}" == freebsd5 && -f $indexfile ]] ||
+- indexfile=$portsdir/INDEX
++ indexfile="$(portsdir)/INDEX-${OSTYPE:8:1}"
+
+ [[ "$prev" == -l || "$prev" == -L || "$prev" == -o ]] && return 0
+
diff --git a/shells/bash-completion-classic/files/pkg-message.in b/shells/bash-completion-classic/files/pkg-message.in
index 7bbf0ac073f2..496b2f38a789 100644
--- a/shells/bash-completion-classic/files/pkg-message.in
+++ b/shells/bash-completion-classic/files/pkg-message.in
@@ -1,9 +1,15 @@
-The programmable completion library is not enabled by default for various
-reasons. To use it, you should source %%PREFIX%%/etc/bash_completion from
-your .bashrc file. For example:
+=====================================================================
- if [ -f %%PREFIX%%/etc/bash_completion ]; then
- . %%PREFIX%%/etc/bash_completion
- fi
+You must enable the bash programmable completion library yourself!
+
+ * source %%PREFIX%%/etc/bash_completion from your .bashrc file
+
+ if [ -f %%PREFIX%%/etc/bash_completion ]; then
+ . %%PREFIX%%/etc/bash_completion
+ fi
+
+ * or, run %%PREFIX%%/bin/bash_completion.sh from your .bashrc
+
+=====================================================================
diff --git a/shells/bash-completion-classic/pkg-descr b/shells/bash-completion-classic/pkg-descr
index 4f48a96869d3..f54b05e43e21 100644
--- a/shells/bash-completion-classic/pkg-descr
+++ b/shells/bash-completion-classic/pkg-descr
@@ -1,7 +1,5 @@
-This is a programmable completion library for bash2 users. It features the
-ability to tab-complete arguments for many common programs.
+This is a programmable completion convenience library for the bash(1)
+shell. It features the ability to tab-complete arguments for many common
+programs.
-WWW: http://www.caliban.org/bash/index.shtml
-
-- Kirk Strauser
-kirk@strauser.com
+WWW: http://bash-completion.alioth.debian.org/
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 566429633c12..6fffcfb66900 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -5,47 +5,36 @@
# $FreeBSD$
#
-PORTNAME= bash-completion
-PORTVERSION= 20060301
-PORTREVISION= 3
-CATEGORIES= shells
-MASTER_SITES= http://www.caliban.org/files/bash/
+PORTNAME= bash-completion
+PORTVERSION= 1.2
+PORTEPOCH= 1
+CATEGORIES= shells
+MASTER_SITES= http://bash-completion.alioth.debian.org/files/
-MAINTAINER= kirk@strauser.com
-COMMENT= Programmable completion library for Bash 2.04 and up
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Programmable completion library for Bash
-WRKSRC= ${WRKDIR}/bash_completion
-NO_BUILD= yes
-
-SUB_FILES= pkg-message
-PLIST_FILES= etc/bash_completion
-
-OPTIONS= GSED "Use GNU sed to enable additional completions" off
-
-.include <bsd.port.pre.mk>
+USE_BZIP2= yes
+SUB_FILES= pkg-message
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-.if defined(WITH_GSED)
-RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
-.endif
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
- s|/usr\(/sbin/postconf\)|${LOCALBASE}\1|g; \
- s|/usr\(/lib/rpm/macros\)|${LOCALBASE}\1|g; \
+ s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
+ s|/usr\(/lib/rpm/macros\)|${PREFIX}\1|g; \
s|/usr/share\(/ssl/openssl.cnf\)|/etc\1|g; \
s|/usr/ports|${PORTSDIR}|g; \
- s|/usr/lib\(/aspell\)|${LOCALBASE}/share\1|g; \
- s|/usr/share/info|&:${LOCALBASE}/info|g; \
+ s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
+ s|/usr/share/info|&:${PREFIX}/info|g; \
+ s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
s|\(FLAC\)|\1\|flv\|FLV|' \
- ${WRKSRC}/bash_completion
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc
+ ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/bash-completion/distinfo b/shells/bash-completion/distinfo
index 285a36c0e2d4..963f9b288a63 100644
--- a/shells/bash-completion/distinfo
+++ b/shells/bash-completion/distinfo
@@ -1,3 +1,3 @@
-MD5 (bash-completion-20060301.tar.gz) = 9bca1cf97e8f8c73e3ef560cc9dead21
-SHA256 (bash-completion-20060301.tar.gz) = 29b78834b975b29810f0bf1f15e5d3a6c003a137cfac7fea671bfaf8f58f5c0d
-SIZE (bash-completion-20060301.tar.gz) = 123300
+MD5 (bash-completion-1.2.tar.bz2) = 88c022a98a02a02293716f840eadd884
+SHA256 (bash-completion-1.2.tar.bz2) = dd09a86134204e4c6b860bfbd5ee8ac46c6b32a54478b967dcf81e8a7839d354
+SIZE (bash-completion-1.2.tar.bz2) = 197574
diff --git a/shells/bash-completion/files/patch-bash_completion b/shells/bash-completion/files/patch-bash_completion
deleted file mode 100644
index 3d06ec6850e3..000000000000
--- a/shells/bash-completion/files/patch-bash_completion
+++ /dev/null
@@ -1,19 +0,0 @@
---- bash_completion.old Sat Sep 23 20:42:29 2006
-+++ bash_completion Sun Sep 24 10:55:26 2006
-@@ -5485,14 +5485,10 @@
- local cur portsdir prev indexfile
- local -a COMPREPLY2
-
-- portsdir=${PORTSDIR:-/usr/ports}/
-+ portsdir=${PORTSDIR:-/usr/ports}
- cur=${COMP_WORDS[COMP_CWORD]}
- prev=${COMP_WORDS[COMP_CWORD-1]}
-- # First try INDEX-5
-- indexfile=$portsdir/INDEX-5
-- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
-- [ "${OSTYPE%.*}" = "freebsd5" -a -f $indexfile ] ||
-- indexfile=$portsdir/INDEX
-+ indexfile="${portsdir}/INDEX-${OSTYPE:7:1}"
-
- [ "$prev" = "-l" -o "$prev" = "-L" -o "$prev" = "-o" ] && return 0
-
diff --git a/shells/bash-completion/files/patch-contrib_portupgrade b/shells/bash-completion/files/patch-contrib_portupgrade
new file mode 100644
index 000000000000..caa9b91d5800
--- /dev/null
+++ b/shells/bash-completion/files/patch-contrib_portupgrade
@@ -0,0 +1,15 @@
+--- contrib/portupgrade.orig 2010-09-04 02:35:04.000000000 -0400
++++ contrib/portupgrade 2010-09-04 02:38:00.000000000 -0400
+@@ -26,11 +26,7 @@
+
+ portsdir=${PORTSDIR:-/usr/ports}/
+ _get_comp_words_by_ref cur prev
+- # First try INDEX-5
+- indexfile=$portsdir/INDEX-5
+- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
+- [[ "${OSTYPE%.*}" == freebsd5 && -f $indexfile ]] ||
+- indexfile=$portsdir/INDEX
++ indexfile="$(portsdir)/INDEX-${OSTYPE:8:1}"
+
+ [[ "$prev" == -l || "$prev" == -L || "$prev" == -o ]] && return 0
+
diff --git a/shells/bash-completion/files/pkg-message.in b/shells/bash-completion/files/pkg-message.in
index 7bbf0ac073f2..496b2f38a789 100644
--- a/shells/bash-completion/files/pkg-message.in
+++ b/shells/bash-completion/files/pkg-message.in
@@ -1,9 +1,15 @@
-The programmable completion library is not enabled by default for various
-reasons. To use it, you should source %%PREFIX%%/etc/bash_completion from
-your .bashrc file. For example:
+=====================================================================
- if [ -f %%PREFIX%%/etc/bash_completion ]; then
- . %%PREFIX%%/etc/bash_completion
- fi
+You must enable the bash programmable completion library yourself!
+
+ * source %%PREFIX%%/etc/bash_completion from your .bashrc file
+
+ if [ -f %%PREFIX%%/etc/bash_completion ]; then
+ . %%PREFIX%%/etc/bash_completion
+ fi
+
+ * or, run %%PREFIX%%/bin/bash_completion.sh from your .bashrc
+
+=====================================================================
diff --git a/shells/bash-completion/pkg-descr b/shells/bash-completion/pkg-descr
index 4f48a96869d3..f54b05e43e21 100644
--- a/shells/bash-completion/pkg-descr
+++ b/shells/bash-completion/pkg-descr
@@ -1,7 +1,5 @@
-This is a programmable completion library for bash2 users. It features the
-ability to tab-complete arguments for many common programs.
+This is a programmable completion convenience library for the bash(1)
+shell. It features the ability to tab-complete arguments for many common
+programs.
-WWW: http://www.caliban.org/bash/index.shtml
-
-- Kirk Strauser
-kirk@strauser.com
+WWW: http://bash-completion.alioth.debian.org/