aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2019-06-16 15:40:08 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2019-06-16 15:40:08 +0000
commit2e29b5e9340901ae7b08f7eab367e394fa736418 (patch)
tree28fefe1ac0f3bc238489a097b61d49194dd83c50 /shells
parenta64f91a4b2754f553ecd23c1c3034c39ca0172d0 (diff)
downloadports-2e29b5e9340901ae7b08f7eab367e394fa736418.tar.gz
ports-2e29b5e9340901ae7b08f7eab367e394fa736418.zip
New port: shells/yash
Yash, yet another shell, is a POSIX-compliant command line shell. Yash is intended to be the most POSIX-compliant shell in the world while supporting features for daily interactive and scripting use. Notable features are: * Global aliases * Arrays * Socket redirection, pipeline redirection, and process redirection * Brace expansion and extended globbing * Fractional numbers in arithmetic expansion * Prompt command and command-not-found handler * Command line completion with predefined completion scripts for more than 100 commands * Command line prediction based on command history WWW: https://yash.osdn.jp/index.html.en
Notes
Notes: svn path=/head/; revision=504351
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/yash/Makefile27
-rw-r--r--shells/yash/distinfo3
-rw-r--r--shells/yash/pkg-descr15
-rw-r--r--shells/yash/pkg-plist230
5 files changed, 276 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index bd83878b7093..dbb41353e428 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -53,6 +53,7 @@
SUBDIR += vshnu
SUBDIR += wcd
SUBDIR += xonsh
+ SUBDIR += yash
SUBDIR += zsh
SUBDIR += zsh-antigen
SUBDIR += zsh-autosuggestions
diff --git a/shells/yash/Makefile b/shells/yash/Makefile
new file mode 100644
index 000000000000..198cf18c39da
--- /dev/null
+++ b/shells/yash/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= yash
+DISTVERSION= 2.48
+CATEGORIES= shells
+MASTER_SITES= OSDN/yash/70439
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= POSIX-compliant command line shell
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= tar:xz
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/shells/yash/distinfo b/shells/yash/distinfo
new file mode 100644
index 000000000000..efa6b191bb63
--- /dev/null
+++ b/shells/yash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560694297
+SHA256 (yash-2.48.tar.xz) = f46294d77c5a646405db20a6dc3d16bc1ed109b061b2a508081ce483153c1e8d
+SIZE (yash-2.48.tar.xz) = 736280
diff --git a/shells/yash/pkg-descr b/shells/yash/pkg-descr
new file mode 100644
index 000000000000..6f03bae80bc1
--- /dev/null
+++ b/shells/yash/pkg-descr
@@ -0,0 +1,15 @@
+Yash, yet another shell, is a POSIX-compliant command line shell.
+Yash is intended to be the most POSIX-compliant shell in the world
+while supporting features for daily interactive and scripting use.
+Notable features are:
+* Global aliases
+* Arrays
+* Socket redirection, pipeline redirection, and process redirection
+* Brace expansion and extended globbing
+* Fractional numbers in arithmetic expansion
+* Prompt command and command-not-found handler
+* Command line completion with predefined completion scripts for more
+ than 100 commands
+* Command line prediction based on command history
+
+WWW: https://yash.osdn.jp/index.html.en
diff --git a/shells/yash/pkg-plist b/shells/yash/pkg-plist
new file mode 100644
index 000000000000..49c97343f1db
--- /dev/null
+++ b/shells/yash/pkg-plist
@@ -0,0 +1,230 @@
+bin/yash
+man/ja/man1/yash.1.gz
+man/man1/yash.1.gz
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/yash.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/yash.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/yash.mo
+%%DATADIR%%/completion/INIT
+%%DATADIR%%/completion/[
+%%DATADIR%%/completion/_backup
+%%DATADIR%%/completion/_blocksize
+%%DATADIR%%/completion/_bsd
+%%DATADIR%%/completion/_dot
+%%DATADIR%%/completion/alias
+%%DATADIR%%/completion/array
+%%DATADIR%%/completion/awk
+%%DATADIR%%/completion/basename
+%%DATADIR%%/completion/bash
+%%DATADIR%%/completion/bg
+%%DATADIR%%/completion/bindkey
+%%DATADIR%%/completion/break
+%%DATADIR%%/completion/bsdtar
+%%DATADIR%%/completion/carthage
+%%DATADIR%%/completion/cat
+%%DATADIR%%/completion/cd
+%%DATADIR%%/completion/chgrp
+%%DATADIR%%/completion/chmod
+%%DATADIR%%/completion/chown
+%%DATADIR%%/completion/chsh
+%%DATADIR%%/completion/cmp
+%%DATADIR%%/completion/comm
+%%DATADIR%%/completion/command
+%%DATADIR%%/completion/complete
+%%DATADIR%%/completion/configure
+%%DATADIR%%/completion/continue
+%%DATADIR%%/completion/cp
+%%DATADIR%%/completion/crontab
+%%DATADIR%%/completion/csplit
+%%DATADIR%%/completion/cut
+%%DATADIR%%/completion/dash
+%%DATADIR%%/completion/date
+%%DATADIR%%/completion/df
+%%DATADIR%%/completion/diff
+%%DATADIR%%/completion/dirs
+%%DATADIR%%/completion/disown
+%%DATADIR%%/completion/dnf
+%%DATADIR%%/completion/du
+%%DATADIR%%/completion/echo
+%%DATADIR%%/completion/ed
+%%DATADIR%%/completion/egrep
+%%DATADIR%%/completion/env
+%%DATADIR%%/completion/eval
+%%DATADIR%%/completion/eview
+%%DATADIR%%/completion/evim
+%%DATADIR%%/completion/ex
+%%DATADIR%%/completion/exec
+%%DATADIR%%/completion/exit
+%%DATADIR%%/completion/expand
+%%DATADIR%%/completion/export
+%%DATADIR%%/completion/fc
+%%DATADIR%%/completion/fg
+%%DATADIR%%/completion/fgrep
+%%DATADIR%%/completion/file
+%%DATADIR%%/completion/find
+%%DATADIR%%/completion/fold
+%%DATADIR%%/completion/gawk
+%%DATADIR%%/completion/getconf
+%%DATADIR%%/completion/getopts
+%%DATADIR%%/completion/gex
+%%DATADIR%%/completion/git
+%%DATADIR%%/completion/git-add
+%%DATADIR%%/completion/git-am
+%%DATADIR%%/completion/git-annotate
+%%DATADIR%%/completion/git-apply
+%%DATADIR%%/completion/git-bisect
+%%DATADIR%%/completion/git-blame
+%%DATADIR%%/completion/git-branch
+%%DATADIR%%/completion/git-checkout
+%%DATADIR%%/completion/git-cherry
+%%DATADIR%%/completion/git-cherry-pick
+%%DATADIR%%/completion/git-clean
+%%DATADIR%%/completion/git-clone
+%%DATADIR%%/completion/git-commit
+%%DATADIR%%/completion/git-config
+%%DATADIR%%/completion/git-describe
+%%DATADIR%%/completion/git-diff
+%%DATADIR%%/completion/git-diff-tree
+%%DATADIR%%/completion/git-fetch
+%%DATADIR%%/completion/git-format-patch
+%%DATADIR%%/completion/git-grep
+%%DATADIR%%/completion/git-init
+%%DATADIR%%/completion/git-log
+%%DATADIR%%/completion/git-ls-remote
+%%DATADIR%%/completion/git-merge
+%%DATADIR%%/completion/git-name-rev
+%%DATADIR%%/completion/git-notes
+%%DATADIR%%/completion/git-pull
+%%DATADIR%%/completion/git-push
+%%DATADIR%%/completion/git-rebase
+%%DATADIR%%/completion/git-reflog
+%%DATADIR%%/completion/git-remote
+%%DATADIR%%/completion/git-request-pull
+%%DATADIR%%/completion/git-reset
+%%DATADIR%%/completion/git-rev-list
+%%DATADIR%%/completion/git-rev-parse
+%%DATADIR%%/completion/git-revert
+%%DATADIR%%/completion/git-rm
+%%DATADIR%%/completion/git-show
+%%DATADIR%%/completion/git-show-branch
+%%DATADIR%%/completion/git-stash
+%%DATADIR%%/completion/git-status
+%%DATADIR%%/completion/git-submodule
+%%DATADIR%%/completion/git-svn
+%%DATADIR%%/completion/git-tag
+%%DATADIR%%/completion/git-whatchanged
+%%DATADIR%%/completion/git-worktree
+%%DATADIR%%/completion/gitg
+%%DATADIR%%/completion/gitk
+%%DATADIR%%/completion/gitx
+%%DATADIR%%/completion/gnutar
+%%DATADIR%%/completion/grep
+%%DATADIR%%/completion/gtar
+%%DATADIR%%/completion/gview
+%%DATADIR%%/completion/gvim
+%%DATADIR%%/completion/gvimdiff
+%%DATADIR%%/completion/hash
+%%DATADIR%%/completion/head
+%%DATADIR%%/completion/help
+%%DATADIR%%/completion/history
+%%DATADIR%%/completion/iconv
+%%DATADIR%%/completion/id
+%%DATADIR%%/completion/jobs
+%%DATADIR%%/completion/join
+%%DATADIR%%/completion/kill
+%%DATADIR%%/completion/ksh
+%%DATADIR%%/completion/less
+%%DATADIR%%/completion/ln
+%%DATADIR%%/completion/local
+%%DATADIR%%/completion/locale
+%%DATADIR%%/completion/ls
+%%DATADIR%%/completion/make
+%%DATADIR%%/completion/man
+%%DATADIR%%/completion/mesg
+%%DATADIR%%/completion/mkdir
+%%DATADIR%%/completion/mkfifo
+%%DATADIR%%/completion/mksh
+%%DATADIR%%/completion/more
+%%DATADIR%%/completion/mv
+%%DATADIR%%/completion/nawk
+%%DATADIR%%/completion/newgrp
+%%DATADIR%%/completion/nice
+%%DATADIR%%/completion/nl
+%%DATADIR%%/completion/nohup
+%%DATADIR%%/completion/od
+%%DATADIR%%/completion/passwd
+%%DATADIR%%/completion/paste
+%%DATADIR%%/completion/patch
+%%DATADIR%%/completion/pathchk
+%%DATADIR%%/completion/pgawk
+%%DATADIR%%/completion/ping
+%%DATADIR%%/completion/popd
+%%DATADIR%%/completion/pr
+%%DATADIR%%/completion/printf
+%%DATADIR%%/completion/ps
+%%DATADIR%%/completion/pushd
+%%DATADIR%%/completion/pwd
+%%DATADIR%%/completion/read
+%%DATADIR%%/completion/readonly
+%%DATADIR%%/completion/renice
+%%DATADIR%%/completion/return
+%%DATADIR%%/completion/rgview
+%%DATADIR%%/completion/rgvim
+%%DATADIR%%/completion/rm
+%%DATADIR%%/completion/rmdir
+%%DATADIR%%/completion/rsync
+%%DATADIR%%/completion/rview
+%%DATADIR%%/completion/rvim
+%%DATADIR%%/completion/scp
+%%DATADIR%%/completion/sed
+%%DATADIR%%/completion/set
+%%DATADIR%%/completion/sftp
+%%DATADIR%%/completion/sh
+%%DATADIR%%/completion/shift
+%%DATADIR%%/completion/slogin
+%%DATADIR%%/completion/sort
+%%DATADIR%%/completion/split
+%%DATADIR%%/completion/ssh
+%%DATADIR%%/completion/ssh-add
+%%DATADIR%%/completion/ssh-agent
+%%DATADIR%%/completion/ssh-keygen
+%%DATADIR%%/completion/stty
+%%DATADIR%%/completion/su
+%%DATADIR%%/completion/sudo
+%%DATADIR%%/completion/sudoedit
+%%DATADIR%%/completion/suspend
+%%DATADIR%%/completion/svn
+%%DATADIR%%/completion/tail
+%%DATADIR%%/completion/tar
+%%DATADIR%%/completion/tee
+%%DATADIR%%/completion/test
+%%DATADIR%%/completion/tig
+%%DATADIR%%/completion/time
+%%DATADIR%%/completion/touch
+%%DATADIR%%/completion/tr
+%%DATADIR%%/completion/trap
+%%DATADIR%%/completion/tree
+%%DATADIR%%/completion/type
+%%DATADIR%%/completion/typeset
+%%DATADIR%%/completion/ulimit
+%%DATADIR%%/completion/umask
+%%DATADIR%%/completion/unalias
+%%DATADIR%%/completion/uname
+%%DATADIR%%/completion/uniq
+%%DATADIR%%/completion/unset
+%%DATADIR%%/completion/useradd
+%%DATADIR%%/completion/valgrind
+%%DATADIR%%/completion/vi
+%%DATADIR%%/completion/view
+%%DATADIR%%/completion/vim
+%%DATADIR%%/completion/vimdiff
+%%DATADIR%%/completion/wait
+%%DATADIR%%/completion/watch
+%%DATADIR%%/completion/wc
+%%DATADIR%%/completion/which
+%%DATADIR%%/completion/who
+%%DATADIR%%/completion/xargs
+%%DATADIR%%/completion/yash
+%%DATADIR%%/config
+%%DATADIR%%/initialization/common
+%%DATADIR%%/initialization/default
+%%DATADIR%%/initialization/sample