aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-08-08 16:14:46 +0000
committerCy Schubert <cy@FreeBSD.org>2019-08-08 16:14:46 +0000
commit5a8b8b3a6f65378fdba02e16f8b253041aba47a5 (patch)
tree615761d1d1171f2eb9255be353718a14d1e7e9af /shells
parentdec49489d8727523b9ffe9d63a6d4ca0f7cf7bac (diff)
downloadports-5a8b8b3a6f65378fdba02e16f8b253041aba47a5.tar.gz
ports-5a8b8b3a6f65378fdba02e16f8b253041aba47a5.zip
MFH: r508344
Fix: $ ksh93 $ time ../src/cmd/ksh93/sh/xec.c:2171: failed assertion 'tb.tv_sec' Abort trap (core dumped) $ ksh93 $ times ../src/cmd/ksh93/sh/xec.c:2171: failed assertion 'tb.tv_sec' Abort trap (core dumped) PR: 239701 Suggested by: w.schwarzenfeld@utanet.at Approved by: portmgr (delphij@)
Notes
Notes: svn path=/branches/2019Q3/; revision=508392
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile2
-rw-r--r--shells/ksh93/files/patch-src_cmd_ksh93_sh_xec.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 89a60d099913..69034ecc9b39 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ksh93
DISTVERSION=2020.0.0-alpha1
PORTEPOCH= 1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MAINTAINER= cy@freebsd.org
diff --git a/shells/ksh93/files/patch-src_cmd_ksh93_sh_xec.c b/shells/ksh93/files/patch-src_cmd_ksh93_sh_xec.c
new file mode 100644
index 000000000000..62237cf768b6
--- /dev/null
+++ b/shells/ksh93/files/patch-src_cmd_ksh93_sh_xec.c
@@ -0,0 +1,11 @@
+--- src/cmd/ksh93/sh/xec.c.orig 2019-04-16 20:04:19 UTC
++++ src/cmd/ksh93/sh/xec.c
+@@ -2167,7 +2167,7 @@ int sh_exec(Shell_t *shp, const Shnode_t *t, int flags
+ }
+ #ifdef timeofday
+ times(&after);
+- timeofday(&ta);
++ timeofday(&tb);
+ assert(tb.tv_sec);
+ at = shp->gd->lim.clk_tck * (ta.tv_sec - tb.tv_sec);
+ at += ((shp->gd->lim.clk_tck *