aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2019-05-15 21:11:43 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2019-05-15 21:11:43 +0000
commit6441cbe7300d79d7576b2c7c3bba784b013377e2 (patch)
tree466b2b884d435ee09f0618cff347a91eba0429d6 /shells
parentd85981f52b69e2cb1576483a9aa3cbbf8da89feb (diff)
downloadports-6441cbe7300d79d7576b2c7c3bba784b013377e2.tar.gz
ports-6441cbe7300d79d7576b2c7c3bba784b013377e2.zip
Move zsh-autosuggestions and zsh-syntax-highlighting from textproc to shells
Notes
Notes: svn path=/head/; revision=501751
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile2
-rw-r--r--shells/zsh-autosuggestions/Makefile28
-rw-r--r--shells/zsh-autosuggestions/distinfo3
-rw-r--r--shells/zsh-autosuggestions/files/pkg-message.in5
-rw-r--r--shells/zsh-autosuggestions/pkg-descr4
-rw-r--r--shells/zsh-syntax-highlighting/Makefile27
-rw-r--r--shells/zsh-syntax-highlighting/distinfo3
-rw-r--r--shells/zsh-syntax-highlighting/files/pkg-message.in5
-rw-r--r--shells/zsh-syntax-highlighting/pkg-descr5
-rw-r--r--shells/zsh-syntax-highlighting/pkg-plist22
10 files changed, 104 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 51696f1e8dc7..44b5c45f0946 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -55,7 +55,9 @@
SUBDIR += xonsh
SUBDIR += zsh
SUBDIR += zsh-antigen
+ SUBDIR += zsh-autosuggestions
SUBDIR += zsh-completions
SUBDIR += zsh-navigation-tools
+ SUBDIR += zsh-syntax-highlighting
.include <bsd.port.subdir.mk>
diff --git a/shells/zsh-autosuggestions/Makefile b/shells/zsh-autosuggestions/Makefile
new file mode 100644
index 000000000000..79071faf6670
--- /dev/null
+++ b/shells/zsh-autosuggestions/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= zsh-autosuggestions
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.2
+CATEGORIES= textproc
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Fish-like autosuggestions for Zsh
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zsh>=4.3:shells/zsh
+
+USE_GITHUB= yes
+GH_ACCOUNT= zsh-users
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= ${DATADIR}/${PORTNAME}.zsh
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/zsh-autosuggestions.zsh ${STAGEDIR}/${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/shells/zsh-autosuggestions/distinfo b/shells/zsh-autosuggestions/distinfo
new file mode 100644
index 000000000000..589c6bbf146b
--- /dev/null
+++ b/shells/zsh-autosuggestions/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555512722
+SHA256 (zsh-users-zsh-autosuggestions-v0.5.2_GH0.tar.gz) = 7ac1c1dbab0d58e8d385dfc5fa9148707a53f029f43d046efb01092f68cc5218
+SIZE (zsh-users-zsh-autosuggestions-v0.5.2_GH0.tar.gz) = 21702
diff --git a/shells/zsh-autosuggestions/files/pkg-message.in b/shells/zsh-autosuggestions/files/pkg-message.in
new file mode 100644
index 000000000000..b478ca7d39e5
--- /dev/null
+++ b/shells/zsh-autosuggestions/files/pkg-message.in
@@ -0,0 +1,5 @@
+================================================================================
+Add the line below to your .zshrc to enable auto suggestions.
+
+source %%DATADIR%%/zsh-autosuggestions.zsh
+================================================================================
diff --git a/shells/zsh-autosuggestions/pkg-descr b/shells/zsh-autosuggestions/pkg-descr
new file mode 100644
index 000000000000..ae4b6be01ab9
--- /dev/null
+++ b/shells/zsh-autosuggestions/pkg-descr
@@ -0,0 +1,4 @@
+zsh-autosuggestions enables fast and unobtrusive fish-like autosuggestions
+for Zsh. It suggests commands as you type, based on command history.
+
+WWW: https://github.com/zsh-users/zsh-autosuggestions
diff --git a/shells/zsh-syntax-highlighting/Makefile b/shells/zsh-syntax-highlighting/Makefile
new file mode 100644
index 000000000000..3db3f9947840
--- /dev/null
+++ b/shells/zsh-syntax-highlighting/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= zsh-syntax-highlighting
+DISTVERSION= 0.6.0-243
+DISTVERSIONSUFFIX= -g82cf252
+PORTEPOCH= 1
+CATEGORIES= textproc
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Fish shell syntax highlighting for Zsh
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= zsh>=5.4:shells/zsh
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= zsh-users
+
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>
diff --git a/shells/zsh-syntax-highlighting/distinfo b/shells/zsh-syntax-highlighting/distinfo
new file mode 100644
index 000000000000..b1d468365467
--- /dev/null
+++ b/shells/zsh-syntax-highlighting/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557512113
+SHA256 (zsh-users-zsh-syntax-highlighting-0.6.0-243-g82cf252_GH0.tar.gz) = 3657984ada2f2716cf2d44be086147c7eb7d34a8c39c50268377bb49b048e1b8
+SIZE (zsh-users-zsh-syntax-highlighting-0.6.0-243-g82cf252_GH0.tar.gz) = 127225
diff --git a/shells/zsh-syntax-highlighting/files/pkg-message.in b/shells/zsh-syntax-highlighting/files/pkg-message.in
new file mode 100644
index 000000000000..2f718de92b61
--- /dev/null
+++ b/shells/zsh-syntax-highlighting/files/pkg-message.in
@@ -0,0 +1,5 @@
+================================================================================
+Add the line below to *the end of* your .zshrc to enable highlighting.
+
+source %%DATADIR%%/zsh-syntax-highlighting.zsh
+================================================================================
diff --git a/shells/zsh-syntax-highlighting/pkg-descr b/shells/zsh-syntax-highlighting/pkg-descr
new file mode 100644
index 000000000000..6b28cdf2786b
--- /dev/null
+++ b/shells/zsh-syntax-highlighting/pkg-descr
@@ -0,0 +1,5 @@
+Zsh-syntax-highlighting enables highlighting of commands whilst they
+are typed at an interactive zsh prompt. This helps in reviewing
+commands before running them, particularly in catching syntax errors.
+
+WWW: https://github.com/zsh-users/zsh-syntax-highlighting
diff --git a/shells/zsh-syntax-highlighting/pkg-plist b/shells/zsh-syntax-highlighting/pkg-plist
new file mode 100644
index 000000000000..f05f5c4ce22e
--- /dev/null
+++ b/shells/zsh-syntax-highlighting/pkg-plist
@@ -0,0 +1,22 @@
+%%DATADIR%%/.revision-hash
+%%DATADIR%%/.version
+%%DATADIR%%/highlighters/brackets/brackets-highlighter.zsh
+%%DATADIR%%/highlighters/cursor/cursor-highlighter.zsh
+%%DATADIR%%/highlighters/line/line-highlighter.zsh
+%%DATADIR%%/highlighters/main/main-highlighter.zsh
+%%DATADIR%%/highlighters/pattern/pattern-highlighter.zsh
+%%DATADIR%%/highlighters/regexp/regexp-highlighter.zsh
+%%DATADIR%%/highlighters/root/root-highlighter.zsh
+%%DATADIR%%/zsh-syntax-highlighting.zsh
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/all.md
+%%PORTDOCS%%%%DOCSDIR%%/changelog.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/brackets.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/cursor.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/line.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/main.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/pattern.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/regexp.md
+%%PORTDOCS%%%%DOCSDIR%%/highlighters/root.md