aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-06 10:07:19 +0000
committerJohn Marino <marino@FreeBSD.org>2015-02-06 10:07:19 +0000
commitbfd01c3c2a4069f7d2a8d32b0102762119ce4242 (patch)
treed7a11a0c3905728ffd41c584401da523efe3775e /shells
parent26ead078cae969594fb76c8495b63128efc4b494 (diff)
downloadports-bfd01c3c2a4069f7d2a8d32b0102762119ce4242.tar.gz
ports-bfd01c3c2a4069f7d2a8d32b0102762119ce4242.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/lshell/Makefile1
-rw-r--r--shells/lshell/files/patch-lshell_checkconfig.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index adf208fc5943..248aa3e21526 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lshell
PORTVERSION= 0.9.16
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF
diff --git a/shells/lshell/files/patch-lshell_checkconfig.py b/shells/lshell/files/patch-lshell_checkconfig.py
new file mode 100644
index 000000000000..6427ccffc8b4
--- /dev/null
+++ b/shells/lshell/files/patch-lshell_checkconfig.py
@@ -0,0 +1,11 @@
+--- lshell/checkconfig.py.orig 2013-08-19 19:59:37 UTC
++++ lshell/checkconfig.py
+@@ -307,7 +307,7 @@ class CheckConfig:
+ try:
+ if logfilename == "syslog":
+ from logging.handlers import SysLogHandler
+- syslog = SysLogHandler(address='/dev/log')
++ syslog = SysLogHandler(address='/var/run/log')
+ syslog.setFormatter(syslogformatter)
+ syslog.setLevel(self.levels[self.conf['loglevel']])
+ logger.addHandler(syslog)