aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-01-22 14:29:35 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-01-22 14:29:35 +0000
commitc68f262b13c84e91c8c79c856d730a1cfbf10a88 (patch)
tree80d2a7396dc6166830f8cc3198fca8591fbbf2aa /shells
parent664f5c452647e9f742be5115f3cefaf8225a2199 (diff)
downloadports-c68f262b13c84e91c8c79c856d730a1cfbf10a88.tar.gz
ports-c68f262b13c84e91c8c79c856d730a1cfbf10a88.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index c2c32cc6e4e2..70fc95fe1b15 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -26,7 +26,9 @@ USE_BZIP2= yes
USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 autoheader:262
GNU_CONFIGURE= yes
+.if !defined(WITH_ZSH_STATIC)
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
+.endif
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -150,7 +152,7 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/zsh) > ${SHELLS}
@${RM} ${SHELLS}.bak
@${PREFIX}/bin/zsh -fc ' \
- setopt extendedglob; \
+ setopt extendedglob nomark_dirs; \
for i in ${DATADIR}/${ZSH_VER}/functions/**/*(/) ; do \
zcompile -U -M $$i.zwc $$i/*~*.zwc(^/) ; \
${CHMOD} 644 $$i.zwc ; \