aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2015-02-19 15:59:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2015-02-19 15:59:54 +0000
commitc73a7391d6f48ab205d1996de53195dbf13ceaa5 (patch)
tree915ab4f465be50ab0656894c7e2714452519e3a7 /shells
parent709bfbae771289a9fccc74d0e30a339e6f399817 (diff)
downloadports-c73a7391d6f48ab205d1996de53195dbf13ceaa5.tar.gz
ports-c73a7391d6f48ab205d1996de53195dbf13ceaa5.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-static/Makefile2
-rw-r--r--shells/bash/Makefile9
2 files changed, 8 insertions, 3 deletions
diff --git a/shells/bash-static/Makefile b/shells/bash-static/Makefile
index 363a823cd52c..87482ecf439a 100644
--- a/shells/bash-static/Makefile
+++ b/shells/bash-static/Makefile
@@ -5,4 +5,6 @@ MASTERDIR= ${.CURDIR}/../../shells/bash
OPTIONS_SLAVE= STATIC
+PKGNAMESUFFIX= -static
+
.include "${MASTERDIR}/Makefile"
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 3a3577d4ce78..4830ad82c7bc 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -56,6 +56,12 @@ CONFIGURE_ARGS+= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins
+.if empty(PKGNAMESUFFIX)
+CONFLICTS+= bash-static-[0-9]*
+.else
+CONFLICTS+= bash-[0-9]*
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPORTFUNCTIONS}
@@ -66,11 +72,8 @@ CFLAGS+= -DIMPORT_FUNCTIONS_DEF=0
.if ${PORT_OPTIONS:MSTATIC} || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:tl} != "no")
CONFIGURE_ARGS+= --enable-static-link
-PKGNAMESUFFIX= -static
-CONFLICTS+= bash-[0-9]*
.else
CONFIGURE_ARGS+= --disable-static-link
-CONFLICTS+= bash-static-[0-9]*
.endif
post-patch: