aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-07-03 04:47:28 +0000
committerWill Andrews <will@FreeBSD.org>2001-07-03 04:47:28 +0000
commit3a8f58edc35355e7ab813a3c5a8676edb3c710c8 (patch)
tree4268066c73e562e1ba1b9089f056926db8d5459c /shells
parentf8e10954e5d750a68ae5443556a260052af4a57f (diff)
downloadports-3a8f58edc35355e7ab813a3c5a8676edb3c710c8.tar.gz
ports-3a8f58edc35355e7ab813a3c5a8676edb3c710c8.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile33
-rw-r--r--shells/zsh/distinfo3
-rw-r--r--shells/zsh/files/patch-ab11
-rw-r--r--shells/zsh/files/patch-ad162
-rw-r--r--shells/zsh/pkg-descr2
-rw-r--r--shells/zsh/pkg-plist66
6 files changed, 87 insertions, 190 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 6a8cc6cdefad..158914ebb043 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zsh
-PORTVERSION= 4.0.1
+PORTVERSION= 4.0.2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.zsh.org/%SUBDIR%/ \
@@ -16,29 +16,39 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ips.oz.au/pub/packages/%SUBDIR%/ \
ftp://ftp.uit.no/pub/unix/shells/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} zsh-${PORTVERSION}-doc.tar.gz
+.endif
MAINTAINER= will@FreeBSD.org
-USE_AUTOCONF= yes
-
ZSH_VER= ${PORTVERSION}
ZSHFUNC_SUBDIR= share/zsh/${ZSH_VER}/functions
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-zsh-mem --enable-zsh-secure-free --enable-dynamic \
--enable-maildir-support
-INSTALL_TARGET= install install.info
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install install.html
+.endif
+
MAN1= zsh.1 zshbuiltins.1 zshcompctl.1 zshcompwid.1 zshcompsys.1 \
zshcontrib.1 zshexpn.1 zshmisc.1 zshmodules.1 zshoptions.1 \
zshparam.1 zshzftpsys.1 zshzle.1 zshall.1
+
PLIST_SUB= ZSH_VER="${ZSH_VER}" ZSHFUNC_SUBDIR="${ZSHFUNC_SUBDIR}"
.if defined(WANT_STATIC)
-CONFIGURE_ENV+= "LDFLAGS=-static"
+CONFIGURE_ENV+= "LDFLAGS=-static"
PLIST_SUB+= NO_STATIC="@comment "
.else
PLIST_SUB+= NO_STATIC=""
.endif
+post-patch:
+ @${PERL} -pi -e 's!\$\(htmldir\)!\$\(prefix\)/share/doc/zsh!' \
+ ${WRKSRC}/Doc/Makefile.in
+
post-build:
# Fix ".so" macro problem by using "soelim" command.
@(cd ${WRKSRC} ; \
@@ -49,13 +59,16 @@ post-build:
${RM} -f ./man1/zshall.1 ; \
/usr/bin/soelim ./man1/zshall.1.source > ./man1/zshall.1 ; \
)
- @cd ${WRKSRC}/Doc && ${MAKE} info
-
-pre-install:
- @${RM} -f ${WRKSRC}/Completion/Unix/Command/_mount.orig
post-install:
- @${INSTALL_DATA} ${WRKSRC}/Doc/zsh.info ${PREFIX}/info
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DATA} ${WRKSRC}/Doc/zsh.info* ${PREFIX}/info
+.endif
+ @${MKDIR} ${PREFIX}/share/examples/zsh
+.for file in zlogin zshenv zshrc
+ ${INSTALL_DATA} ${WRKSRC}/StartupFiles/${file} \
+ ${PREFIX}/share/examples/zsh
+.endfor
@install-info ${PREFIX}/info/zsh.info ${PREFIX}/info/dir
@${ECHO} "Updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
diff --git a/shells/zsh/distinfo b/shells/zsh/distinfo
index 4cb0d496dae3..9a6c3e0fdd57 100644
--- a/shells/zsh/distinfo
+++ b/shells/zsh/distinfo
@@ -1 +1,2 @@
-MD5 (zsh-4.0.1.tar.gz) = 9fc2c72ea3b6cd0449dd513510c9ca0d
+MD5 (zsh-4.0.2.tar.gz) = 38611d4ddd2547668d48867772ce214e
+MD5 (zsh-4.0.2-doc.tar.gz) = f9c24f483898d94d443aa4b536e2da72
diff --git a/shells/zsh/files/patch-ab b/shells/zsh/files/patch-ab
deleted file mode 100644
index 0899f82e9386..000000000000
--- a/shells/zsh/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- Doc/Makefile.in.orig Thu Apr 20 04:03:42 2000
-+++ Doc/Makefile.in Sat Apr 29 00:04:52 2000
-@@ -37,7 +37,7 @@
-
- @DEFS_MK@
-
--MAKEINFO = makeinfo
-+MAKEINFO = makeinfo --no-split
- TEXI2DVI = texi2dvi
- DVIPS = dvips
- TEXI2HTML = texi2html -expandinfo -split_chapter
diff --git a/shells/zsh/files/patch-ad b/shells/zsh/files/patch-ad
deleted file mode 100644
index c40ea35d768b..000000000000
--- a/shells/zsh/files/patch-ad
+++ /dev/null
@@ -1,162 +0,0 @@
---- Completion/Unix/Command/_mount.orig Sun Jun 3 22:30:24 2001
-+++ Completion/Unix/Command/_mount Sun Jun 3 22:30:32 2001
-@@ -365,6 +365,52 @@
- 'onerror[set behaviour on error]:behaviour on error:(panic lock umount repair)'
- )
- ;;
-+ freebsd*)
-+ _fs_any=(
-+ '(sync)async[do all I/O asynchronously]'
-+ 'current[use current options on already mounted file system]'
-+ 'force[force R/W mount of unclean filesystem]'
-+ 'fstab[use options listed in /etc/fstab]'
-+ 'noasync[do I/O synchronously]'
-+ 'noatime[don'"'"'t update access time]'
-+ 'noauto[can only be mounted explicitly]'
-+ 'noclusterr[disable read clustering]'
-+ 'noclusterw[disable write clustering]'
-+ 'nodev[don'"'"'t interpret devices]'
-+ 'noexec[don'"'"'t allow execution of binaries]'
-+ 'nosuid[ignore suid and sgid bits]'
-+ 'nosymfollow[don'"'"'t follow symlinks]'
-+ 'rdonly[mount file system read-only]'
-+ '(async)sync[do all I/O synchronously]'
-+ 'suiddir[allow suid bits on directories]'
-+ 'update[change status of already mounted filesystem]'
-+ 'union[cause the namespace at the mount point to appear as the union of the mounted filesystem and the existing directory]'
-+ )
-+ _fs_iso9660=(
-+ 'extatt[enable use of extended attributes]'
-+ 'gens[don'"'"'t strip version number on files]'
-+ 'joliet[don'"'"'t use any Joliet extensions]'
-+ 'rrip[don'"'"'t use any Rockridge extensions]'
-+ 'strictjoliet[relax checking for Supplementary Volume Descriptor Flags field which is set to a wrong value on some Joliet formatted disks]'
-+ )
-+ _fs_std=(
-+ 'nodev[don'"'"'t interpret devices]'
-+ 'noexec[don'"'"'t allow execution of binaries]'
-+ 'nosuid[ignore suid and sgid bits]'
-+ 'rdonly[mount file system read-only]'
-+ 'union[cause the namespace at the mount point to appear as the union of the mounted filesystem and the existing directory]'
-+ )
-+ _fs_devfs=( "$_fs_std[@]" )
-+ _fs_fdesc=( "$_fs_std[@]" )
-+ _fs_kernfs=( "$_fs_std[@]" )
-+ _fs_linprocfs=( "$_fs_std[@]" )
-+ _fs_procfs=( "$_fs_std[@]" )
-+ _fs_msdos=(
-+ 'shortnames[]'
-+ 'longnames[]'
-+ 'nowin95[]'
-+ )
-+ ;;
- esac
- fi
-
-@@ -475,6 +521,25 @@
- deffs=hsfs
- typeops=-F
- ;;
-+ freebsd*)
-+ args=( -s
-+ '-a[mount all filesystems in fstab]'
-+ '-d[cause everything to be done except for the actual system call]'
-+ '-f[forced mount]'
-+ '-o[specify file system options]:file system option:->fsopt'
-+ '-p[print mounted file systems]'
-+ '-r[mount readonly]'
-+ '-t[specify file system type]:file system type:->fstype'
-+ '-u[change status of already mounted filesystem]'
-+ '-v[verbose mode]'
-+ '-w[mount read/write]'
-+ ':dev or dir:->devordir'
-+ ':mount point:_files -/'
-+ )
-+ fss=( cd9660 devfs ext2fs fdesc kernfs linprocfs mfs msdos nfs
-+ ntfs null nwfs portal procfs std ufs umap union )
-+ deffs=ufs
-+ ;;
- *)
- # Default for all other systems. Dunno.
-
-@@ -517,6 +582,17 @@
- '-v[verbose]'
- )
- ;;
-+ freebsd*)
-+ args=(
-+ '-a[unmount all mounted file systems]'
-+ '-A[unmount all mounted file systems except the root]'
-+ '-f[force unmount]'
-+ '-h[unmount all filesystems associated with host]:hostnames:_hosts'
-+ '-t[unmount all filesystems of specified type]:file system type:->fstype'
-+ '-v[verbose mode]'
-+ '*:dev or dir:->udevordir'
-+ )
-+ ;;
- *)
- args=( \
- '-h[show help]'
-@@ -553,20 +629,55 @@
- if (( $+opt_args[-a] )); then
- _message "no device or directory with option \`-a'"
- else
-- _alternative \
-- 'devices:device:{compadd "$expl[@]" /dev/*}' \
-- 'directories:mount point:_files -/' && ret=0
-+ local dev_tmp mp_tmp mline
-+
-+ case "$OSTYPE" in
-+ freebsd*)
-+ while read mline; do
-+ case $mline[(w)1] in
-+ \#* )
-+ ;;
-+ proc)
-+ ;;
-+ *)
-+ [[ $mline[(w)3] == swap ]] || \
-+ dev_tmp=( $dev_tmp $mline[(w)1] ) \
-+ mp_tmp=( $mp_tmp $mline[(w)2] )
-+ ;;
-+ esac
-+ done < /etc/fstab
-+
-+ _alternative \
-+ 'devices:device:compadd -a dev_tmp' \
-+ 'directories:mount point:compadd -a mp_tmp' && ret=0
-+ ;;
-+ *)
-+ _alternative \
-+ 'devices:device:{compadd "$expl[@]" /dev/*}' \
-+ 'directories:mount point:_files -/' && ret=0
-+ ;;
-+ esac
- fi
- ;;
- udevordir)
- if (( $+opt_args[-a] )); then
- _message "no device or directory with option \`-a'"
- else
-- local dev_tmp mp_tmp
-+ local dev_tmp mp_tmp mline
-
-- tmp=( "${(@f)$(< /etc/mtab)}" )
-- dev_tmp=( "${(@)${(@)tmp%% *}:#none}" )
-- mp_tmp=( "${(@)${(@)tmp#* }%% *}" )
-+ case "$OSTYPE" in
-+ freebsd*)
-+ /sbin/mount | while read mline; do
-+ dev_tmp=( $dev_tmp $mline[(w)1] )
-+ mp_tmp=( $mp_tmp $mline[(w)3] )
-+ done
-+ ;;
-+ *)
-+ tmp=( "${(@f)$(< /etc/mtab)}" )
-+ dev_tmp=( "${(@)${(@)tmp%% *}:#none}" )
-+ mp_tmp=( "${(@)${(@)tmp#* }%% *}" )
-+ ;;
-+ esac
-
- _alternative \
- 'devices:device:compadd -a dev_tmp' \
diff --git a/shells/zsh/pkg-descr b/shells/zsh/pkg-descr
index 4bf0d83794ce..0020d39d9dc5 100644
--- a/shells/zsh/pkg-descr
+++ b/shells/zsh/pkg-descr
@@ -11,6 +11,6 @@ commands:
$ autoload -U compinstall
$ compinstall
-See also zshcompsys(1) manpages. :)
+See also zshcompsys(1) manpage. :)
WWW: http://www.zsh.org/
diff --git a/shells/zsh/pkg-plist b/shells/zsh/pkg-plist
index 64dbc2e492f9..6b6797fd15a0 100644
--- a/shells/zsh/pkg-plist
+++ b/shells/zsh/pkg-plist
@@ -1,10 +1,30 @@
bin/zsh
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
bin/zsh-%%ZSH_VER%%
-@unexec install-info --delete %D/info/zsh.info %D/info/dir
-info/zsh.info
-@exec install-info %D/info/zsh.info %D/info/dir
+%%PORTDOCS%%@unexec install-info --delete %D/%%PORTDOCS%%info/zsh.info %D/info/dir
+%%PORTDOCS%%info/zsh.info
+%%PORTDOCS%%info/zsh.info-1
+%%PORTDOCS%%info/zsh.info-10
+%%PORTDOCS%%info/zsh.info-11
+%%PORTDOCS%%info/zsh.info-12
+%%PORTDOCS%%info/zsh.info-13
+%%PORTDOCS%%info/zsh.info-14
+%%PORTDOCS%%info/zsh.info-15
+%%PORTDOCS%%info/zsh.info-16
+%%PORTDOCS%%info/zsh.info-17
+%%PORTDOCS%%info/zsh.info-18
+%%PORTDOCS%%info/zsh.info-19
+%%PORTDOCS%%info/zsh.info-2
+%%PORTDOCS%%info/zsh.info-20
+%%PORTDOCS%%info/zsh.info-3
+%%PORTDOCS%%info/zsh.info-4
+%%PORTDOCS%%info/zsh.info-5
+%%PORTDOCS%%info/zsh.info-6
+%%PORTDOCS%%info/zsh.info-7
+%%PORTDOCS%%info/zsh.info-8
+%%PORTDOCS%%info/zsh.info-9
+%%PORTDOCS%%@exec install-info %D/%%PORTDOCS%%info/zsh.info %D/info/dir
%%NO_STATIC%%lib/zsh/libzsh-%%ZSH_VER%%.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/cap.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/clone.so
@@ -29,6 +49,39 @@ info/zsh.info
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/zprof.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/zpty.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/zutil.so
+%%PORTDOCS%%share/doc/zsh/zsh_1.html
+%%PORTDOCS%%share/doc/zsh/zsh_10.html
+%%PORTDOCS%%share/doc/zsh/zsh_11.html
+%%PORTDOCS%%share/doc/zsh/zsh_12.html
+%%PORTDOCS%%share/doc/zsh/zsh_13.html
+%%PORTDOCS%%share/doc/zsh/zsh_14.html
+%%PORTDOCS%%share/doc/zsh/zsh_15.html
+%%PORTDOCS%%share/doc/zsh/zsh_16.html
+%%PORTDOCS%%share/doc/zsh/zsh_17.html
+%%PORTDOCS%%share/doc/zsh/zsh_18.html
+%%PORTDOCS%%share/doc/zsh/zsh_19.html
+%%PORTDOCS%%share/doc/zsh/zsh_2.html
+%%PORTDOCS%%share/doc/zsh/zsh_20.html
+%%PORTDOCS%%share/doc/zsh/zsh_21.html
+%%PORTDOCS%%share/doc/zsh/zsh_22.html
+%%PORTDOCS%%share/doc/zsh/zsh_23.html
+%%PORTDOCS%%share/doc/zsh/zsh_24.html
+%%PORTDOCS%%share/doc/zsh/zsh_25.html
+%%PORTDOCS%%share/doc/zsh/zsh_26.html
+%%PORTDOCS%%share/doc/zsh/zsh_27.html
+%%PORTDOCS%%share/doc/zsh/zsh_28.html
+%%PORTDOCS%%share/doc/zsh/zsh_29.html
+%%PORTDOCS%%share/doc/zsh/zsh_3.html
+%%PORTDOCS%%share/doc/zsh/zsh_4.html
+%%PORTDOCS%%share/doc/zsh/zsh_5.html
+%%PORTDOCS%%share/doc/zsh/zsh_6.html
+%%PORTDOCS%%share/doc/zsh/zsh_7.html
+%%PORTDOCS%%share/doc/zsh/zsh_8.html
+%%PORTDOCS%%share/doc/zsh/zsh_9.html
+%%PORTDOCS%%share/doc/zsh/zsh_toc.html
+share/examples/zsh/zlogin
+share/examples/zsh/zshenv
+share/examples/zsh/zshrc
%%ZSHFUNC_SUBDIR%%/_a2ps
%%ZSHFUNC_SUBDIR%%/_alias
%%ZSHFUNC_SUBDIR%%/_aliases
@@ -44,6 +97,7 @@ info/zsh.info
%%ZSHFUNC_SUBDIR%%/_arguments
%%ZSHFUNC_SUBDIR%%/_arp
%%ZSHFUNC_SUBDIR%%/_arrays
+%%ZSHFUNC_SUBDIR%%/_autocd
%%ZSHFUNC_SUBDIR%%/_autoload
%%ZSHFUNC_SUBDIR%%/_bash_completions
%%ZSHFUNC_SUBDIR%%/_bindkey
@@ -406,3 +460,5 @@ info/zsh.info
@dirrm share/zsh/%%ZSH_VER%%
@dirrm share/zsh/site-functions
@dirrm share/zsh
+@dirrm share/examples/zsh
+@dirrm share/doc/zsh