aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>2000-02-13 18:20:45 +0000
committerTorsten Blum <torstenb@FreeBSD.org>2000-02-13 18:20:45 +0000
commit3e8c8b499692ea8c65cc2f01e2a1c7dd06ba7e04 (patch)
treec008f8c5bfa25a6cc350399cfa67fd3e69a01abb /shells
parent28151c348172ebf709fde05520ab1c9f9e3d1fc6 (diff)
downloadports-3e8c8b499692ea8c65cc2f01e2a1c7dd06ba7e04.tar.gz
ports-3e8c8b499692ea8c65cc2f01e2a1c7dd06ba7e04.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile1
-rw-r--r--shells/zsh/files/patch-ac113
2 files changed, 101 insertions, 13 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 0cabddc089b4..c54bb059a863 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -29,6 +29,7 @@ PLIST_SUB= ZSH_VERSION=${DISTNAME:S/zsh-//}
post-build:
# Fix ".so" macro problem by using "soelim" command.
+ @echo HERE!!!
@(cd ${WRKSRC} ; \
${LN} -sf ./Doc man1 ; \
if [ ! -f ./man1/zshall.1.source ]; then \
diff --git a/shells/zsh/files/patch-ac b/shells/zsh/files/patch-ac
index 20799ee09487..90e273ac638e 100644
--- a/shells/zsh/files/patch-ac
+++ b/shells/zsh/files/patch-ac
@@ -1,13 +1,100 @@
---- Doc/zsh.texi.orig Thu Dec 19 09:00:10 1996
-+++ Doc/zsh.texi Mon Jun 16 20:35:02 1997
-@@ -2,6 +2,10 @@
- @c %**start of header
- @setfilename zsh.info
- @settitle zsh
-+@dircategory Shells
-+@direntry
-+* Zsh: (zsh). The Z shell.
-+@end direntry
- @c %**end of header
-
- @setchapternewpage odd
+*** Doc/zsh.texi.orig Fri Sep 3 16:44:37 1999
+--- Doc/zsh.texi Sun Feb 13 12:02:35 2000
+***************
+*** 2,7 ****
+--- 2,11 ----
+ @c %**start of header
+ @setfilename zsh.info
+ @settitle zsh
++ @dircategory Shells
++ @direntry
++ * Zsh: (zsh). The Z shell.
++ @end direntry
+ @c %**end of header
+
+ @ifinfo
+***************
+*** 834,840 ****
+ A character may be @dfn{quoted} (that is, made to stand for itself) by
+ preceding it with a @code{\}. @code{\} followed by a newline is
+ ignored. All characters enclosed between a pair of single quotes
+! (@t{@value{dsq}}) are quoted, except the first character of @code{histchars}
+ (@code{!} by default). A single quote cannot appear within single
+ quotes. Inside double quotes (@code{""}), parameter and command
+ substitution occurs, and @code{\} quotes the characters @code{\},
+--- 838,844 ----
+ A character may be @dfn{quoted} (that is, made to stand for itself) by
+ preceding it with a @code{\}. @code{\} followed by a newline is
+ ignored. All characters enclosed between a pair of single quotes
+! (@t{'}@t{'}) are quoted, except the first character of @code{histchars}
+ (@code{!} by default). A single quote cannot appear within single
+ quotes. Inside double quotes (@code{""}), parameter and command
+ substitution occurs, and @code{\} quotes the characters @code{\},
+***************
+*** 1622,1628 ****
+ @code{histchars} parameter which is @code{!} by default and may occur
+ anywhere on the command line; history substitutions do not nest. The
+ @code{!} can be escaped with @code{\} or can be enclosed between a pair of
+! single quotes (@t{@value{dsq}})
+ to suppress its special meaning. Double quotes will not work for this.
+
+ @noindent
+--- 1626,1632 ----
+ @code{histchars} parameter which is @code{!} by default and may occur
+ anywhere on the command line; history substitutions do not nest. The
+ @code{!} can be escaped with @code{\} or can be enclosed between a pair of
+! single quotes (@t{'}@t{'})
+ to suppress its special meaning. Double quotes will not work for this.
+
+ @noindent
+***************
+*** 5183,5189 ****
+ @cindex rc, quoting style
+ @cindex quoting style, rc
+ @pindex RC_QUOTES
+! Allow the character sequence @t{@value{dsq}} to signify a single quote within
+ singly quoted strings.
+
+ @item RCS (+f)
+--- 5187,5193 ----
+ @cindex rc, quoting style
+ @cindex quoting style, rc
+ @pindex RC_QUOTES
+! Allow the character sequence @t{'}@t{'} to signify a single quote within
+ singly quoted strings.
+
+ @item RCS (+f)
+***************
+*** 7008,7014 ****
+ use is
+
+ @example
+! compctl -D -f + -H 0 @value{dsq} -X '(No file found; using history)'
+ @end example
+
+ which forces completion to look back in the history list for a word if no
+--- 7012,7018 ----
+ use is
+
+ @example
+! compctl -D -f + -H 0 @t{'}@t{'} -X '(No file found; using history)'
+ @end example
+
+ which forces completion to look back in the history list for a word if no
+***************
+*** 7071,7077 ****
+ name completion performed on the first word in the range. For example,
+
+ @example
+! compctl -x 'r[-exec,;]' -l @value{dsq} -- find
+ @end example
+
+ completes arguments between @code{-exec} and the following @code{;} (or the
+--- 7075,7081 ----
+ name completion performed on the first word in the range. For example,
+
+ @example
+! compctl -x 'r[-exec,;]' -l @t{'}@t{'} -- find
+ @end example
+
+ completes arguments between @code{-exec} and the following @code{;} (or the