aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-03-25 21:04:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-03-25 21:04:50 +0000
commit7181051572bc46379e504da875a39641563d7a0f (patch)
tree30a626cc92380ff0038cc45102f37a7eb537bba9 /shells
parentb9eac19b3fdd2c1a378b82fdfefe45974896b144 (diff)
downloadports-7181051572bc46379e504da875a39641563d7a0f.tar.gz
ports-7181051572bc46379e504da875a39641563d7a0f.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-pathname.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 33ef514bb589..362c18b0f1dd 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 2.00a
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.vector.co.jp/pack/unix/util/file/filer/fd/
diff --git a/shells/fd/files/patch-pathname.c b/shells/fd/files/patch-pathname.c
new file mode 100644
index 000000000000..d4b22a267299
--- /dev/null
+++ b/shells/fd/files/patch-pathname.c
@@ -0,0 +1,12 @@
+diff -u ../old/FD-2.00a/pathname.c ./pathname.c
+--- ../old/FD-2.00a/pathname.c Wed Feb 6 00:00:00 2002
++++ ./pathname.c Fri Mar 22 08:55:40 2002
+@@ -2744,7 +2744,7 @@
+ for (w = 0; wild[w]; w++)
+ (*argvp)[n + w] = wild[w];
+ free(wild);
+- n += w;
++ n += w - 1;
+ break;
+ }
+