aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 16:36:21 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 16:36:21 +0000
commit7b72d170ba3c89c7e408c333297d8ecfa3ba72f1 (patch)
treec59f3d834c5b1d9bbf8061f535d231aeccbe42d7 /shells
parentc13c92a1a3f4a197bd93710bd73e5cd4391695a4 (diff)
downloadports-7b72d170ba3c89c7e408c333297d8ecfa3ba72f1.tar.gz
ports-7b72d170ba3c89c7e408c333297d8ecfa3ba72f1.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile2
-rw-r--r--shells/bash-completion/files/patch-reptyr84
-rw-r--r--shells/bash-completion/pkg-plist2
3 files changed, 86 insertions, 2 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 93ab56223862..66aa80d8c0c9 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bash-completion
PORTVERSION= 2.1
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
diff --git a/shells/bash-completion/files/patch-reptyr b/shells/bash-completion/files/patch-reptyr
new file mode 100644
index 000000000000..eacb1f8e4c4c
--- /dev/null
+++ b/shells/bash-completion/files/patch-reptyr
@@ -0,0 +1,84 @@
+From 6a4ad49fa53cc92d3bd23b5b4db0b3318f2ef136 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
+Date: Tue, 3 Feb 2015 07:55:22 +0200
+Subject: reptyr: Rename file to _reptyr to avoid conflict with upstreamed
+ completion
+
+https://github.com/nelhage/reptyr/pull/53
+---
+ completions/Makefile.am | 2 +-
+ completions/_reptyr | 26 ++++++++++++++++++++++++++
+ completions/reptyr | 23 -----------------------
+ 3 files changed, 27 insertions(+), 24 deletions(-)
+ create mode 100644 completions/_reptyr
+ delete mode 100644 completions/reptyr
+
+--- completions/Makefile.am
++++ completions/Makefile.am
+@@ -303,7 +303,7 @@ bashcomp_DATA = 2to3 \
+ _renice \
+ _repomanage \
+ reportbug \
+- reptyr \
++ _reptyr \
+ resolvconf \
+ rfkill \
+ ri \
+--- /dev/null
++++ completions/_reptyr
+@@ -0,0 +1,26 @@
++# bash completion for reptyr(1) -*- shell-script -*-
++
++# Use of this file is deprecated. Upstream completion is available in
++# reptyr > 0.6.2, use that instead.
++
++_reptyr()
++{
++ local cur prev words cword
++ _init_completion || return
++
++ case $prev in
++ -l)
++ return 0
++ ;;
++ esac
++
++ if [[ $cur == -* ]]; then
++ COMPREPLY=( $( compgen -W '$( _parse_help "$1" )' -- "$cur" ) )
++ return 0
++ fi
++
++ [[ $prev != +([0-9]) ]] && _pids
++} &&
++complete -F _reptyr reptyr
++
++# ex: ts=4 sw=4 et filetype=sh
+--- completions/reptyr
++++ /dev/null
+@@ -1,23 +0,0 @@
+-# bash completion for reptyr(1) -*- shell-script -*-
+-
+-_reptyr()
+-{
+- local cur prev words cword
+- _init_completion || return
+-
+- case $prev in
+- -l)
+- return 0
+- ;;
+- esac
+-
+- if [[ $cur == -* ]]; then
+- COMPREPLY=( $( compgen -W '$( _parse_help "$1" )' -- "$cur" ) )
+- return 0
+- fi
+-
+- [[ $prev != +([0-9]) ]] && _pids
+-} &&
+-complete -F _reptyr reptyr
+-
+-# ex: ts=4 sw=4 et filetype=sh
+--
+cgit v0.11.2
+
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 0c2e3af6f30c..f76334d56b15 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -1,6 +1,7 @@
libdata/pkgconfig/bash-completion.pc
%%DATADIR%%/bash_completion
%%DATADIR%%/bash_completion.sh
+%%DATADIR%%/completions/_reptyr
%%DATADIR%%/completions/a2x
%%DATADIR%%/completions/abook
%%DATADIR%%/completions/aclocal
@@ -426,7 +427,6 @@ libdata/pkgconfig/bash-completion.pc
%%DATADIR%%/completions/renice
%%DATADIR%%/completions/reportbug
%%DATADIR%%/completions/repquota
-%%DATADIR%%/completions/reptyr
%%DATADIR%%/completions/resolvconf
%%DATADIR%%/completions/rfcomm
%%DATADIR%%/completions/rfkill