aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2015-07-30 18:50:18 +0000
committerConrad Meyer <cem@FreeBSD.org>2015-07-30 18:50:18 +0000
commitb621c53816a3cf7c63a820554d9c4060b6fe8c0f (patch)
tree8e93ffeee0828d575395f8efcbfe9caba66b2672 /shells
parente614d8f47419038c14e2566aab3f9bbf3b64adac (diff)
downloadports-b621c53816a3cf7c63a820554d9c4060b6fe8c0f.tar.gz
ports-b621c53816a3cf7c63a820554d9c4060b6fe8c0f.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 2ed80f0ae535..90b7f60228d6 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 39
PORTVERSION= 4.3.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -74,6 +74,9 @@ CFLAGS+= -DIMPORT_FUNCTIONS_DEF=0
CONFIGURE_ARGS+= --enable-static-link
.else
CONFIGURE_ARGS+= --disable-static-link
+# Bash symbols must be exported in order to link runtime plugins, i.e.,
+# "enable -f". (Plugins are not supported for bash-static.)
+CFLAGS+= -Wl,-export-dynamic
.endif
post-patch: