aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-01-01 14:35:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-01-01 14:35:03 +0000
commit1d15d261eeed199fadd128f45c8669301de8ef6d (patch)
treeb277096c48014e14dc5e28290d3f6761eace1f19 /shells
parent4f4795bb753d9406d5fb025b73050bcac4714723 (diff)
downloadports-1d15d261eeed199fadd128f45c8669301de8ef6d.tar.gz
ports-1d15d261eeed199fadd128f45c8669301de8ef6d.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile2
-rw-r--r--shells/zsh/files/patch-Src_jobs.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 145cb714c9e5..10ffcaad30d8 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zsh
PORTVERSION= 5.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
diff --git a/shells/zsh/files/patch-Src_jobs.c b/shells/zsh/files/patch-Src_jobs.c
index f9f6a72acae5..6b92999146fc 100644
--- a/shells/zsh/files/patch-Src_jobs.c
+++ b/shells/zsh/files/patch-Src_jobs.c
@@ -1,6 +1,6 @@
--- Src/jobs.c.orig 2014-08-23 20:40:52.000000000 +0200
+++ Src/jobs.c 2014-09-10 10:33:50.283018759 +0200
-@@ -694,15 +694,14 @@
+@@ -694,15 +694,15 @@
/* go ahead and compute these, since almost every TIMEFMT will have them */
elapsed_time = real->tv_sec + real->tv_usec / 1000000.0;
@@ -8,7 +8,7 @@
#ifdef HAVE_GETRUSAGE
user_time = ti->ru_utime.tv_sec + ti->ru_utime.tv_usec / 1000000.0;
system_time = ti->ru_stime.tv_sec + ti->ru_stime.tv_usec / 1000000.0;
-- total_time = user_time + system_time;
+ total_time = user_time + system_time;
- percent = 100.0 * total_time
- / (real->tv_sec + real->tv_usec / 1000000.0);
+ percent = 100.0 * total_time / elapsed_time;