aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-06-24 16:49:14 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-06-24 16:49:14 +0000
commit73739ff80026cd2f036290301cf49b3ce42613ef (patch)
treed3117f4f4212d2b183283f9c2f29ad27d6c5f2e3 /shells
parent94b308cb334bd80f2a6703c2e8d749b8e8001135 (diff)
downloadports-73739ff80026cd2f036290301cf49b3ce42613ef.tar.gz
ports-73739ff80026cd2f036290301cf49b3ce42613ef.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile3
-rw-r--r--shells/fd/distinfo4
-rw-r--r--shells/fd/files/patch-fd.h15
-rw-r--r--shells/fd/files/patch-pathname.c59
-rw-r--r--shells/fd/files/patch-pathname.h10
-rw-r--r--shells/fd/files/patch-system.c18
6 files changed, 15 insertions, 94 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 6e6983007daf..ee29a706d12a 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fd
-PORTVERSION= 2.05e
-PORTREVISION= 1
+PORTVERSION= 2.05f
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index e7919c270351..c1aa0625ceca 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1,2 +1,2 @@
-MD5 (FD-2.05e.tar.gz) = 49fb688fcb87e449e19e6c91e199dc5a
-SIZE (FD-2.05e.tar.gz) = 662382
+MD5 (FD-2.05f.tar.gz) = 4ff49901eb3b024f1ac2bd27ff11a513
+SIZE (FD-2.05f.tar.gz) = 664900
diff --git a/shells/fd/files/patch-fd.h b/shells/fd/files/patch-fd.h
index 38f0333db6f3..6d4ff40f5bdc 100644
--- a/shells/fd/files/patch-fd.h
+++ b/shells/fd/files/patch-fd.h
@@ -1,6 +1,6 @@
---- fd.h.orig Wed May 12 00:00:00 2004
-+++ fd.h Wed May 26 19:07:10 2004
-@@ -171,11 +171,11 @@
+--- fd.h.orig Wed Jun 23 00:00:00 2004
++++ fd.h Fri Jun 25 01:18:25 2004
+@@ -159,11 +159,11 @@
****************************************************************/
#define MAXBINDTABLE 256
#define MAXMACROTABLE 64
@@ -15,3 +15,12 @@
#if MSDOS
#define MAXCOMMSTR (128 - 2)
#endif
+@@ -171,7 +171,7 @@
+ #define MAXSTACK 5
+ #define MAXWINDOWS 2
+ #define MAXHISTNO MAXTYPE(short)
+-#define MAXINVOKEARGS 1
++#define MAXINVOKEARGS MAXWINDOWS
+
+ #ifdef _NOSPLITWIN
+ #undef MAXWINDOWS
diff --git a/shells/fd/files/patch-pathname.c b/shells/fd/files/patch-pathname.c
deleted file mode 100644
index 478740ca4e6a..000000000000
--- a/shells/fd/files/patch-pathname.c
+++ /dev/null
@@ -1,59 +0,0 @@
---- pathname.c.orig Wed Jun 9 00:00:00 2004
-+++ pathname.c Sun Jun 13 01:48:43 2004
-@@ -141,7 +141,7 @@
-
- static char *NEAR getenvvar __P_((char *, int));
- static int NEAR setvar __P_((char *, char *, int));
--static int NEAR ismeta __P_((char *s, int, int, int));
-+static int NEAR ismeta __P_((char *s, int, int, int, int));
- #ifdef _NOORIGGLOB
- static char *NEAR cnvregexp __P_((char *, int));
- #else
-@@ -820,9 +820,9 @@
- return(s);
- }
-
--static int NEAR ismeta(s, ptr, quote, len)
-+static int NEAR ismeta(s, ptr, quote, len, flags)
- char *s;
--int ptr, quote, len;
-+int ptr, quote, len, flags;
- {
- #ifdef FAKEMETA
- return(0);
-@@ -830,7 +830,7 @@
- if (s[ptr] != PMETA || quote == '\'') return(0);
-
- if (len >= 0) {
-- if (ptr + 1 >= len) return(0);
-+ if (!(flags & EA_EOLMETA) && ptr + 1 >= len) return(0);
- # ifndef BASHSTYLE
- /* bash does not treat "\" as \ */
- if (quote == '"' && s[ptr + 1] == quote && ptr + 2 >= len)
-@@ -838,7 +838,7 @@
- # endif
- }
- else {
-- if (!s[ptr + 1]) return(0);
-+ if (!(flags & EA_EOLMETA) && !s[ptr + 1]) return(0);
- # ifndef BASHSTYLE
- /* bash does not treat "\" as \ */
- if (quote == '"' && s[ptr + 1] == quote && !s[ptr + 2])
-@@ -884,7 +884,7 @@
- re[j++] = s[i];
- continue;
- }
-- else if (ismeta(s, i, '\0', len)) {
-+ else if (ismeta(s, i, '\0', len, 0)) {
- re[j++] = s[i++];
- re[j++] = s[i];
- }
-@@ -2183,7 +2183,7 @@
- #endif
- else if (*qp == '\'') return(PC_SQUOTE);
- else if (spc && *s == spc) return(*s);
-- else if (ismeta(s, 0, *qp, len)) return(PC_META);
-+ else if (ismeta(s, 0, *qp, len, flags)) return(PC_META);
- #ifdef BASHSTYLE
- /* bash can include `...` in "..." */
- else if ((flags & EA_BACKQ) && *s == '`') {
diff --git a/shells/fd/files/patch-pathname.h b/shells/fd/files/patch-pathname.h
deleted file mode 100644
index b5ff76f4ee07..000000000000
--- a/shells/fd/files/patch-pathname.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- pathname.h.orig Wed Jun 9 00:00:00 2004
-+++ pathname.h Sun Jun 13 01:47:14 2004
-@@ -129,6 +129,7 @@
- #define EA_NOEVALQ 0010
- #define EA_STRIPQLATER 0020
- #define EA_NOUNIQDELIM 0040
-+#define EA_EOLMETA 0100
-
- #ifdef NOUID_T
- typedef u_short uid_t;
diff --git a/shells/fd/files/patch-system.c b/shells/fd/files/patch-system.c
deleted file mode 100644
index e6d4993981da..000000000000
--- a/shells/fd/files/patch-system.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- system.c.orig Wed Jun 9 00:00:00 2004
-+++ system.c Sun Jun 13 01:55:23 2004
-@@ -5795,11 +5795,12 @@
- }
- }
-
-- pc = parsechar(&(s[i]), -1,
-+ pc = parsechar(&(s[i]), -1, '$', EA_BACKQ | EA_EOLMETA,
- #ifdef BASHSTYLE
-- '$', EA_BACKQ, &(rp -> new), &(rp -> old));
-+ /* bash can include `...` in "..." */
-+ &(rp -> new), &(rp -> old));
- #else
-- '$', EA_BACKQ, &(rp -> new), NULL);
-+ &(rp -> new), NULL);
- #endif
-
- if (pc == PC_OPQUOTE || pc == PC_CLQUOTE || pc == PC_SQUOTE)