aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-06-04 15:01:37 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-06-04 15:01:37 +0000
commita5a79ff2eb02a4d87fb1bf524f7336eab2f9fbff (patch)
treea13a57b4e26d656ceb1da7cde0dfe17b5628920c /shells
parentab1e846e494f36f2399bcd78cc94df0190a805d1 (diff)
downloadports-a5a79ff2eb02a4d87fb1bf524f7336eab2f9fbff.tar.gz
ports-a5a79ff2eb02a4d87fb1bf524f7336eab2f9fbff.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/bash2/Makefile89
-rw-r--r--shells/bash2/distinfo27
-rw-r--r--shells/bash2/files/patch-ac30
-rw-r--r--shells/bash2/files/patch-af14
-rw-r--r--shells/bash2/files/patch-bashline.c118
-rw-r--r--shells/bash2/files/patch-builtins_shopt.def22
-rw-r--r--shells/bash2/files/patch-config.guess10
-rw-r--r--shells/bash2/files/patch-config.sub15
-rw-r--r--shells/bash2/files/patch-doc_bash.116
-rw-r--r--shells/bash2/files/patch-doc_bashref.texi37
-rw-r--r--shells/bash2/files/patch-redir.c11
-rw-r--r--shells/bash2/files/patch-subst.c27
-rw-r--r--shells/bash2/files/patch-terminal.c14
-rw-r--r--shells/bash2/files/patch-tests_shopt.right35
-rw-r--r--shells/bash2/files/patch-tests_shopt.tests25
-rw-r--r--shells/bash2/pkg-descr19
-rw-r--r--shells/bash2/pkg-plist212
18 files changed, 0 insertions, 722 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 6548f3d1e13c..1b49e6444e58 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -6,7 +6,6 @@
SUBDIR += 44bsd-csh
SUBDIR += bash
SUBDIR += bash-completion
- SUBDIR += bash2
SUBDIR += bush
SUBDIR += ch
SUBDIR += es
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
deleted file mode 100644
index 27966ed8d2f5..000000000000
--- a/shells/bash2/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: bash
-# Date created: 21 August 1994
-# Whom: jkh
-#
-# $FreeBSD$
-#
-
-PORTNAME= bash
-PORTVERSION= 2.05b.007
-PORTREVISION?= 6
-CATEGORIES= shells
-MASTER_SITES= ${MASTER_SITE_GNU} \
- ftp://ftp.cwru.edu/pub/bash/
-MASTER_SITE_SUBDIR= bash
-DISTFILES= bash-${PORTVERSION:C/\....$//}.tar.gz
-.if !defined(NOPORTDOCS)
-DISTFILES+= bash-doc-${PORTVERSION:C/\....$//}.tar.gz
-.endif
-
-PATCH_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
- ftp://ftp.cwru.edu/pub/bash/bash-2.05b-patches/ \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-PATCH_SITE_SUBDIR= bash/bash-2.05b-patches/:gnu obrien/:local
-PATCHFILES= bash205b-001 bash205b-002 bash205b-003 bash205b-004 \
- bash205b-005 bash205b-006 bash205b-007
-# msg00029.txt msg00031.txt msg00030.txt
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The GNU Bourne Again Shell
-
-DEPRECATED= Old, unmaintained version, use shells/bash instead
-EXPIRATION_DATE=2007-05-15
-
-CONFLICTS= bash-3*
-
-.include <bsd.port.pre.mk>
-
-LATEST_LINK= ${PORTNAME}2
-WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
-GNU_CONFIGURE= Yes
-CONFIGURE_ARGS= --with-installed-readline
-.if defined(WITH_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
-CONFIGURE_ARGS+= --enable-static-link
-.else
-CONFIGURE_ARGS+= --enable-static-link=no
-.endif
-.if defined(DEBUG)
-CONFIGURE_ARGS+= --debug
-.endif
-MAN1= bash.1 bashbug.1
-INFO= bash
-
-post-patch:
- @${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
- ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
- @${RM} -rf ${WRKSRC}/lib/readline/*.[ch] \
- ${WRKSRC}/lib/readline/Makefile
- @${TOUCH} ${WRKSRC}/lib/readline/Makefile.in
- @${REINPLACE_CMD} -E "s,^((RL|HIST)_LIBSRC = ).*,\1/usr/include/readline," ${WRKSRC}/Makefile.in
-
-update-etc-shells:
- @${ECHO_MSG} "updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @( ${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
- @${RM} /etc/shells.bak
-
-post-install: update-etc-shells
- ${LN} -f ${PREFIX}/bin/bash ${PREFIX}/bin/bash2
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/examples ; ${PAX} -rw . ${EXAMPLESDIR}
- @${FIND} ${EXAMPLESDIR} -type d -print | xargs chmod a+rx
- @${CHMOD} -R a+r ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} \
- ${WRKDIR}/doc/article.ps \
- ${WRKDIR}/doc/bashref.ps \
- ${DOCSDIR}
- ${INSTALL_MAN} \
- ${WRKDIR}/doc/article.txt \
- ${DOCSDIR}
- ${BZIP2_CMD} -f ${DOCSDIR}/*.ps
-.endif
-
-.include <bsd.port.post.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/shells/bash2/distinfo b/shells/bash2/distinfo
deleted file mode 100644
index ac66d5778f40..000000000000
--- a/shells/bash2/distinfo
+++ /dev/null
@@ -1,27 +0,0 @@
-MD5 (bash-2.05b.tar.gz) = 5238251b4926d778dfe162f6ce729733
-SHA256 (bash-2.05b.tar.gz) = ba03d412998cc54bd0b0f2d6c32100967d3137098affdc2d32e6e7c11b163fe4
-SIZE (bash-2.05b.tar.gz) = 1956216
-MD5 (bash-doc-2.05b.tar.gz) = 511b2d07f0f401f686e8edc551a8e47f
-SHA256 (bash-doc-2.05b.tar.gz) = a1a359688802da68d9a5b14e6d2bf2cfc9457f1afbed7b75a874565bf920355d
-SIZE (bash-doc-2.05b.tar.gz) = 1733577
-MD5 (bash205b-001) = 94e520fa0272b06fb03fc46042095b62
-SHA256 (bash205b-001) = bf7a055e0916b7899e7429e36e35d009db445b942b34520a601ea5a8fa634fdd
-SIZE (bash205b-001) = 1132
-MD5 (bash205b-002) = 2957bbe5f6db1830d649d1071baba63c
-SHA256 (bash205b-002) = affdd1808a6262fbfe291ebffa2133b05e4bb46067a90e3329d5741e10f0587b
-SIZE (bash205b-002) = 755
-MD5 (bash205b-003) = 2828e78563927b806246e2b4806ee0f5
-SHA256 (bash205b-003) = 604972eaafe69f44413d429e0a826b0eae209ca74b14eeeccdf0d502bbabb340
-SIZE (bash205b-003) = 2356
-MD5 (bash205b-004) = 6bf89831209ba6d208943d2ebaa7fe3a
-SHA256 (bash205b-004) = fab91e9742ca4e990666441e91821742e6dff78e8e388ba55205cf7b1cd8e8e1
-SIZE (bash205b-004) = 1110
-MD5 (bash205b-005) = 311b7f0e3dabec51767bfabe6afd4ded
-SHA256 (bash205b-005) = de80bbb3b7686c96c1d99354989c0dacfe4ae2cf082cdf7e9dc3c1c6910cce9a
-SIZE (bash205b-005) = 2217
-MD5 (bash205b-006) = f8a86d0a66b51080f3fbc5cc34ef1a06
-SHA256 (bash205b-006) = 92fd6b3313d90194bb7e8868436554866517901da801b5a0c838efc620ea0396
-SIZE (bash205b-006) = 3155
-MD5 (bash205b-007) = 37d2acecc9146883f9b331c03b274f21
-SHA256 (bash205b-007) = 0843c481bd13f4652e0ba722ea3786570b84440869e0944a3a2e1d0d4430500d
-SIZE (bash205b-007) = 1072
diff --git a/shells/bash2/files/patch-ac b/shells/bash2/files/patch-ac
deleted file mode 100644
index 56117d592f64..000000000000
--- a/shells/bash2/files/patch-ac
+++ /dev/null
@@ -1,30 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Tue Jul 16 22:31:47 2002
-+++ configure Wed Jul 24 23:54:26 2002
-@@ -1132,7 +1132,7 @@
- mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
- m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
- sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
--#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
-+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
- *-openbsd*) opt_bash_malloc=no ;; # they claim it needs eight-bit alignment
- *-aix*) opt_bash_malloc=no ;; # AIX machines
- *-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep
-@@ -15218,7 +15218,14 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- if test -d /dev/fd && test -r /dev/fd/0; then
-- bash_cv_dev_fd=standard
-+ # FreeBSD's devfs only provides /dev/fd/[0-2]
-+ exec 3<&0
-+ if test -r /dev/fd/3; then
-+ bash_cv_dev_fd=standard
-+ else
-+ bash_cv_dev_fd=absent
-+ fi
-+ exec 3<&-
- elif test -d /proc/self/fd && test -r /proc/self/fd/0; then
- bash_cv_dev_fd=whacky
- else
diff --git a/shells/bash2/files/patch-af b/shells/bash2/files/patch-af
deleted file mode 100644
index 73c7e7972ed3..000000000000
--- a/shells/bash2/files/patch-af
+++ /dev/null
@@ -1,14 +0,0 @@
---- error.c.old Wed May 24 12:04:50 2000
-+++ error.c Wed May 24 12:05:21 2000
-@@ -465,9 +465,9 @@
- terminal. */
- void
- #if defined (PREFER_STDARG)
--trace (const char *format, ...)
-+bash_trace (const char *format, ...)
- #else
--trace (format, va_alist)
-+bash_trace (format, va_alist)
- const char *format;
- va_dcl
- #endif
diff --git a/shells/bash2/files/patch-bashline.c b/shells/bash2/files/patch-bashline.c
deleted file mode 100644
index 24b74307d966..000000000000
--- a/shells/bash2/files/patch-bashline.c
+++ /dev/null
@@ -1,118 +0,0 @@
---- bashline.c.deo Tue May 7 12:52:42 2002
-+++ bashline.c Sun Sep 8 18:17:30 2002
-@@ -1873,10 +1874,6 @@
- }
- }
-
--/* Define NO_FORCE_FIGNORE if you want to match filenames that would
-- otherwise be ignored if they are the only possible matches. */
--/* #define NO_FORCE_FIGNORE */
--
- /* If FIGNORE is set, then don't match files with the given suffixes when
- completing filenames. If only one of the possibilities has an acceptable
- suffix, delete the others, else just return and let the completer
-@@ -1901,10 +1898,15 @@
- {
- char **newnames;
- int idx, nidx;
--#ifdef NO_FORCE_FIGNORE
- char **oldnames;
- int oidx;
--#endif
-+ char *no_force_fignore;
-+
-+
-+/* Set NO_FORCE_FIGNORE if you want to match filenames that would
-+ otherwise be ignored if they are the only possible matches. */
-+ no_force_fignore = get_string_value ("NO_FORCE_FIGNORE");
-+//fprintf(stderr, ">NO_FORCE_FIGNORE< is [%s]\n", no_force_fignore);
-
- /* If there is only one completion, see if it is acceptable. If it is
- not, free it up. In any case, short-circuit and return. This is a
-@@ -1912,13 +1914,12 @@
- if there is only one completion; it is the completion itself. */
- if (names[1] == (char *)0)
- {
--#ifndef NO_FORCE_FIGNORE
-- if ((*name_func) (names[0]) == 0)
-- {
-- free (names[0]);
-- names[0] = (char *)NULL;
-- }
--#endif
-+ if (!no_force_fignore)
-+ if ((*name_func) (names[0]) == 0)
-+ {
-+ free (names[0]);
-+ names[0] = (char *)NULL;
-+ }
- return;
- }
-
-@@ -1927,10 +1928,11 @@
- for (nidx = 1; names[nidx]; nidx++)
- ;
- newnames = strvec_create (nidx + 1);
--#ifdef NO_FORCE_FIGNORE
-- oldnames = strvec_create (nidx - 1);
-- oidx = 0;
--#endif
-+ if (no_force_fignore)
-+ {
-+ oldnames = strvec_create (nidx - 1);
-+ oidx = 0;
-+ }
-
- newnames[0] = names[0];
- for (idx = nidx = 1; names[idx]; idx++)
-@@ -1938,11 +1940,10 @@
- if ((*name_func) (names[idx]))
- newnames[nidx++] = names[idx];
- else
--#ifndef NO_FORCE_FIGNORE
-- free (names[idx]);
--#else
-- oldnames[oidx++] = names[idx];
--#endif
-+ if (no_force_fignore)
-+ oldnames[oidx++] = names[idx];
-+ else
-+ free (names[idx]);
- }
-
- newnames[nidx] = (char *)NULL;
-@@ -1950,21 +1951,23 @@
- /* If none are acceptable then let the completer handle it. */
- if (nidx == 1)
- {
--#ifndef NO_FORCE_FIGNORE
-- free (names[0]);
-- names[0] = (char *)NULL;
--#else
-- free (oldnames);
--#endif
-+ if (no_force_fignore)
-+ free (oldnames);
-+ else
-+ {
-+ free (names[0]);
-+ names[0] = (char *)NULL;
-+ }
- free (newnames);
- return;
- }
-
--#ifdef NO_FORCE_FIGNORE
-- while (oidx)
-- free (oldnames[--oidx]);
-- free (oldnames);
--#endif
-+ if (no_force_fignore)
-+ {
-+ while (oidx)
-+ free (oldnames[--oidx]);
-+ free (oldnames);
-+ }
-
- /* If only one is acceptable, copy it to names[0] and return. */
- if (nidx == 2)
diff --git a/shells/bash2/files/patch-builtins_shopt.def b/shells/bash2/files/patch-builtins_shopt.def
deleted file mode 100644
index 4a896b397684..000000000000
--- a/shells/bash2/files/patch-builtins_shopt.def
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- builtins/shopt.def.orig Tue Sep 11 21:55:06 2001
-+++ builtins/shopt.def Tue Nov 20 23:52:45 2001
-@@ -56,7 +56,7 @@
-
- #define OPTFMT "%-15s\t%s\n"
-
--extern int allow_null_glob_expansion, glob_dot_filenames;
-+extern int allow_null_glob_expansion, fail_glob_expansion, glob_dot_filenames;
- extern int cdable_vars, mail_warning, source_uses_path;
- extern int no_exit_on_failed_exec, print_shift_error;
- extern int check_hashed_filenames, promptvars, interactive_comments;
-@@ -140,6 +140,7 @@
- #endif
- { "nocaseglob", &glob_ignore_case, (shopt_set_func_t *)NULL },
- { "nullglob", &allow_null_glob_expansion, (shopt_set_func_t *)NULL },
-+ { "failglob", &fail_glob_expansion, (Function *)NULL },
- #if defined (PROGRAMMABLE_COMPLETION)
- { "progcomp", &prog_completion_enabled, (shopt_set_func_t *)NULL },
- #endif
diff --git a/shells/bash2/files/patch-config.guess b/shells/bash2/files/patch-config.guess
deleted file mode 100644
index a109a5e4f442..000000000000
--- a/shells/bash2/files/patch-config.guess
+++ /dev/null
@@ -1,10 +0,0 @@
---- support/config.guess.orig Wed Apr 3 16:47:14 2002
-+++ support/config.guess Fri May 16 19:42:58 2003
-@@ -782,4 +782,7 @@
- echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
- exit 0 ;;
-+ amd64:FreeBSD:*:*)
-+ echo x86_64-unknown-freebsd
-+ exit 0 ;;
- *:FreeBSD:*:*)
- echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
diff --git a/shells/bash2/files/patch-config.sub b/shells/bash2/files/patch-config.sub
deleted file mode 100644
index 457c442391da..000000000000
--- a/shells/bash2/files/patch-config.sub
+++ /dev/null
@@ -1,15 +0,0 @@
---- support/config.sub.orig Wed Apr 3 16:47:14 2002
-+++ support/config.sub Fri May 16 19:42:58 2003
-@@ -268,5 +268,5 @@
- # because (1) that's what they normally are, and
- # (2) the word "unknown" tends to confuse beginning users.
-- i*86 | x86_64)
-+ i*86 | x86_64 | amd64)
- basic_machine=$basic_machine-pc
- ;;
-@@ -282,4 +282,5 @@
- | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
- | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
-+ | amd64-* \
- | arm-* | armbe-* | armle-* | armv*-* \
- | avr-* \
diff --git a/shells/bash2/files/patch-doc_bash.1 b/shells/bash2/files/patch-doc_bash.1
deleted file mode 100644
index fc26ea10be05..000000000000
--- a/shells/bash2/files/patch-doc_bash.1
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- doc/bash.1.orig Tue Nov 13 18:55:59 2001
-+++ doc/bash.1 Tue Nov 20 23:52:45 2001
-@@ -2473,6 +2473,10 @@
- .B nullglob
- option is set, and no matches are found,
- the word is removed.
-+If the
-+.B failglob
-+option is set, and no matches are found, an error message is printed
-+and the command is not executed.
- If the shell option
- .B nocaseglob
- is enabled, the match is performed without regard to the case
diff --git a/shells/bash2/files/patch-doc_bashref.texi b/shells/bash2/files/patch-doc_bashref.texi
deleted file mode 100644
index b4fc6acc6e6e..000000000000
--- a/shells/bash2/files/patch-doc_bashref.texi
+++ /dev/null
@@ -1,37 +0,0 @@
-
-$FreeBSD$
-
---- doc/bashref.texi.orig Tue Nov 13 18:55:03 2001
-+++ doc/bashref.texi Tue Nov 20 23:52:45 2001
-@@ -1700,7 +1700,8 @@
- and replaced with an alphabetically sorted list of
- file names matching the pattern. If no matching file names are found,
- and the shell option @code{nullglob} is disabled, the word is left
--unchanged.
-+unchanged. If the @code{failglob} option is set, an error message is
-+printed and the commandline is not executed.
- If the @code{nullglob} option is set, and no matches are found, the word
- is removed.
- If the shell option @code{nocaseglob} is enabled, the match is performed
-@@ -1713,8 +1714,8 @@
- matched explicitly.
- In other cases, the @samp{.} character is not treated specially.
-
--See the description of @code{shopt} in @ref{Bash Builtins},
--for a description of the @code{nocaseglob}, @code{nullglob},
-+See the description of @code{shopt} in @ref{Bash Builtins}, for a
-+description of the @code{nocaseglob}, @code{nullglob}, @code{failglob}
- and @code{dotglob} options.
-
- The @env{GLOBIGNORE}
-@@ -3372,6 +3373,10 @@
- @item extglob
- If set, the extended pattern matching features described above
- (@pxref{Pattern Matching}) are enabled.
-+
-+@item failglob
-+If set, filenames that have globbing characters in them, but don't match
-+anything, will cause an error.
-
- @item histappend
- If set, the history list is appended to the file named by the value
diff --git a/shells/bash2/files/patch-redir.c b/shells/bash2/files/patch-redir.c
deleted file mode 100644
index 259e4b1d87bc..000000000000
--- a/shells/bash2/files/patch-redir.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- redir.c.orig Tue Mar 12 12:27:38 2002
-+++ redir.c Thu May 5 07:41:18 2005
-@@ -263,7 +263,7 @@ write_here_string (fd, redirectee)
- int herelen, n, e;
-
- herestr = expand_string_to_string (redirectee->word, 0);
-- herelen = strlen (herestr);
-+ herelen = (herestr == NULL) ? 0 : strlen (herestr);
-
- n = write (fd, herestr, herelen);
- if (n == herelen)
diff --git a/shells/bash2/files/patch-subst.c b/shells/bash2/files/patch-subst.c
deleted file mode 100644
index 8ef29a8b5774..000000000000
--- a/shells/bash2/files/patch-subst.c
+++ /dev/null
@@ -1,27 +0,0 @@
-
-$FreeBSD$
-
---- subst.c.orig Mon Nov 5 20:19:49 2001
-+++ subst.c Tue Nov 20 23:52:45 2001
-@@ -121,6 +121,9 @@
- a null file. */
- int allow_null_glob_expansion;
-
-+/* Non-zero means to signal an error when globbing fails to match. */
-+int fail_glob_expansion;
-+
- #if 0
- /* Variables to keep track of which words in an expanded word list (the
- output of expand_word_list_internal) are the result of globbing
-@@ -6132,6 +6135,11 @@
- {
- output_list = (WORD_LIST *)list_append (glob_list, output_list);
- PREPEND_LIST (tlist, disposables);
-+ }
-+ else if (fail_glob_expansion != 0)
-+ {
-+ report_error ("no match: %s", tlist->word->word);
-+ jump_to_top_level (DISCARD);
- }
- else if (allow_null_glob_expansion == 0)
- {
diff --git a/shells/bash2/files/patch-terminal.c b/shells/bash2/files/patch-terminal.c
deleted file mode 100644
index 6f8b017b0a3a..000000000000
--- a/shells/bash2/files/patch-terminal.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/readline/terminal.c.orig Tue Mar 5 02:23:09 2002
-+++ lib/readline/terminal.c Wed Jul 24 05:57:59 2002
-@@ -313,7 +313,11 @@
- { "ei", &_rl_term_ei },
- { "ic", &_rl_term_ic },
- { "im", &_rl_term_im },
-+#ifdef __FreeBSD__
-+ { "@7", &_rl_term_kH }, /* home down ?? */
-+#else
- { "kH", &_rl_term_kH }, /* home down ?? */
-+#endif
- { "kI", &_rl_term_kI }, /* insert */
- { "kd", &_rl_term_kd },
- { "ke", &_rl_term_ke }, /* end keypad mode */
diff --git a/shells/bash2/files/patch-tests_shopt.right b/shells/bash2/files/patch-tests_shopt.right
deleted file mode 100644
index fbbd9a8a27ff..000000000000
--- a/shells/bash2/files/patch-tests_shopt.right
+++ /dev/null
@@ -1,35 +0,0 @@
-
-$FreeBSD$
-
---- tests/shopt.right.orig Wed May 9 19:40:39 2001
-+++ tests/shopt.right Tue Nov 20 23:52:45 2001
-@@ -22,6 +22,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s progcomp
- shopt -s promptvars
- shopt -u restricted_shell
-@@ -58,6 +59,7 @@
- shopt -u no_empty_cmd_completion
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -u restricted_shell
- shopt -u shift_verbose
- shopt -u xpg_echo
-@@ -78,6 +80,7 @@
- no_empty_cmd_completion off
- nocaseglob off
- nullglob off
-+failglob off
- restricted_shell off
- shift_verbose off
- xpg_echo off
-@@ -205,3 +208,5 @@
- --
- ./shopt.tests: shopt: xyz1: unknown shell option name
- ./shopt.tests: shopt: xyz1: unknown option name
-+tmp/l1 tmp/l2 tmp/*4 tmp/l3
-+./shopt.tests: no match: tmp/*4
diff --git a/shells/bash2/files/patch-tests_shopt.tests b/shells/bash2/files/patch-tests_shopt.tests
deleted file mode 100644
index ad2eac3d811e..000000000000
--- a/shells/bash2/files/patch-tests_shopt.tests
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- tests/shopt.tests.orig Tue Sep 21 17:49:32 1999
-+++ tests/shopt.tests Tue Nov 20 23:52:45 2001
-@@ -21,6 +21,7 @@
- shopt -u mailwarn
- shopt -u nocaseglob
- shopt -u nullglob
-+shopt -u failglob
- shopt -s promptvars
- shopt -u shift_verbose
- shopt -s sourcepath
-@@ -92,3 +93,11 @@
- builtin printf -- "--\n"
- shopt -p xyz1
- shopt -o -p xyz1
-+
-+mkdir tmp
-+touch tmp/l1 tmp/l2 tmp/l3
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+shopt -s failglob
-+builtin echo tmp/l[12] tmp/*4 tmp/*3
-+rm -r tmp
-+shopt -u failglob
diff --git a/shells/bash2/pkg-descr b/shells/bash2/pkg-descr
deleted file mode 100644
index 7173cc3b1bd4..000000000000
--- a/shells/bash2/pkg-descr
+++ /dev/null
@@ -1,19 +0,0 @@
-Bash is the GNU Project's Bourne Again SHell
-An interactive shell with Bourne shell syntax (/bin/sh);
-It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
-Tools standard. It includes the following features:
-interactive command line editing, job control on architectures that support it,
-Korn shell (ksh) features, Csh-like history features and brace expansion,
-history and command re-entry, job control, shell functions and aliases,
-arrays, arithmetic, ANSI-C quoting, tilde expansion, brace expansion,
-substring capabilities, indirect variable expansion, expanded i/o capabilities,
-control of builtin commands, help, shell optional behavior, prompt
-customization, security, directory stack, POSIX mode, internationalization,
-and command timing.
-
-For more information on the features of Bash that are new to this type
-of shell, see the file `documentation/features.texi'.
-There is also a processed DVI file there, as well as a large man page.
-
-WWW: http://www.gnu.org/software/bash/
- http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html
diff --git a/shells/bash2/pkg-plist b/shells/bash2/pkg-plist
deleted file mode 100644
index dfd1175bcc15..000000000000
--- a/shells/bash2/pkg-plist
+++ /dev/null
@@ -1,212 +0,0 @@
-@comment $FreeBSD$
-bin/bash
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
-bin/bash2
-bin/bashbug
-%%PORTDOCS%%%%DOCSDIR%%/article.ps.bz2
-%%PORTDOCS%%%%DOCSDIR%%/bashref.ps.bz2
-%%PORTDOCS%%%%DOCSDIR%%/article.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%EXAMPLESDIR%%/bashdb/PERMISSION
-%%EXAMPLESDIR%%/bashdb/bashdb
-%%EXAMPLESDIR%%/bashdb/bashdb.el
-%%EXAMPLESDIR%%/complete/complete-examples
-%%EXAMPLESDIR%%/complete/complete.ianmac
-%%EXAMPLESDIR%%/complete/complete2.ianmac
-%%EXAMPLESDIR%%/complete/complete.freebsd
-%%EXAMPLESDIR%%/complete/complete.gnu-longopt
-%%EXAMPLESDIR%%/functions/array-stuff
-%%EXAMPLESDIR%%/functions/array-to-string
-%%EXAMPLESDIR%%/functions/autoload
-%%EXAMPLESDIR%%/functions/autoload.v2
-%%EXAMPLESDIR%%/functions/autoload.v3
-%%EXAMPLESDIR%%/functions/basename
-%%EXAMPLESDIR%%/functions/basename2
-%%EXAMPLESDIR%%/functions/coproc.bash
-%%EXAMPLESDIR%%/functions/coshell.README
-%%EXAMPLESDIR%%/functions/coshell.bash
-%%EXAMPLESDIR%%/functions/csh-compat
-%%EXAMPLESDIR%%/functions/dirfuncs
-%%EXAMPLESDIR%%/functions/dirname
-%%EXAMPLESDIR%%/functions/emptydir
-%%EXAMPLESDIR%%/functions/exitstat
-%%EXAMPLESDIR%%/functions/external
-%%EXAMPLESDIR%%/functions/fact
-%%EXAMPLESDIR%%/functions/fstty
-%%EXAMPLESDIR%%/functions/func
-%%EXAMPLESDIR%%/functions/gethtml
-%%EXAMPLESDIR%%/functions/getoptx.bash
-%%EXAMPLESDIR%%/functions/inetaddr
-%%EXAMPLESDIR%%/functions/inpath
-%%EXAMPLESDIR%%/functions/isnum.bash
-%%EXAMPLESDIR%%/functions/isnum2
-%%EXAMPLESDIR%%/functions/isvalidip
-%%EXAMPLESDIR%%/functions/jdate.bash
-%%EXAMPLESDIR%%/functions/jj.bash
-%%EXAMPLESDIR%%/functions/keep
-%%EXAMPLESDIR%%/functions/ksh-cd
-%%EXAMPLESDIR%%/functions/ksh-compat-test
-%%EXAMPLESDIR%%/functions/kshenv
-%%EXAMPLESDIR%%/functions/login
-%%EXAMPLESDIR%%/functions/lowercase
-%%EXAMPLESDIR%%/functions/manpage
-%%EXAMPLESDIR%%/functions/mhfold
-%%EXAMPLESDIR%%/functions/notify.bash
-%%EXAMPLESDIR%%/functions/pathfuncs
-%%EXAMPLESDIR%%/functions/recurse
-%%EXAMPLESDIR%%/functions/repeat2
-%%EXAMPLESDIR%%/functions/repeat3
-%%EXAMPLESDIR%%/functions/seq
-%%EXAMPLESDIR%%/functions/seq2
-%%EXAMPLESDIR%%/functions/shcat
-%%EXAMPLESDIR%%/functions/shcat2
-%%EXAMPLESDIR%%/functions/sort-pos-params
-%%EXAMPLESDIR%%/functions/substr
-%%EXAMPLESDIR%%/functions/substr2
-%%EXAMPLESDIR%%/functions/term
-%%EXAMPLESDIR%%/functions/whatis
-%%EXAMPLESDIR%%/functions/whence
-%%EXAMPLESDIR%%/functions/which
-%%EXAMPLESDIR%%/functions/xalias.bash
-%%EXAMPLESDIR%%/functions/xfind.bash
-%%EXAMPLESDIR%%/loadables/perl/Makefile
-%%EXAMPLESDIR%%/loadables/perl/Makefile.in
-%%EXAMPLESDIR%%/loadables/perl/README
-%%EXAMPLESDIR%%/loadables/perl/bperl.c
-%%EXAMPLESDIR%%/loadables/perl/iperl.c
-%%EXAMPLESDIR%%/loadables/README
-%%EXAMPLESDIR%%/loadables/template.c
-%%EXAMPLESDIR%%/loadables/Makefile
-%%EXAMPLESDIR%%/loadables/Makefile.in
-%%EXAMPLESDIR%%/loadables/necho.c
-%%EXAMPLESDIR%%/loadables/hello.c
-%%EXAMPLESDIR%%/loadables/print.c
-%%EXAMPLESDIR%%/loadables/realpath.c
-%%EXAMPLESDIR%%/loadables/sleep.c
-%%EXAMPLESDIR%%/loadables/truefalse.c
-%%EXAMPLESDIR%%/loadables/getconf.h
-%%EXAMPLESDIR%%/loadables/getconf.c
-%%EXAMPLESDIR%%/loadables/finfo.c
-%%EXAMPLESDIR%%/loadables/cat.c
-%%EXAMPLESDIR%%/loadables/cut.c
-%%EXAMPLESDIR%%/loadables/logname.c
-%%EXAMPLESDIR%%/loadables/basename.c
-%%EXAMPLESDIR%%/loadables/dirname.c
-%%EXAMPLESDIR%%/loadables/tty.c
-%%EXAMPLESDIR%%/loadables/pathchk.c
-%%EXAMPLESDIR%%/loadables/tee.c
-%%EXAMPLESDIR%%/loadables/rmdir.c
-%%EXAMPLESDIR%%/loadables/head.c
-%%EXAMPLESDIR%%/loadables/printenv.c
-%%EXAMPLESDIR%%/loadables/push.c
-%%EXAMPLESDIR%%/loadables/id.c
-%%EXAMPLESDIR%%/loadables/whoami.c
-%%EXAMPLESDIR%%/loadables/uname.c
-%%EXAMPLESDIR%%/loadables/sync.c
-%%EXAMPLESDIR%%/loadables/mkdir.c
-%%EXAMPLESDIR%%/loadables/ln.c
-%%EXAMPLESDIR%%/loadables/unlink.c
-%%EXAMPLESDIR%%/misc/suncmd.termcap
-%%EXAMPLESDIR%%/misc/aliasconv.sh
-%%EXAMPLESDIR%%/misc/aliasconv.bash
-%%EXAMPLESDIR%%/misc/cshtobash
-%%EXAMPLESDIR%%/scripts/adventure.sh
-%%EXAMPLESDIR%%/scripts/bcsh.sh
-%%EXAMPLESDIR%%/scripts/cat.sh
-%%EXAMPLESDIR%%/scripts/center
-%%EXAMPLESDIR%%/scripts/dd-ex.sh
-%%EXAMPLESDIR%%/scripts/fixfiles.bash
-%%EXAMPLESDIR%%/scripts/hanoi.bash
-%%EXAMPLESDIR%%/scripts/inpath
-%%EXAMPLESDIR%%/scripts/krand.bash
-%%EXAMPLESDIR%%/scripts/line-input.bash
-%%EXAMPLESDIR%%/scripts/nohup.bash
-%%EXAMPLESDIR%%/scripts/precedence
-%%EXAMPLESDIR%%/scripts/randomcard.bash
-%%EXAMPLESDIR%%/scripts/scrollbar
-%%EXAMPLESDIR%%/scripts/scrollbar2
-%%EXAMPLESDIR%%/scripts/self-repro
-%%EXAMPLESDIR%%/scripts/showperm.bash
-%%EXAMPLESDIR%%/scripts/shprompt
-%%EXAMPLESDIR%%/scripts/spin.bash
-%%EXAMPLESDIR%%/scripts/timeout
-%%EXAMPLESDIR%%/scripts/vtree2
-%%EXAMPLESDIR%%/scripts/vtree3
-%%EXAMPLESDIR%%/scripts/vtree3a
-%%EXAMPLESDIR%%/scripts/websrv.sh
-%%EXAMPLESDIR%%/scripts/xterm_title
-%%EXAMPLESDIR%%/scripts/zprintf
-%%EXAMPLESDIR%%/scripts.v2/PERMISSION
-%%EXAMPLESDIR%%/scripts.v2/README
-%%EXAMPLESDIR%%/scripts.v2/arc2tarz
-%%EXAMPLESDIR%%/scripts.v2/bashrand
-%%EXAMPLESDIR%%/scripts.v2/cal2day.bash
-%%EXAMPLESDIR%%/scripts.v2/cdhist.bash
-%%EXAMPLESDIR%%/scripts.v2/corename
-%%EXAMPLESDIR%%/scripts.v2/fman
-%%EXAMPLESDIR%%/scripts.v2/frcp
-%%EXAMPLESDIR%%/scripts.v2/lowercase
-%%EXAMPLESDIR%%/scripts.v2/ncp
-%%EXAMPLESDIR%%/scripts.v2/newext
-%%EXAMPLESDIR%%/scripts.v2/nmv
-%%EXAMPLESDIR%%/scripts.v2/pages
-%%EXAMPLESDIR%%/scripts.v2/pf
-%%EXAMPLESDIR%%/scripts.v2/ren
-%%EXAMPLESDIR%%/scripts.v2/rename
-%%EXAMPLESDIR%%/scripts.v2/repeat
-%%EXAMPLESDIR%%/scripts.v2/untar
-%%EXAMPLESDIR%%/scripts.v2/uudec
-%%EXAMPLESDIR%%/scripts.v2/uuenc
-%%EXAMPLESDIR%%/scripts.v2/vtree
-%%EXAMPLESDIR%%/scripts.v2/where
-%%EXAMPLESDIR%%/scripts.v2/pmtop
-%%EXAMPLESDIR%%/scripts.v2/shprof
-%%EXAMPLESDIR%%/scripts.noah/PERMISSION
-%%EXAMPLESDIR%%/scripts.noah/README
-%%EXAMPLESDIR%%/scripts.noah/aref.bash
-%%EXAMPLESDIR%%/scripts.noah/bash.sub.bash
-%%EXAMPLESDIR%%/scripts.noah/bash_version.bash
-%%EXAMPLESDIR%%/scripts.noah/meta.bash
-%%EXAMPLESDIR%%/scripts.noah/mktmp.bash
-%%EXAMPLESDIR%%/scripts.noah/number.bash
-%%EXAMPLESDIR%%/scripts.noah/prompt.bash
-%%EXAMPLESDIR%%/scripts.noah/remap_keys.bash
-%%EXAMPLESDIR%%/scripts.noah/require.bash
-%%EXAMPLESDIR%%/scripts.noah/send_mail.bash
-%%EXAMPLESDIR%%/scripts.noah/shcat.bash
-%%EXAMPLESDIR%%/scripts.noah/source.bash
-%%EXAMPLESDIR%%/scripts.noah/string.bash
-%%EXAMPLESDIR%%/scripts.noah/stty.bash
-%%EXAMPLESDIR%%/scripts.noah/y_or_n_p.bash
-%%EXAMPLESDIR%%/startup-files/apple/README
-%%EXAMPLESDIR%%/startup-files/apple/aliases
-%%EXAMPLESDIR%%/startup-files/apple/bash.defaults
-%%EXAMPLESDIR%%/startup-files/apple/environment
-%%EXAMPLESDIR%%/startup-files/apple/login
-%%EXAMPLESDIR%%/startup-files/apple/logout
-%%EXAMPLESDIR%%/startup-files/apple/rc
-%%EXAMPLESDIR%%/startup-files/README
-%%EXAMPLESDIR%%/startup-files/Bashrc.bfox
-%%EXAMPLESDIR%%/startup-files/Bash_aliases
-%%EXAMPLESDIR%%/startup-files/Bash_profile
-%%EXAMPLESDIR%%/startup-files/bash-profile
-%%EXAMPLESDIR%%/startup-files/bashrc
-%%EXAMPLESDIR%%/obashdb/PERMISSION
-%%EXAMPLESDIR%%/obashdb/README
-%%EXAMPLESDIR%%/obashdb/bashdb
-%%EXAMPLESDIR%%/obashdb/bashdb.fns
-%%EXAMPLESDIR%%/obashdb/bashdb.pre
-@dirrm %%EXAMPLESDIR%%/bashdb
-@dirrm %%EXAMPLESDIR%%/complete
-@dirrm %%EXAMPLESDIR%%/functions
-@dirrm %%EXAMPLESDIR%%/loadables/perl
-@dirrm %%EXAMPLESDIR%%/loadables
-@dirrm %%EXAMPLESDIR%%/misc
-@dirrm %%EXAMPLESDIR%%/obashdb
-@dirrm %%EXAMPLESDIR%%/scripts
-@dirrm %%EXAMPLESDIR%%/scripts.noah
-@dirrm %%EXAMPLESDIR%%/scripts.v2
-@dirrm %%EXAMPLESDIR%%/startup-files/apple
-@dirrm %%EXAMPLESDIR%%/startup-files
-@dirrm %%EXAMPLESDIR%%