aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2007-01-07 22:00:21 +0000
committerThomas Gellekum <tg@FreeBSD.org>2007-01-07 22:00:21 +0000
commitae84ec6c0f23ab5aa3d24ee9ca53e28b5911dd51 (patch)
treeb9dd0632ccff83a65576472910b46bf203e203e5 /shells
parentee3df70d623849cc66eeed8ef880cac24a04ecdd (diff)
downloadports-ae84ec6c0f23ab5aa3d24ee9ca53e28b5911dd51.tar.gz
ports-ae84ec6c0f23ab5aa3d24ee9ca53e28b5911dd51.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/pdksh/Makefile2
-rw-r--r--shells/pdksh/files/patch-edit.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/shells/pdksh/Makefile b/shells/pdksh/Makefile
index 85c6d9d72101..e39e0ccb03dd 100644
--- a/shells/pdksh/Makefile
+++ b/shells/pdksh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdksh
PORTVERSION= 5.2.14p2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= ftp://ftp.cs.mun.ca/pub/pdksh/ \
http://gd.tuwien.ac.at/utils/shells/pdksh/ \
diff --git a/shells/pdksh/files/patch-edit.c b/shells/pdksh/files/patch-edit.c
new file mode 100644
index 000000000000..e4f7b6ecbcc7
--- /dev/null
+++ b/shells/pdksh/files/patch-edit.c
@@ -0,0 +1,10 @@
+--- edit.c.orig Thu May 13 19:04:33 1999
++++ edit.c Sun Jan 7 22:48:23 2007
+@@ -344,6 +344,7 @@
+ */
+ if (*cp && cp[1] == '\r') {
+ delimiter = *cp;
++ indelimit = !indelimit;
+ cp += 2;
+ }
+