aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2020-07-22 19:46:00 +0000
committerSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2020-07-22 19:46:00 +0000
commit29b0ff23a5afb25a64dbc4d31f92c5789f3e6806 (patch)
treeaa2fa6c16c97e3f34fb1d1ca394ffe9f20531fd6 /shells
parentd5fc1155818ef508296aea9d5fde3131387401d7 (diff)
downloadports-29b0ff23a5afb25a64dbc4d31f92c5789f3e6806.tar.gz
ports-29b0ff23a5afb25a64dbc4d31f92c5789f3e6806.zip
Update and adjust shells/ohmyzsh
- Update to 2020-07-22 - Add comments to the patches in files/ [1] - Use XDG cache directory if present [1] - Rewrite port description to have something more factual with a bit less of hype [1] PR: 247887 [1] Submitted by: fernape, mat [1]
Notes
Notes: svn path=/head/; revision=542890
Diffstat (limited to 'shells')
-rw-r--r--shells/ohmyzsh/Makefile4
-rw-r--r--shells/ohmyzsh/distinfo6
-rw-r--r--shells/ohmyzsh/files/patch-oh-my-zsh.sh12
-rw-r--r--shells/ohmyzsh/files/patch-templates_zshrc.zsh-template2
-rw-r--r--shells/ohmyzsh/files/pkg-message.in3
-rw-r--r--shells/ohmyzsh/pkg-descr12
-rw-r--r--shells/ohmyzsh/pkg-plist1
7 files changed, 19 insertions, 21 deletions
diff --git a/shells/ohmyzsh/Makefile b/shells/ohmyzsh/Makefile
index d240c143b70e..d7ef59539d76 100644
--- a/shells/ohmyzsh/Makefile
+++ b/shells/ohmyzsh/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ohmyzsh
-PORTVERSION= 20200706
+PORTVERSION= 20200722
CATEGORIES= shells
MAINTAINER= skozlov@FreeBSD.org
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= zsh:shells/zsh
USE_GITHUB= yes
-GH_TAGNAME= 1c58a746af7a67f311ee47f97285a855eaf18b5e
+GH_TAGNAME= db3d05f
NO_ARCH= yes
NO_BUILD= yes
diff --git a/shells/ohmyzsh/distinfo b/shells/ohmyzsh/distinfo
index 24638df456c0..a0117d44883a 100644
--- a/shells/ohmyzsh/distinfo
+++ b/shells/ohmyzsh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594050806
-SHA256 (ohmyzsh-ohmyzsh-20200706-1c58a746af7a67f311ee47f97285a855eaf18b5e_GH0.tar.gz) = cc9ce90a0543798715aa972c898d8ef017e131937d28271c9e053fc9360290c1
-SIZE (ohmyzsh-ohmyzsh-20200706-1c58a746af7a67f311ee47f97285a855eaf18b5e_GH0.tar.gz) = 648364
+TIMESTAMP = 1595444062
+SHA256 (ohmyzsh-ohmyzsh-20200722-db3d05f_GH0.tar.gz) = 0991e6576d4253565db47ad27453a61cad52dca69a3b06a6cfe142fa46528ce2
+SIZE (ohmyzsh-ohmyzsh-20200722-db3d05f_GH0.tar.gz) = 648935
diff --git a/shells/ohmyzsh/files/patch-oh-my-zsh.sh b/shells/ohmyzsh/files/patch-oh-my-zsh.sh
index ef65e5304580..12bab5e90f22 100644
--- a/shells/ohmyzsh/files/patch-oh-my-zsh.sh
+++ b/shells/ohmyzsh/files/patch-oh-my-zsh.sh
@@ -1,8 +1,11 @@
---- oh-my-zsh.sh.orig 2020-07-06 15:31:40 UTC
+Disable auto update
+Respect XDG cache directory if present.
+--- oh-my-zsh.sh.orig 2020-07-18 17:06:08 UTC
+++ oh-my-zsh.sh
-@@ -1,12 +1,7 @@
+@@ -1,12 +1,8 @@
# Set ZSH_CACHE_DIR to the path where cache files should be created
- # or else we will use the default cache/
+-# or else we will use the default cache/
++# or else we will use the default .cache/
if [[ -z "$ZSH_CACHE_DIR" ]]; then
- ZSH_CACHE_DIR="$ZSH/cache"
-fi
@@ -10,7 +13,8 @@
-# Check for updates on initial load...
-if [ "$DISABLE_AUTO_UPDATE" != "true" ]; then
- source $ZSH/tools/check_for_upgrade.sh
-+ ZSH_CACHE_DIR="$HOME/.oh-my-zsh/cache"
++ ZSH_CACHE_DIR="${XDG_CACHE_HOME:-$HOME/.cache}/oh-my-zsh"
++ mkdir -p ${ZSH_CACHE_DIR}
fi
# Initializes Oh My Zsh
diff --git a/shells/ohmyzsh/files/patch-templates_zshrc.zsh-template b/shells/ohmyzsh/files/patch-templates_zshrc.zsh-template
index 42a9141e4f05..e6e92efb8609 100644
--- a/shells/ohmyzsh/files/patch-templates_zshrc.zsh-template
+++ b/shells/ohmyzsh/files/patch-templates_zshrc.zsh-template
@@ -1,3 +1,5 @@
+Correct installation path
+Disable auto update bits
--- templates/zshrc.zsh-template.orig 2020-07-06 15:31:40 UTC
+++ templates/zshrc.zsh-template
@@ -2,7 +2,7 @@
diff --git a/shells/ohmyzsh/files/pkg-message.in b/shells/ohmyzsh/files/pkg-message.in
index 3b1030ad7ace..74a29f012352 100644
--- a/shells/ohmyzsh/files/pkg-message.in
+++ b/shells/ohmyzsh/files/pkg-message.in
@@ -8,9 +8,6 @@ cp ~/.zshrc ~/.zshrc.orig
2. Create a new zsh configuration file
cp %%DATADIR%%/templates/zshrc.zsh-template ~/.zshrc
-
-3. Create Oh My Zsh cache directory
-mkdir -p ~/.oh-my-zsh/cache
EOM
}
]
diff --git a/shells/ohmyzsh/pkg-descr b/shells/ohmyzsh/pkg-descr
index c349ab0b4ef6..d28ac32dd44c 100644
--- a/shells/ohmyzsh/pkg-descr
+++ b/shells/ohmyzsh/pkg-descr
@@ -1,17 +1,11 @@
Oh My Zsh is an open source, community-driven framework for managing your zsh
configuration.
+It provides plugins for things like ansible, bazel, git, tmux, etc. It is fully
+customizable and provides dozens of different themes.
+
Sounds boring. Let's try again.
Oh My Zsh will not make you a 10x developer...but you may feel like one.
-Once installed, your terminal shell will become the talk of the town or your
-money back! With each keystroke in your command prompt, you'll take advantage of
-the hundreds of powerful plugins and beautiful themes. Strangers will come up to
-you in cafes and ask yo, "that is amazing! are you some sort of genis?"
-
-Finally, you'll begin to get the sort of attention that you have always felt you
-deserved. ...or maybe you'll use the time that you're saving to start flossing
-more often.
-
WWW: https://ohmyz.sh/
diff --git a/shells/ohmyzsh/pkg-plist b/shells/ohmyzsh/pkg-plist
index a682b78e3101..08e993c51866 100644
--- a/shells/ohmyzsh/pkg-plist
+++ b/shells/ohmyzsh/pkg-plist
@@ -307,6 +307,7 @@
%%DATADIR%%/plugins/homestead/homestead.plugin.zsh
%%DATADIR%%/plugins/httpie/README.md
%%DATADIR%%/plugins/httpie/_httpie
+%%DATADIR%%/plugins/httpie/httpie.plugin.zsh
%%DATADIR%%/plugins/ionic/README.md
%%DATADIR%%/plugins/ionic/ionic.plugin.zsh
%%DATADIR%%/plugins/iterm2/README.md