aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-01-31 05:41:20 +0000
committerCy Schubert <cy@FreeBSD.org>2020-01-31 05:41:20 +0000
commitef96722aeb958301e8d64b8f03befe87a7f12fd8 (patch)
tree2e65989bd15bcd76b19fa4f6619a6f2d73dd81d9 /shells
parentf5b4b958e98ca49ff0782f995c9e814c5845c1cf (diff)
downloadports-ef96722aeb958301e8d64b8f03befe87a7f12fd8.tar.gz
ports-ef96722aeb958301e8d64b8f03befe87a7f12fd8.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93-devel/Makefile4
-rw-r--r--shells/ksh93-devel/distinfo6
-rw-r--r--shells/ksh93-devel/files/extra-patch-install-as-ksh9315
-rw-r--r--shells/ksh93-devel/pkg-plist3
4 files changed, 18 insertions, 10 deletions
diff --git a/shells/ksh93-devel/Makefile b/shells/ksh93-devel/Makefile
index 00e43cb31843..6ed8ce73bf2c 100644
--- a/shells/ksh93-devel/Makefile
+++ b/shells/ksh93-devel/Makefile
@@ -12,8 +12,8 @@ LICENSE= EPL
USES= compiler:c11 meson ninja python:build
-HASH= 031d73aa
-AST_COMMIT_DATE= 2020.01.11
+HASH= db54d369
+AST_COMMIT_DATE= 2020.01.30
USE_GITHUB= yes
GH_ACCOUNT= att
diff --git a/shells/ksh93-devel/distinfo b/shells/ksh93-devel/distinfo
index 7e80764e2ea1..99d5502da076 100644
--- a/shells/ksh93-devel/distinfo
+++ b/shells/ksh93-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578763618
-SHA256 (att-ast-2020.01.11-031d73aa_GH0.tar.gz) = 6addb573a6e2059cad4de53ab75ac09694776f7e9ac98f28c24c43e9f19a2c48
-SIZE (att-ast-2020.01.11-031d73aa_GH0.tar.gz) = 2228653
+TIMESTAMP = 1580443934
+SHA256 (att-ast-2020.01.30-db54d369_GH0.tar.gz) = 322deb2c6e63726751de7d0f0e1bae8de4047849b1956432a33555de11f5a750
+SIZE (att-ast-2020.01.30-db54d369_GH0.tar.gz) = 2229756
diff --git a/shells/ksh93-devel/files/extra-patch-install-as-ksh93 b/shells/ksh93-devel/files/extra-patch-install-as-ksh93
index e6406f59b035..0ef50874bd81 100644
--- a/shells/ksh93-devel/files/extra-patch-install-as-ksh93
+++ b/shells/ksh93-devel/files/extra-patch-install-as-ksh93
@@ -1,6 +1,6 @@
---- ./src/cmd/ksh93/meson.build.orig 2019-09-16 17:08:04.000000000 -0700
-+++ ./src/cmd/ksh93/meson.build 2019-09-17 11:55:21.799030000 -0700
-@@ -27,13 +27,13 @@
+--- src/cmd/ksh93/meson.build.orig 2020-01-30 18:34:35.000000000 -0800
++++ src/cmd/ksh93/meson.build 2020-01-30 20:47:13.410465000 -0800
+@@ -26,7 +26,7 @@
dependencies: [libm_dep, libexecinfo_dep, libdl_dep, libsocket_dep, libnsl_dep],
install: get_option('default_library') == 'shared')
@@ -9,7 +9,14 @@
include_directories: [configuration_incdir, ksh93_incdir],
link_with: [libksh, libast, libcmd, libdll],
dependencies: [libm_dep, libexecinfo_dep, libdl_dep],
- install: true)
+@@ -34,11 +34,11 @@
+
+ # Create a symlink for a restricted version of the ksh shell.
+ create_rksh_symlink = find_program(source_dir + '/scripts/create_rksh_symlink')
+-rksh93_exe = custom_target('rksh', input: ksh93_exe, output: 'rksh', build_by_default: true,
++rksh93_exe = custom_target('rksh', input: ksh93_exe, output: 'rksh93', build_by_default: true,
+ install: true, install_mode: 'rwxr-xr-x', install_dir: install_prefix + '/bin',
+ command: [create_rksh_symlink, '@INPUT@'])
-shcomp_exe = executable('shcomp', ['sh/shcomp.c'], c_args: shared_c_args,
+shcomp_exe = executable('shcomp93', ['sh/shcomp.c'], c_args: shared_c_args,
diff --git a/shells/ksh93-devel/pkg-plist b/shells/ksh93-devel/pkg-plist
index 2aea210d2ac2..0e4d7d5e0b2f 100644
--- a/shells/ksh93-devel/pkg-plist
+++ b/shells/ksh93-devel/pkg-plist
@@ -1,8 +1,9 @@
@shell bin/ksh%%93%%
+@shell bin/rksh%%93%%
bin/shcomp%%93%%
man/man1/ksh%%93%%.1.gz
share/ksh/config.ksh
-share/ksh/functions/_cd
+share/ksh/functions/cd
share/ksh/functions/_ksh_print_help
share/ksh/functions/dirs
share/ksh/functions/man