aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2003-12-15 08:23:29 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2003-12-15 08:23:29 +0000
commitab8dd75a02d8b22665724370140c508712d87d8a (patch)
tree12e176fd495dd479be35a76c0bd2210a423732c7 /shells
parent107029a4b632d126f322755694686dcc15d83290 (diff)
downloadports-ab8dd75a02d8b22665724370140c508712d87d8a.tar.gz
ports-ab8dd75a02d8b22665724370140c508712d87d8a.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash2/Makefile2
-rw-r--r--shells/bash3/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no