aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-11 04:10:38 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-11 04:10:38 +0000
commitc1e99c88eaa99319b694b59564e1520854fc6088 (patch)
treea1f5ace43b9f85f9b1d7f783647688c306891cc6 /shells
parent21c3d713d2988ac1c54baa5213bd78657648c49c (diff)
downloadports-c1e99c88eaa99319b694b59564e1520854fc6088.tar.gz
ports-c1e99c88eaa99319b694b59564e1520854fc6088.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/anongitssh/Makefile37
-rw-r--r--shells/anongitssh/distinfo3
-rw-r--r--shells/anongitssh/pkg-descr6
-rw-r--r--shells/anongitssh/pkg-message2
-rw-r--r--shells/anongitssh/pkg-plist5
6 files changed, 54 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index c3612fe0c48e..363e82ec762e 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -5,6 +5,7 @@
SUBDIR += 44bsd-csh
SUBDIR += ammonite
+ SUBDIR += anongitssh
SUBDIR += antibody
SUBDIR += ast-ksh
SUBDIR += bash
diff --git a/shells/anongitssh/Makefile b/shells/anongitssh/Makefile
new file mode 100644
index 000000000000..1dd8f57e0d47
--- /dev/null
+++ b/shells/anongitssh/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= anongitssh
+PORTVERSION= 0.2
+DISTVERSIONPREFIX= v
+CATEGORIES= shells
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Restricted shell for git-upload-pack over SSH
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= hrs-allbsd
+MAKE_ARGS= MK_INSTALL_AS_USER="yes" BINMODE=0555
+
+README_URL?= https://git.FreeBSD.org/
+REPODIR_PREFIX?= /home/git
+ANONGIT_USER?= anongit
+CONTACT?= git-admin@FreeBSD.org
+GITUPLOADPACK_PATH?= /usr/local/bin/git-upload-pack
+.for D in README_URL REPODIR_PREFIX ANONGIT_USER CONTACT GITUPLOADPACK_PATH
+MAKE_ARGS+= ${D}=\"${$D}\"
+.endfor
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+
+pre-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOCS-on:
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/shells/anongitssh/distinfo b/shells/anongitssh/distinfo
new file mode 100644
index 000000000000..67549e9efb18
--- /dev/null
+++ b/shells/anongitssh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1606451618
+SHA256 (hrs-allbsd-anongitssh-v0.2_GH0.tar.gz) = 339d209c7f7287431c3ecc0e7119c2b871473895f0d761a3e2f8d8715b70db78
+SIZE (hrs-allbsd-anongitssh-v0.2_GH0.tar.gz) = 5225
diff --git a/shells/anongitssh/pkg-descr b/shells/anongitssh/pkg-descr
new file mode 100644
index 000000000000..5a1f3864e9fa
--- /dev/null
+++ b/shells/anongitssh/pkg-descr
@@ -0,0 +1,6 @@
+anongitssh: a restricted shell for git-upload-pack over SSH
+
+Note: The default setting is for git.FreeBSD.org only and needs to be
+ overridden and rebuilt for being useful in other setups.
+
+WWW: https://github.com/hrs-allbsd/anongitssh/
diff --git a/shells/anongitssh/pkg-message b/shells/anongitssh/pkg-message
new file mode 100644
index 000000000000..78ebca975ce1
--- /dev/null
+++ b/shells/anongitssh/pkg-message
@@ -0,0 +1,2 @@
+The default setting is for git.FreeBSD.org only and needs to be
+overridden and rebuilt for being useful in other setups.
diff --git a/shells/anongitssh/pkg-plist b/shells/anongitssh/pkg-plist
new file mode 100644
index 000000000000..b85a46501a88
--- /dev/null
+++ b/shells/anongitssh/pkg-plist
@@ -0,0 +1,5 @@
+@mode 4111
+libexec/anongitssh
+@mode
+share/man/man1/anongitssh.1.gz
+@shell libexec/anongitssh