aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-08-28 09:05:50 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-08-28 09:05:50 +0000
commit72546e991e170be9015639d870c6ac50f6f36d0b (patch)
tree9aa467647ee91da6dc11e833c57c5966f1bccae9 /shells
parent74b1783df5b590dcefcc133db6c069327d6dd82f (diff)
downloadports-72546e991e170be9015639d870c6ac50f6f36d0b.tar.gz
ports-72546e991e170be9015639d870c6ac50f6f36d0b.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bush/Makefile20
-rw-r--r--shells/bush/distinfo4
-rw-r--r--shells/bush/files/patch-configure13
-rw-r--r--shells/bush/files/patch-src::GNUmakefile15
-rw-r--r--shells/bush/files/patch-src::apq-2.1::mysql_incl11
-rw-r--r--shells/bush/files/patch-src_GNUmakefile.diff11
-rw-r--r--shells/bush/pkg-plist5
7 files changed, 32 insertions, 47 deletions
diff --git a/shells/bush/Makefile b/shells/bush/Makefile
index adad5cd4a910..1f600e3743b2 100644
--- a/shells/bush/Makefile
+++ b/shells/bush/Makefile
@@ -6,33 +6,42 @@
#
PORTNAME= bush
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= shells
MASTER_SITES= http://www.pegasoft.ca/downloads/ \
http://66.11.182.223/downloads/
-EXTRACT_SUFX= -src.tgz
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The Business Shell
BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat \
bash:${PORTSDIR}/shells/bash
+
USE_PGSQL= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
-MAKE_ARGS= GMAKE=${GMAKE} CPUTYPE=${CPUTYPE} \
- PTHREAD_LIBS=${PTHREAD_LIBS}
+MAKE_ARGS= GMAKE=${GMAKE} CPUTYPE=${CPUTYPE} PTHREAD_LIBS=${PTHREAD_LIBS} \
+ SDL_CONFIG=${SDL_CONFIG}
MAKEFILE= GNUmakefile
+USE_SDL= sdl image
USE_MYSQL= yes
BROKEN_WITH_MYSQL= 323
USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= bush.1
PORTDOCS= *
-BASH2FIX= examples/benchmark.bash src/testsuite/test.sh
+BASH2FIX= examples/benchmark.bash examples/export.sh src/testsuite/test.sh
+
+post-extract:
+ @${RMDIR} ${WRKSRC}/examples/test
pre-build:
.for FILE in ${BASH2FIX}
@@ -47,6 +56,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.bush ${EXAMPLESDIR}
.endif
post-install:
diff --git a/shells/bush/distinfo b/shells/bush/distinfo
index 76f3ea189566..7ffe17ac2ff2 100644
--- a/shells/bush/distinfo
+++ b/shells/bush/distinfo
@@ -1,2 +1,2 @@
-MD5 (bush-1.0.1-src.tgz) = 34d8d9ceeb002b61976df99e05325d38
-SIZE (bush-1.0.1-src.tgz) = 1355249
+MD5 (bush-1.0.2-src.tgz) = 5d3cb890273fd1f58c0ec28c10a6babe
+SIZE (bush-1.0.2-src.tgz) = 1448691
diff --git a/shells/bush/files/patch-configure b/shells/bush/files/patch-configure
deleted file mode 100644
index 072861b9afb9..000000000000
--- a/shells/bush/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Sat Jan 8 04:24:43 2005
-+++ configure Tue Jan 25 21:06:21 2005
-@@ -174,8 +174,8 @@
- else
- echo "no"
- echo
-- echo "ADAVOX requires /dev/dsp. Create a /dev/dsp symlink to your real audio device"
-- exit 1
-+ echo "ADAVOX requires /dev/dsp."
-+ echo "Note that you should enable /dev/dsp on the machine on which you will install this package."
- fi
-
- echo "ADAVOX library is configured"
diff --git a/shells/bush/files/patch-src::GNUmakefile b/shells/bush/files/patch-src::GNUmakefile
deleted file mode 100644
index 475f014e7283..000000000000
--- a/shells/bush/files/patch-src::GNUmakefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/GNUmakefile.orig Sat Jan 8 04:08:31 2005
-+++ src/GNUmakefile Fri Jan 21 22:52:36 2005
-@@ -5,9 +5,9 @@
- # These are filled in by ./configure. If they are incorrect, change them for
- # your system...
-
--CC=gcc
--CPU=i686
--MAKE=gmake
-+#CC=gcc
-+MAKE=${GMAKE}
-+CPU=${CPUTYPE}
- GNATMAKE=gnatmake
-
- # RPM Directories For Building an RPM file
diff --git a/shells/bush/files/patch-src::apq-2.1::mysql_incl b/shells/bush/files/patch-src::apq-2.1::mysql_incl
deleted file mode 100644
index a8f15af17630..000000000000
--- a/shells/bush/files/patch-src::apq-2.1::mysql_incl
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/apq-2.1/mysql_incl.orig Wed Sep 24 21:56:27 2003
-+++ src/apq-2.1/mysql_incl Fri Jan 21 23:43:18 2005
-@@ -1,7 +1,7 @@
- #
-
- if [ ! -f config.win32 ] ; then
-- echo $(mysql_config --cflags) | sed "s|^.*'\(.*\)'.*$|\1|"
-+ echo $(mysql_config --include) | sed 's|^-I||'
- else
- sed -n '/^MY_UINCL/p' <config.win32 | sed 's|^.*=||;s| *$||'
- fi
diff --git a/shells/bush/files/patch-src_GNUmakefile.diff b/shells/bush/files/patch-src_GNUmakefile.diff
new file mode 100644
index 000000000000..39cc047c09d8
--- /dev/null
+++ b/shells/bush/files/patch-src_GNUmakefile.diff
@@ -0,0 +1,11 @@
+--- src/GNUmakefile.orig.orig Wed Aug 17 22:59:07 2005
++++ src/GNUmakefile.orig Wed Aug 24 23:45:36 2005
+@@ -11,7 +11,7 @@
+ GNATMAKE=gnatmake
+ SDLLIBS=SDLLIBSTYPE
+ SDLINCL=SDLINCLTYPE
+-CFLAGS=CFLAGSTYPE
++CFLAGS+=CFLAGSTYPE
+ # For SDL, sdl_config is not always available.
+
+ # RPM Directories For Building an RPM file
diff --git a/shells/bush/pkg-plist b/shells/bush/pkg-plist
index cfe478c05384..72cbe1cffae5 100644
--- a/shells/bush/pkg-plist
+++ b/shells/bush/pkg-plist
@@ -1,12 +1,13 @@
bin/bush
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
+%%PORTDOCS%%%%EXAMPLESDIR%%/archive.bush
+%%PORTDOCS%%%%EXAMPLESDIR%%/archive.html
%%PORTDOCS%%%%EXAMPLESDIR%%/arrow.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/bats.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/benchdata.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.adb
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bash
-%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bash.bak
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.ksh
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.sh
@@ -62,6 +63,8 @@ bin/bush
%%PORTDOCS%%%%EXAMPLESDIR%%/scripting.c
%%PORTDOCS%%%%EXAMPLESDIR%%/validate_name.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/validate_name.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/web_summary.bush
+%%PORTDOCS%%%%EXAMPLESDIR%%/web_summary.html
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.html