aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2006-04-11 08:12:00 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2006-04-11 08:12:00 +0000
commit36b30af69fddb49dcdb92b2070d7103cea035d91 (patch)
treea1e72dca1198a262a59e6822d0ae58582bc0eb28 /shells
parent2fa9c7d3ff43872b5bd618be19244e9749d063c8 (diff)
downloadports-36b30af69fddb49dcdb92b2070d7103cea035d91.tar.gz
ports-36b30af69fddb49dcdb92b2070d7103cea035d91.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-shell.c47
2 files changed, 48 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 287c36871dbb..2c7f8a728e34 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 2.08b
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/files/patch-shell.c b/shells/fd/files/patch-shell.c
new file mode 100644
index 000000000000..8d79078746b3
--- /dev/null
+++ b/shells/fd/files/patch-shell.c
@@ -0,0 +1,47 @@
+cf. [FDclone-users:00493]
+
+diff -u ../old/FD-2.08b/shell.c ./shell.c
+--- ../old/FD-2.08b/shell.c Thu Mar 30 00:00:00 2006
++++ ./shell.c Mon Apr 10 22:45:35 2006
+@@ -1630,12 +1630,7 @@
+ int i, j, size;
+
+ if (!file || !(fp = Xfopen(file, "r"))) return(-1);
+-#ifndef NOFLOCK
+- if (lockfile(Xfileno(fp), LCK_READ) < 0) {
+- Xfclose(fp);
+- return(-1);
+- }
+-#endif
++ VOID_C lockfile(Xfileno(fp), LCK_READ);
+
+ size = (int)histsize[n];
+ history[n] = (char **)malloc2(sizeof(char *) * (size + 1));
+@@ -1650,7 +1645,7 @@
+ for (j = i; j > 0; j--) history[n][j] = history[n][j - 1];
+ history[n][0] = line;
+ }
+- lockfile(Xfileno(fp), LCK_UNLOCK);
++ VOID_C lockfile(Xfileno(fp), LCK_UNLOCK);
+ Xfclose(fp);
+
+ for (i++; i <= size; i++) history[n][i] = NULL;
+@@ -1684,16 +1679,11 @@
+
+ if (!history[n] || !history[n][0]) return(-1);
+ if (!file || !(fp = Xfopen(file, "w"))) return(-1);
+-#ifndef NOFLOCK
+- if (lockfile(Xfileno(fp), LCK_WRITE) < 0) {
+- Xfclose(fp);
+- return(-1);
+- }
+-#endif
++ VOID_C lockfile(Xfileno(fp), LCK_WRITE);
+
+ size = (savehist > (int)histsize[n]) ? (int)histsize[n] : savehist;
+ for (i = size - 1; i >= 0; i--) convhistory(history[n][i], fp);
+- lockfile(Xfileno(fp), LCK_UNLOCK);
++ VOID_C lockfile(Xfileno(fp), LCK_UNLOCK);
+ Xfclose(fp);
+
+ return(0);