aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-10-28 12:28:24 +0000
committerStefan Eßer <se@FreeBSD.org>2021-10-29 09:50:18 +0000
commit819f25b36d45b8ac5593ec8e6f470d9ad454b08a (patch)
treea9ad0caa2a052fc695c1cdede2866080f5660431 /shells
parentf2b9a177fa65d8010c60d9dd2803a4b4bb9bcec8 (diff)
downloadports-819f25b36d45b8ac5593ec8e6f470d9ad454b08a.tar.gz
ports-819f25b36d45b8ac5593ec8e6f470d9ad454b08a.zip
*/*: Remove redundant '-[0-9]*' from CONFLICTS
The conflict checks compare the patterns first against the package names without version (as reported by "pkg query "%n"), then - if there was no match - agsinst the full package names including the version (as reported by "pkg query "%n-%v"). Many CONFLICTS definitions used patterns like "bash-[0-9]*" to filter for the bash package in any version. But that pattern is functionally identical with just "bash". Approved by: portmgr (blanket)
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile4
-rw-r--r--shells/bashc/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 19c1275f55ab..b6d715274b3b 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -58,9 +58,9 @@ CONFIGURE_ARGS+= --without-bash-malloc \
MAKE_ARGS+= TERMCAP_LIB=-ltinfow
.if empty(PKGNAMESUFFIX)
-CONFLICTS+= bash-static-[0-9]*
+CONFLICTS+= bash-static
.else
-CONFLICTS+= bash-[0-9]*
+CONFLICTS+= bash
.endif
CONFLICTS+= bashc
diff --git a/shells/bashc/Makefile b/shells/bashc/Makefile
index 61bed23d78c9..8074cac5f10f 100644
--- a/shells/bashc/Makefile
+++ b/shells/bashc/Makefile
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+= --disable-rpath \
--with-libiconv-prefix=${ICONV_PREFIX} \
--without-bash-malloc
-CONFLICTS+= bash-[0-9]* bash-static-[0-9]*
+CONFLICTS+= bash bash-static
.include <bsd.port.options.mk>