aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-04-07 20:05:24 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-04-07 20:07:02 +0000
commit2d82d9794002a34abf1774f2d59ab6e8b06e8a5d (patch)
tree2c60f69cc9229413f8ec8be2b276e5ed4de42551 /shells
parent020693c166d18f55c760793095996f470d434474 (diff)
downloadports-2d82d9794002a34abf1774f2d59ab6e8b06e8a5d.tar.gz
ports-2d82d9794002a34abf1774f2d59ab6e8b06e8a5d.zip
Diffstat (limited to 'shells')
-rw-r--r--shells/yash/Makefile11
-rw-r--r--shells/yash/distinfo6
-rw-r--r--shells/yash/files/patch-configure21
3 files changed, 30 insertions, 8 deletions
diff --git a/shells/yash/Makefile b/shells/yash/Makefile
index b97d0908e771..d1b667aee9c1 100644
--- a/shells/yash/Makefile
+++ b/shells/yash/Makefile
@@ -1,7 +1,7 @@
PORTNAME= yash
-DISTVERSION= 2.52
+DISTVERSION= 2.54
CATEGORIES= shells
-MASTER_SITES= OSDN/yash
+MASTER_SITES= https://osdn.net/projects/yash/downloads/78345/
MAINTAINER= naddy@FreeBSD.org
COMMENT= POSIX-compliant command line shell
@@ -10,6 +10,9 @@ WWW= https://yash.osdn.jp/index.html.en
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+# skip interposed HTML page
+FETCH_ARGS= --user-agent=curl/7.68.0
+
USES= tar:xz
HAS_CONFIGURE= yes
@@ -19,9 +22,7 @@ CPPFLAGS+= -std=c99
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext-runtime
+NLS_USES= gettext-runtime localbase:ldflags
NLS_CONFIGURE_ENABLE= nls
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/shells/yash/distinfo b/shells/yash/distinfo
index ec98538202dc..53d3cb31cca6 100644
--- a/shells/yash/distinfo
+++ b/shells/yash/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1646748654
-SHA256 (yash-2.52.tar.xz) = 55137beffd83848805b8cef90c0c6af540744afcc103e1b0f7bdf3ef1991b5c9
-SIZE (yash-2.52.tar.xz) = 755016
+TIMESTAMP = 1680896240
+SHA256 (yash-2.54.tar.xz) = 44a0ac1ccf7c3acecfbea027d8c0c930f13a828065be318055ce113015391839
+SIZE (yash-2.54.tar.xz) = 758916
diff --git a/shells/yash/files/patch-configure b/shells/yash/files/patch-configure
new file mode 100644
index 000000000000..14ac4203f80b
--- /dev/null
+++ b/shells/yash/files/patch-configure
@@ -0,0 +1,21 @@
+https://osdn.net/projects/yash/ticket/47773
+
+--- configure.orig 2023-04-07 19:40:18 UTC
++++ configure
+@@ -746,6 +746,7 @@ END
+ checking "for ${i%:*}"
+ cat >"${tempsrc}" <<END
+ ${confighdefs}
++#include <stdio.h>
+ #if HAVE_CURSES_H
+ #include <curses.h>
+ #elif HAVE_NCURSES_H
+@@ -756,8 +757,6 @@ ${confighdefs}
+ #include <ncursesw/ncurses.h>
+ #endif
+ #include <${i%:*}>
+-int putchar(int);
+-
+ int main(void) {
+ /* Undeclared identifiers are a syntax error in C99, but many compilers assume
+ * implicit declarations when they appear in a function call. We force compilers