aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2011-02-12 21:34:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2011-02-12 21:34:23 +0000
commit9e2ba8ac3146bbc6988f4588c6088b6d797455d0 (patch)
tree99ae916db07195b309ed4b9fbc3cbb5612d1a073 /shells
parent6ff696affb62fa579be6744a928eb4bcfd897230 (diff)
downloadports-9e2ba8ac3146bbc6988f4588c6088b6d797455d0.tar.gz
ports-9e2ba8ac3146bbc6988f4588c6088b6d797455d0.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile9
-rw-r--r--shells/bash-completion/distinfo4
-rw-r--r--shells/bash-completion/files/patch-contrib_portupgrade4
-rw-r--r--shells/bash-completion/files/patch-do_not_hang_on_avahi_daemon21
-rw-r--r--shells/bash-completion/pkg-plist18
5 files changed, 27 insertions, 29 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 30a76582b441..7b3f2584e50e 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bash-completion
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.3
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -26,7 +25,8 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
+ @${ECHO_CMD} You can safely ignore this next error...
+ -@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
s|/usr\(/lib/rpm/macros\)|${PREFIX}\1|g; \
@@ -36,7 +36,8 @@ post-patch:
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
s|\(FLAC\)|\1\|flv\|FLV|' \
- ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
+ ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/completions/* ${WRKSRC}/completions/helpers/*
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/shells/bash-completion/distinfo b/shells/bash-completion/distinfo
index fece586321b8..2c5534c372f2 100644
--- a/shells/bash-completion/distinfo
+++ b/shells/bash-completion/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bash-completion-1.2.tar.bz2) = dd09a86134204e4c6b860bfbd5ee8ac46c6b32a54478b967dcf81e8a7839d354
-SIZE (bash-completion-1.2.tar.bz2) = 197574
+SHA256 (bash-completion-1.3.tar.bz2) = 8ebe30579f0f3e1a521013bcdd183193605dab353d7a244ff2582fb3a36f7bec
+SIZE (bash-completion-1.3.tar.bz2) = 211899
diff --git a/shells/bash-completion/files/patch-contrib_portupgrade b/shells/bash-completion/files/patch-contrib_portupgrade
index caa9b91d5800..f03ddce85f7e 100644
--- a/shells/bash-completion/files/patch-contrib_portupgrade
+++ b/shells/bash-completion/files/patch-contrib_portupgrade
@@ -1,5 +1,5 @@
---- contrib/portupgrade.orig 2010-09-04 02:35:04.000000000 -0400
-+++ contrib/portupgrade 2010-09-04 02:38:00.000000000 -0400
+--- completions/portupgrade.orig 2010-09-04 02:35:04.000000000 -0400
++++ completions/portupgrade 2010-09-04 02:38:00.000000000 -0400
@@ -26,11 +26,7 @@
portsdir=${PORTSDIR:-/usr/ports}/
diff --git a/shells/bash-completion/files/patch-do_not_hang_on_avahi_daemon b/shells/bash-completion/files/patch-do_not_hang_on_avahi_daemon
deleted file mode 100644
index 413fad67b02a..000000000000
--- a/shells/bash-completion/files/patch-do_not_hang_on_avahi_daemon
+++ /dev/null
@@ -1,21 +0,0 @@
-This patch is related to PR ports/150322.
-
-When avahi-daemon is not running, bash-completion will hang for some seconds
-waiting for response from it because of the call to avahi-browse.
-
-The patch was originally obtained in bash-completion's bug tracker, and was
-written by Ville Skyttä.
-
-Reference: https://alioth.debian.org/tracker/?func=detail&atid=413095&aid=312691&group_id=100114
-
---- bash_completion 2010-06-16 12:44:20.000000000 -0300
-+++ bash_completion 2010-11-18 23:33:53.000000000 -0200
-@@ -1315,7 +1315,7 @@
- # avahi's services DB. We don't need the name of the service, and if it
- # contains ";", it may mistify the result. But on Gentoo (at least),
- # -k isn't available (even if mentioned in the manpage), so...
-- if type avahi-browse >&/dev/null; then
-+ if type avahi-browse >&/dev/null && PATH="$PATH:/sbin:/usr/sbin:/usr/local/sbin" avahi-daemon --check &>/dev/null; then
- COMPREPLY=( "${COMPREPLY[@]}" $( \
- compgen -P "$prefix$user" -S "$suffix" -W \
- "$( avahi-browse -cpr _workstation._tcp 2>/dev/null | \
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 5fc2329a0750..16a1b985b764 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -7,6 +7,8 @@ etc/bash_completion.d/apt
etc/bash_completion.d/apt-build
etc/bash_completion.d/aptitude
etc/bash_completion.d/aspell
+etc/bash_completion.d/autoconf
+etc/bash_completion.d/automake
etc/bash_completion.d/autorpm
etc/bash_completion.d/bash-builtins
etc/bash_completion.d/bind-utils
@@ -26,6 +28,7 @@ etc/bash_completion.d/coreutils
etc/bash_completion.d/cowsay
etc/bash_completion.d/cpan2dist
etc/bash_completion.d/cpio
+etc/bash_completion.d/crontab
etc/bash_completion.d/cryptsetup
etc/bash_completion.d/cups
etc/bash_completion.d/cvs
@@ -36,8 +39,11 @@ etc/bash_completion.d/dict
etc/bash_completion.d/dpkg
etc/bash_completion.d/dselect
etc/bash_completion.d/dsniff
+etc/bash_completion.d/dvd+rw-tools
+etc/bash_completion.d/e2fsprogs
etc/bash_completion.d/findutils
etc/bash_completion.d/freeciv
+etc/bash_completion.d/freerdp
etc/bash_completion.d/fuse
etc/bash_completion.d/gcc
etc/bash_completion.d/gcl
@@ -50,12 +56,15 @@ etc/bash_completion.d/gpg
etc/bash_completion.d/gpg2
etc/bash_completion.d/gzip
etc/bash_completion.d/heimdal
+etc/bash_completion.d/helpers/perl
etc/bash_completion.d/hping2
etc/bash_completion.d/iconv
+etc/bash_completion.d/iftop
etc/bash_completion.d/ifupdown
etc/bash_completion.d/imagemagick
etc/bash_completion.d/info
etc/bash_completion.d/ipmitool
+etc/bash_completion.d/iproute2
etc/bash_completion.d/ipsec
etc/bash_completion.d/iptables
etc/bash_completion.d/ipv6calc
@@ -71,6 +80,8 @@ etc/bash_completion.d/lilo
etc/bash_completion.d/links
etc/bash_completion.d/lintian
etc/bash_completion.d/lisp
+etc/bash_completion.d/lrzip
+etc/bash_completion.d/lsof
etc/bash_completion.d/lvm
etc/bash_completion.d/lzma
etc/bash_completion.d/lzop
@@ -97,6 +108,7 @@ etc/bash_completion.d/net-tools
etc/bash_completion.d/nmap
etc/bash_completion.d/ntpdate
etc/bash_completion.d/openldap
+etc/bash_completion.d/open-iscsi
etc/bash_completion.d/openssl
etc/bash_completion.d/p4
etc/bash_completion.d/perl
@@ -130,14 +142,17 @@ etc/bash_completion.d/samba
etc/bash_completion.d/sbcl
etc/bash_completion.d/screen
etc/bash_completion.d/service
+etc/bash_completion.d/sh
etc/bash_completion.d/shadow
etc/bash_completion.d/sitecopy
etc/bash_completion.d/smartctl
etc/bash_completion.d/snownews
+etc/bash_completion.d/sqlite3
etc/bash_completion.d/ssh
etc/bash_completion.d/sshfs
etc/bash_completion.d/strace
etc/bash_completion.d/svk
+etc/bash_completion.d/sysbench
etc/bash_completion.d/sysctl
etc/bash_completion.d/sysv-rc
etc/bash_completion.d/tar
@@ -158,9 +173,12 @@ etc/bash_completion.d/xm
etc/bash_completion.d/xmllint
etc/bash_completion.d/xmlwf
etc/bash_completion.d/xmms
+etc/bash_completion.d/xmodmap
etc/bash_completion.d/xrandr
+etc/bash_completion.d/xrdb
etc/bash_completion.d/xsltproc
etc/bash_completion.d/xz
etc/bash_completion.d/yp-tools
etc/bash_completion.d/yum-arch
+@dirrm etc/bash_completion.d/helpers
@dirrm etc/bash_completion.d