aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2010-09-10 02:30:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2010-09-10 02:30:50 +0000
commit9f82a80526280de1900be9e938dcb75057123268 (patch)
tree153b2430f33f9a0738e446325ba47c67a7973a58 /shells
parentd070333158c29085dee1b281957e0e1ad374719b (diff)
downloadports-9f82a80526280de1900be9e938dcb75057123268.tar.gz
ports-9f82a80526280de1900be9e938dcb75057123268.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile8
-rw-r--r--shells/bash/options6
2 files changed, 12 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 79351c9d7634..77a527e92ce8 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -31,6 +31,12 @@ COMMENT= The GNU Project's Bourne Again SHell
IGNOREFILES= FAQ
+.if defined(WITH_OPTIONS) || defined(WITH_BASH_OPTIONS)
+.include "${.CURDIR}/../bash/options"
+.endif
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_IMPLICITCD)
EXTRA_PATCHES+= ${PATCHDIR}/xpatch-implicitcd
.endif
@@ -96,8 +102,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
YACC="bison -y"
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
.if defined(WITHOUT_NLS)
diff --git a/shells/bash/options b/shells/bash/options
new file mode 100644
index 000000000000..5fb109a83dd5
--- /dev/null
+++ b/shells/bash/options
@@ -0,0 +1,6 @@
+OPTIONS= IMPLICITCD "Use directory name alone to cd into it" on \
+ COLONBREAKSWORDS "Colons break words" on \
+ HELP "Install the help files" on \
+ INST_READL "Use readline from base, otherwise bash's" on \
+ NLS "National Language Support" on \
+ STATIC_BASH "Compile without shared libs" off