aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-08-15 10:10:22 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-08-15 10:10:22 +0000
commit385ae243eb0dfc63c7c7919fd1aae14f6de232bd (patch)
tree16515a8cd8ee5a360e76f395ea489208df294306 /shells
parent0a7455c83ce45910f0ee6965d5db7b95bc54c9db (diff)
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/poshinit/Makefile26
-rw-r--r--shells/poshinit/distinfo3
-rw-r--r--shells/poshinit/pkg-descr16
4 files changed, 46 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index dbb41353e428..aa8e24cd24ad 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -39,6 +39,7 @@
SUBDIR += p5-Term-ShellUI
SUBDIR += pdksh
SUBDIR += pear-PHP_Shell
+ SUBDIR += poshinit
SUBDIR += psh
SUBDIR += rc
SUBDIR += rush
diff --git a/shells/poshinit/Makefile b/shells/poshinit/Makefile
new file mode 100644
index 000000000000..cd537f16c11a
--- /dev/null
+++ b/shells/poshinit/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= poshinit
+PORTVERSION= 1.0
+CATEGORIES= shells
+
+MAINTAINER= bourne.identity@hotmail.com
+COMMENT= Portable shell setup for Bash/Zsh across FreeBSD/Linux/Cygwin
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= bourne-again
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/shells/poshinit/distinfo b/shells/poshinit/distinfo
new file mode 100644
index 000000000000..0c6103e4f58b
--- /dev/null
+++ b/shells/poshinit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542812999
+SHA256 (bourne-again-poshinit-1.0_GH0.tar.gz) = 39b263db0c0ca9682cbe6b71dacb73c9b5bdd3a12aca2698df1f349fe6fee068
+SIZE (bourne-again-poshinit-1.0_GH0.tar.gz) = 11636
diff --git a/shells/poshinit/pkg-descr b/shells/poshinit/pkg-descr
new file mode 100644
index 000000000000..94d1b9d65518
--- /dev/null
+++ b/shells/poshinit/pkg-descr
@@ -0,0 +1,16 @@
+You want your shell stuff to work the same way even when you use a
+different shell, or even a different box. Right?
+
+If you use poshinit (Portable Shell Initialization), you can attain at
+least most of what you desire, perhaps even all. You can log out of Bash
+and log in with Zsh (or vice versa) - and your aliases/exports/functions
+will continue to work as before.
+
+It gets better - if someday you need to use a different box with a
+different OS, you can get your shell to work your 'normal' way in a
+jiffy. Just save your $HOME/.shell directory on your primary box, and
+paste it over your second box's $HOME/.shell (after running poshinit
+setup script on the second box). The second box need not be the same
+operating system - poshinit works across FreeBSD / Linux / Cygwin.
+
+WWW: https://github.com/bourne-again/poshinit